Skip navigation

Unable to sync my iphone with itunes over wi-fi

32041 Views 46 Replies Latest reply: Mar 12, 2014 6:15 PM by Bill2462 RSS
  • Baldwin001 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2011 9:14 PM (in response to Markavo)

    Tried and checked everything mentioned above. Finally, decided to restart the computer. IT WORKED.

  • Ruiner75 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 10:37 AM (in response to sildani)

    sildani wrote:

     

    In my case (iPhone 4, iOS 5.0, iTunes 10, Mac OS X Lion, Airport Wireless Router) I found that turning off my WiFi network adapter on my laptop and turning it back on made iTunes recognize the iPhone over WiFi.

     

    Same thing here on Snow Leopard 10.6.8. Turning off and on WiFi did the trick.

  • wmielke Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2011 3:45 PM (in response to Vvinay)

    VVinay's post was very helpful.  I have had troubles getting the WiFi sync to work reliably.  After much trial and error I have discovered the following for my Windows 7 x64 box:

     

    (1) After checking the items in VVinay's post and rebooting my machine my iPhone 4 running iOS 5 appears to be discovered reliably and I can sync wirelessly.

     

    (2) If I then start up a Windows Virtual PC virtual machine the WiFi sync stops working.

     

    So it appears that Windows Virtual PC interferes with the proper operation of this feature, at least  as of this writing.  USB syncing still works as expected and if you attach the iPhone's USB connection to the virtual machine it works there as well.

     

    Hopefully this will be fixed in a future update and my posting this here might save someone from pulling out too much hair if they too are running virtual machines on their laptops and finding that WiFi sync on the host OS isn't working.  I haven't found a work around for this problem.  If you have please post it here.  Thanks.

  • holmesmd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2011 10:28 AM (in response to Vvinay)

    I have a 4S, Windows 7, 10.5, new Linksys router. Same wonky issues with Wi-Fi synch. It just seems to randomly resolve itself. With all due respect to Vvinay's helpful directions, I don't feel I should have to do a liver transplant's worth of work to get this feature fixed. I paid too much for this stuff not to work as advertised and they need to fix it. What is really bizzare is that my phone appears in iTunes but it is not on the device list in iTunes like it once was?! Can someone explain that?

  • sildani Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2011 10:54 AM (in response to holmesmd)

    Wi-Fi sync doesn't work consistently for me, either. Lots of ideas in this thread, but they are all at best workarounds for deeper issues only Apple can solve.

  • louishermans Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 2, 2011 8:00 AM (in response to Markavo)

    I had the same problem! This seems to have fixed it!

     

    1. Log into your WiFi Router on Internet Explorer.
    2. Write down the Primary DNS of your Router. You should find it on the main page somewhere.
    3. On your iPhone go to Settings.
    4. Go to Wi-Fi
    5. There should be a tick next to the name of your Wi-Fi Router if connected. If not, connect to your Wi-Fi Router.
    6. Once connected, touch the little white/blue arrow pointing right.
    7. Make sure that DNS setting is the same as the one in (2) above!! If not, you can change it by tapping on the field.

     

    I changed mine as it was different and my WiFi synch works perfectly each time. In fact my Laptop even starts iTunes if it is not open and proceeds to synch automatically now!! Your phone must be connected to power & and the WiFi Router obviously!

     

    Let me know!

     

    Louis.

  • berry123 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2011 5:50 PM (in response to Markavo)

    disconnect iphone from itunes , but keep itunes opened

     

    turn off the power of the modem/router for a minute, then turn it back on.

    reconnect iphone wi-fi again (disable, then enable it again)

    open itunes wifi sync tab on iphone and 'sync now' button should be enabled

  • geraldfromkeystone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2011 5:08 AM (in response to Markavo)

    Make sure in Services that Apple Mobile Device is running.

    (Windows)

  • timsteele Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2011 5:42 PM (in response to Markavo)

    I can see my iPhone and iPad in iTunes (when connected to power) and I can initiate a sync on any of the devices.  But it doesn't "just start" automatically like I expect it to (or maybe my expectations are incorrect?).  I've got iTunes running, I plug in my device, it shows up in iTunes - then nothing.  It doesn't start the sync.  Any idea why it shows up and syncs fine but only when I start it manually?

  • usefz89 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2012 10:30 AM (in response to Markavo)

    This is  what make it Works !!!!!!    (geraldfromkeystone)

     

    Make sure in Services that Apple Mobile Device is running.

    (Windows)

  • Jim Warthman Level 1 Level 1 (125 points)
    Currently Being Moderated
    Apr 26, 2012 8:32 PM (in response to usefz89)

    On the Mac, I discovered that IPv6 MUST be enabled in the Network panel of System Preferences.

     

    For me, this alone solved the wi-fi sync problem.

  • richaney Level 1 Level 1 (0 points)

    On my Win7 Home 64 PC, I checked the Apple Mobile Device service (following other's suggestions); and although it was on I restarted it... success!  All devices reappeared in iTunes!

     

    I'm now going to make a Net cmd batch to restart the little blighter next time it plays up.

  • Aunt Deena Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 7, 2012 1:10 AM (in response to Markavo)

    Well, it happens often and, as to me, I don't think it's an issue of Apple, OS or whatever else, rather than a Wi-Fi nowadays technology itself: let's be hones — even though it is popular it is not that good. But, getting back to your question — my solution (the one which works for me) is easy and quite — no hassle with password, nothing...

     

    All you need is to renew lease of your device over the wi-fi network. Go to the Wi-Fi settings, click the blue arrow to get to the settings of the current network and click the renew lease button; launch iTunes — it's there your iDevice.

     

    Personally, I've got two of them — and from time to time I'm renewing the lease — that solves mentioned issue.

     

    With the Kindest Regard,

    Yours Aunt Deena

     

    PS

     

    Will you excuse my English, which is not my native language, and thus has more misstypes and mistakes than it really should.

  • yodamastera Level 1 Level 1 (30 points)
    Currently Being Moderated
    Aug 22, 2012 2:39 PM (in response to Markavo)

    If you use PC with Windows try manually open iTunes and press sync button.

  • Arani2302 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2013 7:34 AM (in response to Vvinay)

    Thank yu for your extreme help.. Worked wonderfully...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.