Skip navigation

http live streaming will not finish segmentation

1690 Views 24 Replies Latest reply: May 22, 2012 12:11 PM by mike_xDUBx RSS
1 2 Previous Next
blacksheep_2011 Calculating status...
Currently Being Moderated
Apr 24, 2012 1:02 AM

Hi,

 

I'm tring to create an http live stream with compressor 4.

The transcoding finish successfully, but the program hangs on the segmentation of the files(95% of the job).

 

It starts to segment the first file but never finish it.

 

Thats the last line of the log:

 

 

<log tms="356944681.796" tmt="04/24/2012 09:18:01.796" pid="12970" msg="done _postProcessRequest for job target: file://localhost/Users/TimIngensiep/Movies/HE-Videos/2010-03-12_ISS-2010/Video/2011-ISS-21-Schulz-Wi-Fi%20(Hoch).mp4"/>
<mrk tms="356944683.346" tmt="04/24/2012 09:18:03.346" pid="12970" kind="end" what="service-request" req-id="EB7885BC-DD92-4F0A-9B5A-A8C9306102BC:5" msg="Postprocessing service request end."></mrk>

 

I hope someone can fix my problem.^^

Compressor, Mac OS X (10.7.3)
  • vp@apple Calculating status...

    I have same issue, exporting directly from FCPX, without Compressor.

    Actually I was hopping that using Compressor will solve the problem, but seems it doesn't, after your posting. FCPX 10.0.3 had no this problem (it had another issue, couldn't re-export a project already exported)

     

    I found out if the project is around 10-12 minutes, than it works, but if it larger, about 20 minutes it doesn't work, it creates just few .ts segments or sometimes none, and is stuck at 95%, always at 95%.

     

    Also, once you get a 95% stuck job, there is no way to successfully export other project, even if it is just 1 minute long. The only way is to stop FCPX, delete preferences files and all generated files, restart computer, all this crap until your Share Monitor shows no running task and the stuck processes are gone.

  • Russ H Level 6 Level 6 (12,945 points)

    I realize others have reported similar issues – here and in the FCX forum. Although I haven't been able to duplicate the problem, it's obviously an issue for some and I'm not saying it's not a possible bug.

     

    Try the usual trouble-shooting steps as outlined here.

     

    Good luck.

     

    Russ

  • Russ H Level 6 Level 6 (12,945 points)

    Yes…completed on Lion.  Perhaps your source file?

     

    Russ

  • Russ H Level 6 Level 6 (12,945 points)

    In the Share Monitor, hit the Inspector icon and you should get a log.

     

    My last test was ten pages.

     

    Russ

  • svanteh Calculating status...
    Currently Being Moderated
    Apr 29, 2012 1:00 AM (in response to Russ H)

    I have the same problem as 'blacksheep_2011' and others. I have tried the trouble-shooting steps you refered to, BUT it doesn't help.

    Prior to version 4.0.3 it worked just fine for me. I have made about 50 batches with the 'HTTP Live Streaming' template. All OK. Since 4.0.3, none has completed. Very frustrating.

    I have Mac Pro 2x2.4 Quad-Core Xeon with 32 GB internal and running 10.7.3.

  • Russ H Level 6 Level 6 (12,945 points)
    Currently Being Moderated
    Apr 29, 2012 7:35 AM (in response to svanteh)

    What OS are you running?

     

    Of the four tests I've run, three were on 10.6 and one on 10.7. (It's easier for me to test on SL.) I've used both SD and HD (Pro Res , XDCAM and h.264) files as source fiiles. I've shared out from FCX and directly from Compressor. Are you submitting to a cluster? One thing I haven't done is tried anything >4 minutes.

     

    It's sounding more and more like an update bug, but I so far I haven't re-created the right conditions.


    Russ

  • Russ H Level 6 Level 6 (12,945 points)

    FWIW, I just did a 13 minute movie directly from Compressor and it completed the entire batch (with all the segments). This was done with 4.0.3 but I will add that it was on my Snow Leopard system, not Lion.

     

    Russ

  • svanteh Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 29, 2012 10:03 AM (in response to Russ H)

    Hi,

     

    I have tested movies as short as < 2 minutes and > 30 minutes. With the same result.It doesn't complete. I have waited more than 24 hours as well.

    I have tried to submit to This Computer, This Computer Plus and a cluster of one Mac Pro and two Mac Mini all running the same OS (10.7.3) and Compressor 4.0.3.

    I have also used FCP X (10.0.4) share option  Export for HTTP Streaming... . Doesn't finnish either.

    Very annoying.

  • Russ H Level 6 Level 6 (12,945 points)
    Currently Being Moderated
    Apr 29, 2012 10:14 AM (in response to svanteh)

    I'll try it on the Lion system tonight and let you know. Just one thought…in Compressor, you have to specify the destination for the job action…in addition to the jobs' destination…otherwise you'll get a fail. Probably not the case here but had to mention it.

     

    Russ

  • vp@apple Level 1 Level 1 (0 points)

    It is definitively a project size issue.

    I have a project about 22 minutes long and is always stuck at 95%, never succeeded to finish export.

    I split it in two smaller projects, one 13 minutes and one 9 with no other changes. I can successfully export both of them to http live streaming.

    This problem is not only with Compressor but also when sharing in FCPX without Compressor.

     

    The source files are AVCHD 1080p from a Canon camcorder on a MBP with latest Lion.

    I think is good you guys fill in some bug reports with Apple. This will help.

  • svanteh Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 30, 2012 2:10 AM (in response to vp@apple)

    Hm...

    It is  not a project issue for me. Have tested a 2 minutes long project; stops around 95% complete.

     

    I will fill in a bug report to Apple.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.