Skip navigation

iPhone 4 iOS 5.1 Battery Drain ... Major progress for me

9107 Views 19 Replies Latest reply: Dec 3, 2012 8:11 AM by FinlandiOs RSS
1 2 Previous Next
shaggy1966 Calculating status...
Currently Being Moderated
Apr 27, 2012 9:55 AM

Me:  I'm a freelance Apple iOS developer.  I have so many iOS devices I can't count them all. 

 

My issue:  My iPhone 4 has worked flawlessly (minus the antenna issue everyone knows about) up until I got iOS 5.0.1...and then worsened with iOS 5.1.

 

My battery life went from "as described" in the product literature to "as described" by all the comlpaints on these boards regarding battery drain (2-4 hours of standby time on full charge, very long charge time).

 

I have 3 batteries for my phone.  All behaved the same.

 

I went through all the incremental steps to nail down the root cause.

 

1. Turn off WiFi

2. Turn off Blue Tooth

3. Turn off personal hot spot

4. Turn off iCloud

5. Deleted every single non-Apple app

6. Remove running apps for memory

7. Reboot

8. Reset all settings

 

Nothing worked....except this:

1. Backup to iTunes

2. Restore to Factory Defaults

3. Restore from Backup

 

FIXED.  Didn't loose any data.

 

Can others confirm?

iPhone 4, iOS 5.1, Battery drain slow charge
  • gdgmacguy Level 6 Level 6 (18,405 points)

    Confirm what?  I have no problems with battery drain.

  • gnrtoney Calculating status...

    I'm trying it now and will let you know how tomrrow goes!

  • SDJasmine Calculating status...

    I have the same issue, suddenly since 2 days ago the battery is draining really fast and the phone is getting super hot. I've tried everything under the book, including the restore, the switiching off notis, push, EVERYTHING, and nothing seems to be working. Is there a way to remove the update? And could that cause further issues? Any help is appreciated!

  • pretysmartchic Calculating status...

    @Shaggy1966

     

    I tried your solution. Just wanted to let you know that it didn't work for me but I really appreciate helpful posts like yours to try to address it.

     

    Recapping the problem I had: I had phenomenal battery life and standby time in iOS 5.0.1.

    After upgrading to 5.1, the battery life plummets by more than half. I am looking for all possible solutions and tried yours. The net-net for me is that I'm using my phone EXACTLY THE SAME WAY after the iOS 5.1 update as I did before and my battery life and phone functionality has plummeted. It's just like when the 4.1 update came out and killed my iphone 3G.

     

    Other things wrong after the 5.1 update: can't use data functions and talk on the phone at the same time easily. Text messages spin constantly and never send if an image is attached.

     

    Tons of suggestions say to "turn off this" and "don't do that" but that hasn't helped either. Even charging is a problem.  Thanks for the help... but I will keep looking or ask a Genius to roll me back.

     

    @gdgmacguy no need to respond here. I've read your recent posts and responses on the matter as well.

  • xtremecarbon Level 4 Level 4 (2,235 points)

    No two devices are the same. What works for you, may not work for soemone else. There are general things that can preserve battery life, which you have already pointed out.

  • pretysmartchic Level 1 Level 1 (0 points)

    I'm using Exchange but I was before. Before I had 3 days of standby with Exchange running. I could charge every other day. Just this morning I'm down to 38% in 2.58 hours. Yikes!

  • Syrus82 Calculating status...

    I had almost the same problem. My batterie drained after 4-5 hours. I removed my Exchange account, and the battery lifetime as amazing. I reseted the network settings, and then reattached my Exchange account. The battery lifetime is still good! So try to reset the network settings and then attatch your email account again, and see what happends.

  • SDJasmine Level 1 Level 1 (0 points)

    I never had an Exchange account. So far I've restored three times, keep WiFi off mostly, have turned off the "push" for every app, reset the network settings and updated to iOS 5.1.1. Also got battery manager, nothing seems to be working

  • MayorMoose Calculating status...

    I am on 5.1.1 I have been having batteriey issues for the last few weeks and I just updated to 5.1.1 yesterday. But today it seems even worse. I had a full charge at 11 and its at 35% at 4 and I haven't really used it at all...

     

    I was also having a problem where my emails were not either marking as read or deleting. I would read an email or even delete it and lock my phone only to return a while later to see that they emails were still there marked as unread. This happened for the first time yesterday. The night before I went to sleep with the app MyPhone+ syncing my facebook contacts to my phone contacts. I woke up and somehow I unplugged the phone and it was dead. I charged it up to fine these issues happening. Updated to 5.1.1 and the battery is even worse than it was two days ago...

     

    I just deleted my exchange accounts and we will see what happens... Will update later.

  • MayorMoose Level 1 Level 1 (0 points)

    UPDATE: So I tried deleting my Exchange mail (but I didn't change my iCloud account) and reset my networks and still same old thing... I charged it for a little and had to run out of the house. The charge was at 57% maybe 10 minutes ago and I took a call for 3 minutes and now I am at 47% and I still cannot delete emails without them showing up again in 20 seconds as a new unread email...  Plus my email screen is saying Connecting... at the bottom ALL THE TIME!!!

  • jak1975 Calculating status...

    I'd like to add that I'm suffering the same issues since upgrading to 5.1.1. I use Hotmail, and whether it's configured as a "hotmail" account or set-up via Exchange the battery life is now horrendous. As soon as I remove the account everything returns to normal.

     

    I've never had any issues like this before 5.1.1

     

    I've tried resetting the phone, adding/removing the account, etc - nothing resolves the issue - apart from removing the account and not adding it back!

  • xtremecarbon Level 4 Level 4 (2,235 points)

    Have you edited the Sync settings for that account? It could be constantly fetching, where your other accounts do not.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.