Skip navigation

Spotlight keeps indexing

11620 Views 9 Replies Latest reply: Mar 17, 2014 7:09 PM by dmrich RSS
TresRoque Level 1 Level 1 (85 points)
Currently Being Moderated
Apr 27, 2012 11:24 AM

I've tried the few solutions in this forum but none work.

 

I can't figure out how to stop Spotlight indexing, as it's been doing it since yesterday.

 

Any tips?

Macbook 2.4Ghz (White) 4GB RAM, Mac OS X (10.6.4), Logic Studio 8, Safari 5.0.2, iLife 08, iWork 08, Aperture 2
  • Gerry Brown Calculating status...
    Currently Being Moderated
    Apr 27, 2012 12:15 PM (in response to TresRoque)

    Try the following:  {This will delete the Spotlight database and tell it to start over}

    1) From the Terminal

         >sudo rm -rf /.Spotlight-V100/*

    2) Reboot

    NOTE: It will take a couple of hours to reindex your hard drive. "Don't Panic"

     

    and if you have any large mounted drives you don't want indexed, in the Spotlight System Preferences, select the Privacy tab and add the volumes you dont want indexed.

  • Gerry Brown Level 3 Level 3 (795 points)
    Currently Being Moderated
    Apr 27, 2012 1:17 PM (in response to TresRoque)

    Umm, sudo reported permission denied?  Spacing is important.

  • Gerry Brown Level 3 Level 3 (795 points)
    Currently Being Moderated
    Apr 27, 2012 4:28 PM (in response to TresRoque)

    Copy and Paste it exactly as it is, minus the ">" character.  I am assuming thatyour account has Admin piveledges, so when it asks foe a password, yours will work.

  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    Apr 27, 2012 4:36 PM (in response to TresRoque)

    Run through this list and get back with me

     

    Step by Step to fix your Mac

  • RyanBoulder Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2012 4:19 AM (in response to TresRoque)

    I had the same problem, but the solutions above (only doing sudo rm -rf /.Spotlight-V100/*) didn't work for me. Then I found this solution, which did work for me:

     

    http://guidovanoorschot.nl/how-to-fix-spotlight-when-it-keeps-indexing-n-mac-os- x-lion/

  • dmrich Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2014 7:09 PM (in response to TresRoque)

    so I've been annoyed to **** with spotlight for the last few weeks, only looking at it on and off. warning this will rebuild spotlight indexes of all drives afaik

     

    Tried and failed:

    system preferences, spotlight, privacy, add and remove the drive

    sudo rm -rf /.Spotlight-V100/

    sudo mdutil -ai off then sudo -ai on

    sudo mdutil -E /

     

    many of these have worked in the past, but osx had me in for some fun

     

    finally after finding nothing, and after all these steps watching spotlight reindex into eternity...

     

    SUCCESS!!!:

     

    dsenableroot (type your admin password then set a root password - note you won't see typing as the pw is hidden)

    logout

    login, select other user

    login as root/the password you just set

    rm -rf /.Spotlight-V100/

    mdutil -ai off

    mdutil -ai on

    mdutil -E /

     

     

    then logout, login as your admin again, open terminal

    sudo dsenableroot -d

    type user pw

    type root pw if needed

     

    spotlight pwned

     

    i know some of these steps are redundant, but might as well blow the #$%&%er away as reliably as possible. SUCH a simple fix can't believe i didn't think of it before. this also isn't the first time i've seen osx need you fully logged in as root to get rid of a strange issue. pfft.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.