7 Replies Latest reply: Apr 27, 2012 4:42 PM by ChrisWluther
ChrisWluther Level 1 Level 1 (0 points)

Hi,

    This is a weird one.. My USB ports will only recognise USB2 devices now and only if they are powered (my back up drive for instance). I've talked to Apple who believe it's the motherboard but shouldn't the ports have failed completely if that's so? Machine is a Macbook Pro 15" Intel Core i5  2.4 GHz running Snow Leopard (tried Lion but lost too many good apps under that system). Also if I unmount my external back up drive, it's not recognised again unless I restart or interrupt power to the external USB 2 drive. Almost like the old serial devices!

Did a total erase and reinstall of Snow Leopard 10.6.8, tried a powered hub and Apple had me do all the usual key combo resets all to no avail so it looks like I'm going to need a muthaboard. It just nags me that it still sees USB 2 only. How can it fail just a bit and then stay that way??

Hope someone can help. Heck, it would be nice just to know I' not the only one who's ever had this happen!

Cheers,

              Chris.


MacBook Pro (15-inch Mid 2010), Mac OS X (10.6.8)
  • 1. Re: My USB ports will only recognise USB2 devices
    Wayne Contello Level 6 Level 6 (13,620 points)

    What devices do you want your machine to recognize?  USB has a limit of 500mA so if your external drive is not powered and it draws too much power the ICs on your motherboard will shut off power to the device until it is unplugged.  Macs only support USB1.1 and 2.0 and will never support 3.0 (at least in my opinion).

  • 2. Re: My USB ports will only recognise USB2 devices
    ds store Level 7 Level 7 (30,305 points)

    will never support 3.0 (at least in my opinion).

     

    They will eventually, they just want to give Thunderbolt a chance.

     

    Apple adopted USB2 a few years later when they were pushing Firewire,  they eventually gave in.

  • 3. Re: My USB ports will only recognise USB2 devices
    ChrisWluther Level 1 Level 1 (0 points)

    I'd like it to see my USB1 flash drives, my ipod nano and the USB to audio jack for my guitar. My Macbook used to handle all these things with no problems then... poof..nothing. Nobody home. Don't understand why it still sees USB 2's.

  • 4. Re: My USB ports will only recognise USB2 devices
    ChrisWluther Level 1 Level 1 (0 points)

    Okay I've got a little more info on this. Basically anything that needs power from the USB ports (even for an LED light) doesn't get recognised. As my USB2 devices (camera, external drive etc.) happen to be powered they work fine. So the problem isn't with the type of USB, it's with the 5v internal power supply to the ports.

    I've seen posts where this has been solved by shutting down, disconnecting the power cord and battery and leaving the machine for a few minutes without power. Apparently it works like a charm.

    Just one problem; on this Macbook Pro the battery is under the casing and has a sticker with dire warnings about removing it! Considering I'm long out of warranty and my only other option is a new muthaboard, I might, with a little encouragement, give it a try. I've already ordered some tri-slot screwdrivers for the screw that hold the battery in so I'm halfway there. Go on, dare me!

  • 5. Re: My USB ports will only recognise USB2 devices
    ChrisWluther Level 1 Level 1 (0 points)

    Well, I disconnected mains power, ran the battery down, disconnected it for half an hour, put it back, charged it up, and, hey presto, no change. Everything's exactly the same. New muthaboard I suppose <sigh>.

  • 6. Re: My USB ports will only recognise USB2 devices
    ds store Level 7 Level 7 (30,305 points)

    You need a powered USB hub.

  • 7. Re: My USB ports will only recognise USB2 devices
    ChrisWluther Level 1 Level 1 (0 points)

    Tried that. Didn't work. However the problem has resolved. I can't say it's fixed, more sort of... unbroke. Bear with me...

    Something posessed me to try a powered hub, as you say, with a flash drive attached. My screen went black the second I plugged it into the computer! I unplugged it from the laptop and the thing started up again. Oh boy. I unplugged the power supply (5v) from the hub then, after a deep breath, plugged the hub into the laptop again. Nothing, as I expected so I unplugged it and got the usual 'device removal' warning on the screen. Errrrm. I okayed the warning then plugged the hub in again. Yes, it had seen it and mounted it before and I'd missed it. This time I watched the flash drive and sure enough the green LED flickered to life.

    Now, I'd been plugging in external drives the other night when the screen died the same way but I thought it was coincidence and didn't make the connection because it didn't happen again. After making exactly the same mistake and crashing the machine tonight, it reversed the problem with the power to the USB port. This makes no sense to me but it's as if the first 'shock' to the port somehow switched of the power supply from the motherboard and then switched it back on after a repeat of the incident tonight. Now the power supply is matched to the hub and it's the same 5v supply that the USB port normally draws from the motherboard so why should this be bad? There has to be a short somewhere in there presumably but it causes no trouble when connected to my MacMini. Strange.

    This has to be one for the little black books. Maybe there's a microelectronics engineer (is that a job description?) out there who will calmly explain why this is completely straightforward and obvious, but I've been using Macs since '92 and can only goggle because I've never seen anything like it. Powered hub killed it. Powered hub fixed it. Wild.