Skip navigation

Java Applets not running

1292 Views 4 Replies Latest reply: Oct 28, 2012 1:48 PM by Sparen RSS
krisdpeterson Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 27, 2012 1:18 PM

Hi,

 

At my work, there is an internal HR website that launches a Java applet, that I need to be able to use.  It used to work fine, but recently suddenly stopped.  (and java is enabled in Safari's preferences).

 

However, two things have changed in that time, and I'm not sure which might be causing the problem.

 

First, I recently did the recent Java system update (something-003) that is supposed to fix the security issue exploited by that recent Mac virus.

 

Second, I followed these instructions:

 

http://support.apple.com/kb/HT1428

 

to change my short user name, because I wanted to make it match the user name on some servers at work I need to ssh into from the terminal window.

 

But for some reason, when I go to the internal HR website, the Java Applet never appears.  I've tried both in Safari and Chrome.  But interestingly, I've noticed that in the Activity Monitor, I can see that the JavaAppletPlugin is running for both Safari and Chrome. 

 

I've already used the disk utility to repair permissions, but that didn't allow me to start the applet. Does anyone have any other ideas?  Do I need to check ownership of any files?  Could my having changed the user name have broken anything?  Also, a lot of file owners are now listed as root (most of the Applications in the Applications folder, are owned by root).  Should I change them to make my user the owner?

 

Or is there a way to uninstall Java so I can try reinstalling it?

 

thanks!

MacBook Pro 15"
  • Linc Davis Level 10 Level 10 (108,150 points)
  • Linc Davis Level 10 Level 10 (108,150 points)
    Currently Being Moderated
    Apr 27, 2012 2:59 PM (in response to krisdpeterson)

    The permissions of your built-in applications appear to be correct.

  • Sparen Calculating status...
    Currently Being Moderated
    Oct 28, 2012 1:48 PM (in response to krisdpeterson)

    As of the latest Java Update/003 Lion update, Java Preferences has been removed from the Utilities Folder.

     

    What should I do now? .html files that have applets embeded in them don't even have the 'missing plug-in' anymore.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.