1 2 Previous Next 23 Replies Latest reply: Oct 13, 2013 11:58 AM by 5happy
rlrear Level 1 Level 1 (0 points)

Why does the default email reader in Mail Preferences keep changing to Outllook after I set it to Mail 5.2 and then close the preference pane?  The Default in Outlook is set as Mail 5.2. 


iMac (24-inch), Mac OS X (10.7.3)
  • 1. Re: Mail will not stay as default email reader
    petermac87 Level 5 Level 5 (4,205 points)

    Uninstall Outlook.

     

    Pete

  • 2. Re: Mail will not stay as default email reader
    rlrear Level 1 Level 1 (0 points)

    Uninstalling is really not an option.   I use Word and Excel to do mail merge for an organization that I am in.   Unfortunately, Word will not use Mail as the email client and Pages and Numbers do not have that capability..   I had no problem when I had to use Entourage.

  • 3. Re: Mail will not stay as default email reader
    Glenn Leblanc Level 5 Level 5 (5,940 points)

    Quit Mail.

    Go to your Home Library folder. It's hidden in Lion. To get to it, from the Finder, select Go while holding the option key down. Your home Library will open in a Finder window. Go to the preference folder and find the com.apple.mail.plist files. Move them to the desktop and restart Mail. New preference files will be created. You will need to recreate your Mail settings. Set your preferences again and see if that works.

  • 4. Re: Mail will not stay as default email reader
    jjpcpanama Level 1 Level 1 (0 points)

    removing the mail.plist file removes all my mail... not what i want to do..

  • 5. Re: Mail will not stay as default email reader
    Glenn Leblanc Level 5 Level 5 (5,940 points)

    Removing the com.apple.mail.plist file does not remove your mail.

    It removes the settings for the Mail application and put them back to default. Account info and messages are stored in your Library folder.

  • 6. Re: Mail will not stay as default email reader
    rlrear Level 1 Level 1 (0 points)

    Removing the Com.apple.mail.plist does not  change the situation.  Neither does removing outlook preferences within the Office 2011 folder or com.microsoft.outllook.plist.  There has to be something else somewhere that is causing this problem.

  • 7. Re: Mail will not stay as default email reader
    Glenn Leblanc Level 5 Level 5 (5,940 points)

    That .plist file is what controls the settings in Mail application. Removing that file will set them back to default. Did you quit Mail before removing the file?

    If the preference settings hold in Mail and shows Mail as the default reader, then it should not open Outlook.

     

    Open Outlook's preferences and under the General Tab, make sure that Outlook is not checked as the default Mail application.

     

    I don't know of any settings in Word to choose an email application. I've tried sending a document from Word and the Mail application opens up with the document.

  • 8. Re: Mail will not stay as default email reader
    jjpcpanama Level 1 Level 1 (0 points)

    I am not using Outlook.  my other mail from another imap account is removed when i remove the mail.plist file.

    I have to add my imap accounts also.  was hoping not to have to do this all over again.

     

    I did try it.  And the same result with the reversion of default email reader to "run a dll as app....  vmware fusion....

  • 9. Re: Mail will not stay as default email reader
    Glenn Leblanc Level 5 Level 5 (5,940 points)

    Are you the OP using 2 user names?

     

    jjpcpanama

    What you are discribing is not a result of removing com.apple.mail.plist file. It does not remove accounts from Mail. If this is what's happening, then you are not in the correct folder.The correct path is:  ~/Library/Preferences/com.apple.mail.plist. That is in your Home Folder. See my first post.

     

    If you are not the orininal poster, please start another question.

  • 10. Re: Mail will not stay as default email reader
    PJ'sPal Level 1 Level 1 (25 points)

    OK. I am having the same problem but with Parallels Desktop installed.

     

    The bigger problem is that without the default email reader set to Apple's Mail.app client, outlook invites received by the Mail.app have their file types changed from .ICS to IFB that iCal cannot use. 

     

    I have not tried Glenn's suggestion yet as I an not sure what settings I will need to recreate just yet.

    I may complain to Parallels Desktop about this as I don't know why Apple's mail client has become changed by this.

  • 11. Re: Mail will not stay as default email reader
    PJ'sPal Level 1 Level 1 (25 points)

    I think Parallels Desktop ver. 7 has caused this problem for me on my Mac Pro.

     

    I have a Macbook with the same MAC OSX 10.6.8 with the same version of the Mail.app and it works fine.

    Mail.App is the default email reader on my MacBook and it can load the .ICS files from invites properly into ICal. 

    In fact, there are only two choices for default readers.

    The Macbook has Parallels Desktop ver. 6 loaded instead of ver. 7. 

     

    However, I just remembered that I have a Mac Mini with the same OSX versions with Parallels Desktop ver. 7 installed.  It's defaullt email reader is properly set to the Mail.App even though there are many other choices provided by Parallels Desktop. 

    This leads me to believe that Mr. Glenn Leblanc is correct in that the Mail.App preference settings are corrupt and need to be rebuilt. 

  • 12. Re: Mail will not stay as default email reader
    LoRob Level 1 Level 1 (10 points)

    This worked for me using Mail 6.2, Mountain Lion 10.8.2 and MS Office 2011.  I couldn't get Mail to stay as the default email program in Mountain Lion. No matter how many times I changed the pref to 'Mail', when I opened the preferences again, it was set to 'Outlook'. Running Disk Utility to repair permissions didn't fix things.  So to fix in ML:

     

    1. Quit Mail

    2. Go to your User folder – Library – Preferences

    3. Delete this file: com.apple.mail.plist.lockfile

    4. Restart

    5. Open Mail

    6. Open 'Preferences – General

    7. Maker sure 'Default email reader is set to 'Mail'

     

    Fixed my problem finally.  Thanks.

  • 13. Re: Mail will not stay as default email reader
    jbwilkinson Level 1 Level 1 (0 points)

    I was having the same problem and LoRob's recommendation fixed it.

  • 14. Re: Mail will not stay as default email reader
    chesters Level 1 Level 1 (0 points)

    I had exactly the same software and problem as LoRob, but my ~/Library/Preferences folder contained NO files with the prefix com.apple.mail.  Where is it hidden?  How is Microsoft overriding it?

1 2 Previous Next