Skip navigation

HT5218: About Safari 5.1.5 for Mac OS X Server v10.6

Learn about About Safari 5.1.5 for Mac OS X Server v10.6

HT5218 Safari versions and Extensions

2078 Views 9 Replies Latest reply: May 1, 2012 12:33 AM by cruisingfeijao RSS
cruisingfeijao Calculating status...
Currently Being Moderated
Apr 28, 2012 12:34 AM

I run OS X Lion 10.7.3 and only ever update my software through Apple Software Update. I kept getting an error message when trying to load Safari Extensions and was told it was a Safari problem.  I now find that I have Safari is 5.1.5 running which appears to be Mac OS X Server v10.6 software NOT LION software. So I've no idea how I got Safari 5.1.5.

 

I tried to trash Safari 5.1.5 so I could load 5.1.4 (for Lion), but get a message that it can't be deleted as OS X needs Safari to run.

I tried to reload Safari without trashing 5.1.5, but get a message that I have a newer version so can't load 5.1.4.

 

Every time I try to load Safari Extensions I get an error message.  Any ideas?

 

Thanks

MacBookAir, Mac OS X (10.6.7)
  • MrHoffman Level 6 Level 6 (11,720 points)
    Currently Being Moderated
    Apr 28, 2012 4:47 AM (in response to cruisingfeijao)

    If your footer is correct, please get your OS X client upgraded to v10.6.8.  (That resolves other issues, like removing Flashback and plugging the Java hole.  I've seen a report here that the Flashback malware tosses Safari errors in certain configurations.)

     

    As for the extensions, what's the error message you're getting?

     

    And if the error is specific to a particular extension, what's the extension that's tossing the error?  (If it's not, then post the extensions you have installed, or alternatively cycle through the installed extensions and disable each one in turn and particularly determine which of the extensions is likely tossing the error.)

     

    I don't know about that Safari version information; that Safari v5.1.5 (7534.55.3) is specific OS X Server.  That version is installed on the local 10.7.3 OS X client system.  Checking a 10.6.8 OS X Server box, I also see v5.1.5 (6534.55.3).  AFAIK, Safari is common to both OS X client and OS X Server.  (Apple'd be in an interesting situation to need two different versions.)

  • MrHoffman Level 6 Level 6 (11,720 points)
    Currently Being Moderated
    Apr 28, 2012 6:37 AM (in response to cruisingfeijao)

    What other extensions and plug-ins are installed?  (Safari itself or some of its extensions apparently occasionally get themselves corrupted.)

     

    I'd suggest a full external disk backup before trying the following.

     

    First, boot the recovery partition and use Disk Utility to verify your disk structures and verify your file protections, and try again.

     

    Failing that, one of the other common suggestions around is to quit Safari, to drag all of your current Safari extensions folder (~/Library/Safari/Extensions/) to the trash or (probably a better approach) rename your existing Extensions folder to something like ~/Library/Safari/Extensions_Corrupt), and reload your extensions.

     

    And if that fails, download and reinstall the 10.7.3 Combo update (the Combo and not the delta update), then run Software Update to see if anything else is missing, and then try the Safari extensions again.  (If something's gotten tangled from attempts to remove and reinstall Safari or such, this can sometimes clear the problem.)

     

    The footer here in the forums is set manually.  It's not an automatic thing.  Rummage around under the "Your Stuff" settings here in the forums, and see what's been established there.

  • MadMacs0 Level 4 Level 4 (3,320 points)
    Currently Being Moderated
    Apr 28, 2012 12:16 PM (in response to cruisingfeijao)

    > I have no idea why the footer says OS X (10.6.7) because when I check 'about this mac' in the Apple menu I'm told I'm running 10.7.3.

     

    Because you have not changed your profile. Click on "Your Stuff" at the top of this page to change it.

  • MadMacs0 Level 4 Level 4 (3,320 points)
    Currently Being Moderated
    Apr 30, 2012 2:42 AM (in response to cruisingfeijao)

    cruisingfeijao wrote:

     

    ~/Library/Safari/Extensions:  The f.older can't be found, and

    The folder "Extensions" can't be opened because you don't have permission to see its contents

    Hold the option key down and select Library from the Finder's "Go" menu. Open the Safari folder and if you see the Extensions folder, hightlight it and choose "Get Info" from the File menu (or type Command-I) then look at the bottom of the window at the Sharing & Permissions: section (make sure the disclosure triangle is pointed down and tell us what it says for Privileges.

     

    Then use Disk Utility to Repair Permissions and see if that is of any help.

  • MadMacs0 Level 4 Level 4 (3,320 points)
    Currently Being Moderated
    Apr 30, 2012 3:14 AM (in response to cruisingfeijao)

    cruisingfeijao wrote:

     

    Okay, did that

     

    (by the way, the EXTENSION Folder has a red circle with a white line through it in the bottom right hand corner.)

    The Permissions read:

    "System: Read & Write"

    "Everyone: No Access"

    That would be your problem. The red circle means it cannot be examined by you, which is born out by the permissions. It should belong to you, not the System.

     

    Let's try this. Highlight the ~/Library/Safari/ directory (folder) and do Get Info on it.

    Click on the padlock at the very bottom of the window and when the dialog opens with your name in it, enter your password.

    Click on the Gear symbol to the left of the padlock and select "Apply to enclosed items".

    Click "OK" in the are you sure dialog.

     

    That should take care of it.

    The Disk Utility Repair Disk Permissions read:

     

    Repairing permissions for “Macintosh HD”

    Group differs on “Library/Java”; should be 0; group is 80.

    Permissions differ on “Library/Java”; should be drwxr-xr-x ; they are drwxrwxr-x .

    Repaired “Library/Java”

    ACL found but not expected on “Library/Extensions”

    Repaired “Library/Extensions”

     

    Permissions repair complete

    That looks OK, but does not appear to have corrected your problem. I don't have a Library/Extensions on this Mac, but it's running Leopard.

     

    It's way past my bed time, so I'm going to have to sign off. If you still have issues I'm sure someone else can take it from here or I'll be back in a few hours.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.