5 Replies Latest reply: Jul 23, 2012 5:03 PM by Urs Gubser
Rob Rocket Level 2 Level 2 (305 points)

Because I have this setup on a production server, and could not figure out to get around it. I just made a new testserver..

 

I have set up a new server with simple services and a couple of test users.

10.7.3 out of the box just filesharing and vpn turned on. Every user can connect and work wonderful, just the users who I want them to work over vpn cannot connect. They see the server, enter their user/pass and get the spinning wheel...

 

Errors in the console (client) are:

 

07.04.12 23:40:20,667 KernelEventAgent: tid 00000000 received event(s) VQ_NOTRESP (1)

07.04.12 23:40:20,810 KernelEventAgent: tid 00000000 received event(s) VQ_NOTRESP (1)

07.04.12 23:40:20,810 KernelEventAgent: tid 00000000 type 'afpfs', mounted on '/Volumes/Server', from 'afp_2vXZnv1B9ldi4gNdmP1I2ExX-1.2e000017', not responding

07.04.12 23:40:20,810 KernelEventAgent: tid 00000000 found 1 filesystem(s) with problem(s)

07.04.12 23:40:21,275 KernelEventAgent: tid 00000000 received event(s) VQ_NOTRESP (1)

07.04.12 23:40:21,414 KernelEventAgent: tid 00000000 received event(s) VQ_NOTRESP (1)

07.04.12 23:40:21,415 KernelEventAgent: tid 00000000 type 'afpfs', mounted on '/Volumes/Server', from 'afp_2vXZnv1B9ldi4gNdmP1I2ExX-1.2e000017', not responding

07.04.12 23:40:21,415 KernelEventAgent: tid 00000000 found 1 filesystem(s) with problem(s)

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  Restoring session /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  get the reconnect token

07.04.12 23:40:21,000 kernel: ASP_TCP Disconnect: triggering reconnect by bumping reconnTrigger from curr value 20 on so 0xffffff803102a368

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect started /Volumes/Server prevTrigger 20 currTrigger 21

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  doing reconnect on /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  posting to KEA EINPROGRESS for /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  Max reconnect time: 60 secs, Connect timeout: 30 secs for /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  connect to the server /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  Logging in with uam 10 /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  Restoring session /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  get the reconnect token

07.04.12 23:40:21,000 kernel: ASP_TCP Disconnect: triggering reconnect by bumping reconnTrigger from curr value 21 on so 0xffffff803102a368

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect started /Volumes/Server prevTrigger 21 currTrigger 22

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  doing reconnect on /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  posting to KEA EINPROGRESS for /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  Max reconnect time: 60 secs, Connect timeout: 30 secs for /Volumes/Server

07.04.12 23:40:21,000 kernel: AFP_VFS afpfs_DoReconnect:  connect to the server /Volumes/Server

 

... and this keeps repeating very fast.

  • 1. Re: No AFP over VPN but AFP over IP yes...
    Rob Rocket Level 2 Level 2 (305 points)

    I am not quit sure if this is a configuration or Apple Fault. I have a lot of other Mac Mini Servers running, from 10.5, 10.6 up to 10.7 and never had this problem. Since they are all basically configured with mostly the same features by myself, I stopped fixing things on this server, which are "not broken"...

     

    In the last 12 hours I have searched the web and read gazillions of posts regarding this problems. And most people come to the conclusio that it is hardware related either a defective cable or HD...

     

    And whats funny, this server was running perfect, I just reorganized the cable mess around it on my customers request... Hmm, I also installed 17.7.3 combo 10 minutes before... one of these...

     

    I'll post back, when I find the fix.

     

    Rob

  • 2. Re: No AFP over VPN but AFP over IP yes...
    dankly Level 1 Level 1 (0 points)

    Im having this happen on my mac mini too...I have no idea what it could be but its messing with movie playback

     

    28/04/12 5:56:33.961 PM KernelEventAgent: tid 00000000 received event(s) VQ_NOTRESP (1)

    28/04/12 5:56:33.962 PM KernelEventAgent: tid 00000000 type 'afpfs', mounted on '/Volumes/Data', from 'afp_1iQZkn1pFlUU0XhLTe0Pyeru-1.2d000003', not responding

    28/04/12 5:56:33.962 PM KernelEventAgent: tid 00000000 found 1 filesystem(s) with problem(s)

    28/04/12 5:56:34.078 PM KernelEventAgent: tid 00000000 received event(s) VQ_NOTRESP (1)

    28/04/12 5:56:34.000 PM kernel: ASP_TCP Disconnect: triggering reconnect by bumping reconnTrigger from curr value 24 on so 0xffffff8015432108

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect started /Volumes/Data prevTrigger 24 currTrigger 25

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect:  doing reconnect on /Volumes/Data

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect:  posting to KEA EINPROGRESS for /Volumes/Data

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect:  Max reconnect time: 30 secs, Connect timeout: 15 secs for /Volumes/Data

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect:  connect to the server /Volumes/Data

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect:  Logging in with uam 13 /Volumes/Data

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect:  Restoring session /Volumes/Data

    28/04/12 5:56:34.000 PM kernel: AFP_VFS afpfs_DoReconnect:  get the reconnect token

  • 3. Re: No AFP over VPN but AFP over IP yes...
    Rob Rocket Level 2 Level 2 (305 points)

    I solved the problem in changing the Ethernet Cable from the server to the switch... I really do not know why this is the case, because I tested this cable on other machines (just for connectivity) and it worked.

     

    One thing I noticed was, that the (broken) cable was not very tight in Mac Minis Ethernet Connector. The new one, sits really tight and maybe the plug and not the cable was the problem.

     

    Anyway, try to recable... In my case it really helped and solved my problem. Every VPN-Client can now work as fine and expected.

     

    Rob

  • 4. Re: No AFP over VPN but AFP over IP yes...
    dankly Level 1 Level 1 (0 points)

    Thanks Rob. Without risking murpheys law and speaking too soon It seems to have worked. Its been a full 10mins, no log and im not getting my original problem which led me here.

    Which was the dropping of a signal from the optical port on the mini. I haven't had the audio fail on this movie yet.

     

    My network is brand new but when you menitioned about the cables it reminded me that I had a scaggy old cat5 cable at the mini end. Also I unmounted the Data volume as it was in my login items to be mounted along with the a storage drive.

    There was no reason to have the Data drive (time cap) mounted all the time.

     

     

    Thanks heaps..

     

    Dan

  • 5. Re: No AFP over VPN but AFP over IP yes...
    Urs Gubser Level 1 Level 1 (0 points)

    Wow!! That's crazy - I have a ReadyNas NV+ running 4.1.9 radiator upgraded today and I upgraded my Mac Pro to Mountain Lion yesterday and guess what I got these disconnect messages. So I figured it must be something with the combo Mountain Lion and ReadyNas NV+ 4.1.9 radiator. I've tried all sorts of Google searches until this post came up. Guess what - I replaced my Ethernet cable (and used a different port on the switch) and now it works! Amazing....