Skip navigation

after pressing 'shift' , mac become really slow!

704 Views 3 Replies Latest reply: Apr 28, 2012 11:36 PM by Rob Crestani RSS
joycecrazy Calculating status...
Currently Being Moderated
Apr 27, 2012 7:44 PM

I realy got crazy on my mac....

 

last year i found that my mac's "shift" key was kept being pressed   

  so i sent it to Apple,and they fixed it

but after about 2 days of normal status,my mac become incredible slow.....

I cant even do my typing normally...

but this time i let a friend of mine to fix it, and he removed the ox system i had,repalced with XP

the XP runs great

but i didn't do much things in XP,cos  i don't like it

so i turn my mac into OS system again

 

then my mac runs normal

but the whole things turned into a tragedy angain after i pressed "shift"

mac become really slow ,and makes out big noise!!!  I couldn't bear it , it's now the worst machine i have

 

is anyone figure out the real problem with my mac?

does it still a hardware mistake with my "shift key"  ?  i would be really appreciate if u can solve my problem!!

MacBook Air, Mac OS X (10.6.5)
  • Rob Crestani Calculating status...
    Currently Being Moderated
    Apr 27, 2012 11:33 PM (in response to joycecrazy)

    Hi Joyce,

    The connection between pressing the "shift" key and the overall slow-down problem (and strange beeps) sounds like it might be related to the Universal Access system preference.  Check the keyboard tab of Universal Access in the System Preferences.... there are features here to make using the keyboard easier for those people with limited mobility. These features can get in the way and make using the keyboard difficult for people without mobility issues.

    Check that the  "on/off" control for something called "Sticky Keys" is OFF; that the checkbox to enable "sticky keys" by repeatedly pressing the SHIFT key is not checked; and finally that the "Slow Keys" on/off control is OFF.  This last one sounds very much like what you may be experiencing -- Slow Keys inserts a delay between each and every keystroke. If this is on, it adds a horribly long delay between pressing the key and having something happen.

     

    Hope this helps!

     

    Regards,

    Rob

  • Rob Crestani Level 1 Level 1 (105 points)
    Currently Being Moderated
    Apr 28, 2012 11:36 PM (in response to joycecrazy)

    You should update to the latest version of Snow Leopard (it is now at version 10.6.8) and see if this helps. This will also install a number of security updates to help protect you from potential viruses.

     

    The few other things I can suggest to try are:

    1) checking the hard disk by running "Verify Disk" in the Disk Utility program (see the Apple KB article at http://support.apple.com/kb/HT1782 for instructions)

    2) check and repair file access privileges (see Apple kb article http://support.apple.com/kb/HT1452)

    3) make sure the Startup Disk System Preference shows the Macbook Air's hard disk is selected.

     

    Sorry I have no experience with Chinese input on the mac, however I did find this website http://www.yale.edu/chinesemac that may further help. Good luck!

     

    Rob

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.