Skip navigation

Cannot connect to sever web sites.

816 Views 7 Replies Latest reply: May 8, 2012 9:49 PM by Jimbooooooo RSS
Jimbooooooo Calculating status...
Currently Being Moderated
Apr 28, 2012 11:18 AM

I am running multiple services with the latest version of OS X 10.6 Server on my MacMini (web, mail, ichat, address book, etc.) . When I try to open my websites I get an "unable to find sever message". Everything has been working fine for the last 2 years and no changes have been made to the server settings, ISP, or DNS. All other services are working as they should. The server is hooked up to an Airport Extreme via a cable modem with a static IP. I have tried the following thus far:

1) restarted the server, airport extreme, and cable modem

2) checked the DNS via the web and my site addresses are pointing to my static IP address

3) turned Web services off and on again in Server Admin

4) checked the Airport port mapping to make sure Web Service (Port 80) was still open

 

Any idea what's causing the problem???

 

Thank you.

Mac mini, Mac OS X (10.6.7), Server
  • gracoat Level 3 Level 3 (645 points)
    Currently Being Moderated
    Apr 29, 2012 7:10 AM (in response to Jimbooooooo)

    Try the obvious...

    Check and double check that all your cables are plugged in and seated properly.

    Verify your DNS.  In terminal, type:

     

    changeip -checkhostname

     

    It should tell you that there's nothing to change.

    Are there any notes in the server log that indicate that the server is even being reached? 

    Is this server reachable from the outside world normally?  If so, have you had someone else try to reach it unsuccessfully?

     

    Are you using an SSL certificate for the site, and is it still current?

  • gracoat Level 3 Level 3 (645 points)
    Currently Being Moderated
    Apr 29, 2012 9:20 AM (in response to Jimbooooooo)

    Apr 29 11:38:49 xxxxxx-corp org.apache.httpd[47667]: SSLCertificateKeyFile: file '/etc/certificates/xxxxxx-corp.com xxxxxxxxxxxxxxxxC96C30F1986D48D59D227F1.key.pem' does not exist or is empty

    There lies the problem.

    In server admin, select the site in question.

    Click on the security tab.

    Make sure "enable SSL" is checked.

    Select the new certificate that you installed recently.

    Save and exit server admin.

     

    In the terminal type

    sudo apachectl graceful

    type your password

     

    See if it works now.

    HTH

    -Graham

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.