Skip navigation

2.7 GHz Dual CPU PPC G5 Startup Problems

1718 Views 7 Replies Latest reply: May 12, 2012 12:40 PM by BDAqua RSS
Bill Strohm Level 3 Level 3 (555 points)
Currently Being Moderated
Apr 28, 2012 4:42 PM

New, ongoing problems with my Early 2005 G5 (typing this on my old G3):  Boot process suddenly no workee. If I reset the PMU, and then reset PRAM, it will boot normally. But attempt to restart or reboot subsequently will result in (a) black screen, (b) Apple logo but no "rotating gear," or (c) random boot success but a cursor freeze very soon after.  DIY troubleshooting:  1) Running Apple Hardware Test from Mac OS X v 10.4 installation disc indicates a failure of the CPU "B" AD7417, Ref Desig AD1. (Temperature of CPU B displays as -35.7°C using Marcel Bresink's "Hardware Monitor." CPU A indicates an expected temperature of 50°C at idle.) This has been the case since 2010, but computer has always acted normally until about a week ago.  2) Running TechTool Pro v 4.1.3 from second internal HD on primary shows no failures during any test.  3) Running Disk Warrior v 3.0.3 showed no problems.  4) Same startup failures occur when the Tiger installation disc is selected as the startup disc.  5) Once the system fails to boot, attempting startup without resetting PMU (i.e. attempting to reset only the PRAM first) will not produce a second chime, although I get the first chime. PRAM battery (3.6 volt Lithium) measures 3.68 volts out of circuit and is only about 1 year old.  6) Took the G5 to the local Apple Genius bar, where they kept it for about 4 days and reported that the "ASD" (Apple System Diagnostics) procedure recommended to replace the CPU assembly ("or if that didn't work to replace the Logic Board"). I found that "diagnosis" unhelpful and retrieved my G5 from them not repaired ($900+ for CPU assembly or $900+ for Logic Board).  7) When I overhauled the LCS back in October 2009, I had observed thermal grease had leaked through to the PPC970 CPU chips from the heat sink interfaces on both CPU A and B. However the computer had worked fine for the last 3 years with that condition present. As a precaution against possibility that the new start-up problems were being caused by this, I have just pulled the CPU/LCS assembly from the G5, removed both CPUs from the LCS, cleaned and re-greased the PPC970 chips and re-installed the CPU assemblies. There was no change in the boot failure symptoms. There has been no coolant leakage and CPU A temperature looks normal.  Questions:  Could the AD7417 Analog Devices sensor have anything to do with this booting problem? (Can't see how since it didn't do anything before now.) Is it possible the Power Management Unit (Mitsubishi M16C/62F) ROM is at fault? Any guesses as to any particular components or component types that might be bad ( i.e. maybe electrolytic capacitors, etc)?  Thanks for reading!

PowerMac Dual 2.7 GHz G5, Mac OS X (10.4.11), Desktop G3 (1997) upgraded CPU, RAM, Hard Disks
  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    Apr 28, 2012 5:06 PM (in response to Bill Strohm)

    I'd try turning off CPU1

     

    You might try this in Terminal or Single User Mode if you don't have CHUD tools...

     

    sudo nvram boot-args="cpus=1"

     

    The cpus boot argument can range from 1 up to the total number of processor cores on your system.

     

    http://developer.apple.com/mac/library/qa/qa2001/qa1141.html

     

    And thanks to old comm guy...

     

    This can also be done in open firmware as well (boot with cmd-option-O-F held down.

     

    setenv boot-args cpus=1

    reset-all

  • Heikki Lindholm Calculating status...
    Currently Being Moderated
    Apr 29, 2012 2:45 AM (in response to Bill Strohm)

    I've just spent fighting the exact same boot symptoms + almost immediate (few minutes usually) crashing when booted into Leopard for some days. It could be the CPUs, but I'd place my bets on the well-known logic board BGA solder issue. I had an original 2003 G5 logic board and a June 2004 G5 tower to play with. I've run tests on the CPUs for hours and they don't crash, but the logic board test as well as anything in the OS that transfers lots of data through the U3 chip quickly end up in a lockup. For some people, the hair dryer trick (google it) helps, but it doesn't fix anything really.

     

    The discouraging fact is that I think most of these logic boards are starting to be in the same condition; they just can't take years of power on-off heating/cooling cycles. The best replacement part would probably come from a machine that has had very little use or been running 24/7.

     

    btw. AFAIK the 2.7 GHz model can't boot up with one CPU only.

  • Heikki Lindholm Level 1 Level 1 (135 points)
    Currently Being Moderated
    May 1, 2012 11:26 AM (in response to Bill Strohm)

    Most probably the solder issue happens in the U3 system controller which is situated on the backside of the logic board, with a large heatsink assembly. They should have cooled it better. Even on 2 GHz machines it heated up to 80 C quite easily. There's an IBM document [1] boasting how well they designed the thermal pumping endurance of the CPUs (also BGAs) - I don't know whether they applied that bit of engineering to the U3 controller as well..

     

    With the older G5 generation as well as the latest one, it's possible to run the machine with only one CPU attached, and see whether it's one the CPUs that's starting to give up. I don't think the 2.7 model will start up like that, unfortunately.

     

    You could fire up the OF test from the ASD CD and let it run the logic board test (select individual tests) for like 50 runs (loop count) or so and see if it locks up. The problem with the CD is that the fans go full rpm, making the cooling much better than during boot up or in the OS. One of my broken logic boards hung up during the ASD test deterministically and the other only in the OS or during boot up.

     

    You could also loop the CPU tests from the ASD, but they don't seem to be a stress test, but rather just test computational correctness. Looping them probably won't put much heat load on the CPUs. If you can boot into OS, using some small stress test that fits in the CPU cache (small ffts etc..) could be used to verify the CPUs. The ASD memory test should be ok to test the memory buses, but those also go through the U3 chip.

     

    [1] https://www-01.ibm.com/chips/techlib/techlib.nsf/techdocs/59BEA03A4FA9E41787256F D600710800/$file/BGA%20Solution%20for%20G5.pdf

  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    May 12, 2012 12:40 PM (in response to Bill Strohm)

    Great to hear it's working for you, thanks for the report.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.