Skip navigation

Slow copy speeds to USB in Lion

65136 Views 96 Replies Latest reply: Oct 29, 2013 8:57 PM by Patrick Kinsella RSS
  • jur9en Calculating status...
    Currently Being Moderated
    Mar 2, 2012 3:59 AM (in response to petyusa)

    >I hope this helps.

     

    No, unfortunately it doesn't.

     

    For the tests I did I used just one folder containing JPG's, copying this from HDD to USB-key.

    I did the tests a second time after I reset the PRAM, reset the SMC, rebooted and turned off all non-relevant memory resident software. Exactly the same result (even a little bit slower).

     

    This is a structural OSX Lion bug.

    I gave up hope waiting for a solution. Because I think Apple is more interested in trying to sell me the next IOS device than fixing their buggy software for which they've already received my cash.

  • petyusa Calculating status...
    Currently Being Moderated
    Mar 2, 2012 5:46 AM (in response to jur9en)

    I'm sorry to hear this, man, one more thing to try - even though this really should NOT be a poblem in 2012, but hey, what can we do - anyways, try a USB connector with not one but 2 USB connections. I know this is crap, and we are all supposed to use out devices as we paid for them, but give it a go, like I said, these steps helped me. My iMac is from 2007, pretty much one of the first Intel ones (can you believe I found it in a used shop for 200 bucks in London, the guy genuinely thought he was selling an old screen.). With Lion and only on 2GBs of RAM it runs like a dream, and I do pro cartoon films on it, so obvi an external HDD and easy accessiblity are equally essential. I wish I could  help more, one more thing - I swear Apple product are best from the 2006-2007 era, their popularity was due to real, unespected ease for creative people. I agree, these days Apple is just another Microsoft. My laptop is a 2007 Macbook, as well, and I am not planning on up(?)grading.

  • cgwen Calculating status...
    Currently Being Moderated
    Mar 23, 2012 7:05 AM (in response to petyusa)

    same issue here, have OS 10.7.3 (macbook pro) and get a usb transfer of a few kb per second most of the time (but at other times it works fine). What I notice though is that my mac is indexing the external hard drive that I try to copy from.

     

    Could that be the issue?

  • lxboston Calculating status...
    Currently Being Moderated
    Apr 2, 2012 3:43 AM (in response to ritchiefromnottingham)

    I am having the same issue on a brand new MacBook Air.

     

    Only got this a week ago and the USB transfer is really slow.

     

    What is the deal?

  • Robert_L. Calculating status...
    Currently Being Moderated
    Apr 3, 2012 3:54 PM (in response to lxboston)

    Same thing for me. Copies to a USB stick on Lion is very slow. It is  ^$^%#  ridiculous. 

     

    Any know if Apple has any idea why this is so and/or any fixes.

     

    I have a 64G USB stick - big deal - can't copy anything of any size to it.

     

    Nuts! 

     

    Regards - Robert

  • enryfox Calculating status...
    Currently Being Moderated
    Apr 8, 2012 1:28 AM (in response to ritchiefromnottingham)

    I think the issue is not related to hardware, but to the fat32 kernel driver: i have several USB drives formatted in either HFS+ or NTFS (using Paragon driver) and they are as fast as they should be. I also have an 8 Gb kingston pendrive and it was working fine until i had to format it to FAT32: using this file system really slowed down transfer speed to 1/4 of what it used to be. Once again is not a hardware problems, it is just badly written software (and my bet goes to the stock FAT32 kernel driver).

     

    bye   

  • Mitchell Sefton Level 1 Level 1 (25 points)
    Currently Being Moderated
    Apr 8, 2012 7:12 AM (in response to enryfox)

    I have tried various formats on USB drives and on my iMac, they seem to make no difference.

     

    In fact, if anything, formatting a USB drive as a FAT32 partition seems to make the copy speeds marginally faster.

     

    I have also formatted a USB drive as a FAT32 in a PVR and at work on a Windows 7 PC and, again, it makes no difference to the copy speed - ie - still really slow.

     

    I'm unfamiliar with a 3rd party formatter like Paragon but will try and see if that works.

     

    Thanks.

  • coocooforcocoapuffs Level 3 Level 3 (845 points)
    Currently Being Moderated
    Apr 8, 2012 9:44 AM (in response to jur9en)

    Namaste Jur9en! Where r u... I'm in Dhobighat

     

    Anyway, I have Sansdisk Cruzers of various sizes and they all act the same on all versions of Lion: fast enough reading but 10x slower writing, making the sticks all rather useless. So not sure if it's hardware, software or a combo of both...

     

    Cheers,

    coocoo aka jiggy in Republica every other friday (tech talk)

  • ncalsurfer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2012 11:27 AM (in response to enryfox)

    I think is something here to the Fat32 issue. In fact, I think its related to a software update for both Snow Leopard and Lion. When I first encountered the problem on my Lion MBP, I went back to original Lion release - clean install. USB speeds were fine. However after applying all updates speeds were slow again. I also tried clean install and then using migration assistant to put all my stuff on clean install. Slow down also occurred after this migration.

     

    Is there someway to test differetn Fat32 drivers (kexts?) to see if that is the issue??? Any expert response would be appreciated.

     

    Thank you!

  • astrinormann Calculating status...
    Currently Being Moderated
    Apr 9, 2012 4:11 AM (in response to ritchiefromnottingham)

    Same problem. Brand new MacBook Air, Lion 10.7.3 (updated, not clean installed).

    SanDisk 32 GB flash drive.

    Formatted as FAT32 originally, but I tried different formats after I discovered the bad speeds.

    Makes no difference what format I use, but I have only formatted using DiskUtility.

    Will try formatting using Windows when I get to my Windows laptop.

     

    20 to 25 minutes transferring one 6 GB file. Ridicolous!

  • Jugney Calculating status...
    Currently Being Moderated
    Apr 25, 2012 6:46 AM (in response to astrinormann)

    I wonder if you're on to something - as to whether the FAT32 drive was formatted with Disk Utility on Mac or on Windows.

     

    I have an 8GB Kindston key that has been horrendously slow. Not the whole time it's been FAT32, so I can't quite pin down when it started.

     

    But I plugged in a Sandisk SD card via a USB adapter, which is formatted FAT32, and that runs just fine. It was formatted inside my camera.

     

    So I'm also going to try re-formatting my USB key in Windows to see if that makes it work normally again.

  • Jugney Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 25, 2012 7:20 AM (in response to Jugney)

    Update - After using the built-in formatting in Windows XP, still in FAT32, it is now running about 8x faster! Though still not as fast as my SD card via USB adapter - which could just be due to the difference in transfer technologies and inherent speed limits between those devices.

  • Sid1356 Calculating status...
    Currently Being Moderated
    Apr 29, 2012 10:13 PM (in response to Jugney)

    Doesnt work.

     

    I think this has more to do with different USB Drives as well. I used a 3 year old Kingston 8 GB drive today and ZIPPING speeds while copying on to the drive .. !! I have not seen such speeds before ... on the other hand ... I have an HP 16GB thumb drive ... it does not seem to work on ANY of my Macs. I have Macbook Pro, Macbook, iMac 27" and Mac Pro ... all on Snow Leopard 10.6.8.1 ......

     

    There is definitely something VERY crazy going on ... why doesnt APPLE reply to such threads?????

     

    My HP 16GB drive has been working fine up till some time now ... It now takes 4 - 5 minutes to copy 130 MB?? Horrible ... the same took less than 20 seconds to copy on to my Kingston

  • dudleyneal Calculating status...
    Currently Being Moderated
    May 1, 2012 8:46 PM (in response to ritchiefromnottingham)

    Yep same issue here. Terribly slow speeds. Seems to be tranferring at origainal USB speed of 12Mbps.

  • pancrazio Calculating status...
    Currently Being Moderated
    May 15, 2012 6:44 AM (in response to ritchiefromnottingham)

    same problem. Used an external 20gb hard disk and a sync app to sync my imac at work and my mac book air at home. Then I got a 64gb usb stick and takes over 15 min to copy 4.7gb - something must be wrong. However, I upgraded to lion so I have no way to tell if Leopard would have been faster.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.