Skip navigation

Safari has problems on Youtube.

1073 Views 12 Replies Latest reply: Apr 29, 2012 11:55 PM by 2point5 RSS
macjsus Calculating status...
Currently Being Moderated
Feb 16, 2012 12:47 PM

Latetly Safari has been crashing alot on Youtube. Also it has problems loading the video description. It only loads half the description text. In addition, I have to randomly moving the mouse over it reeals links as though it were masked. I don't have this problem with other browsers so what is going on. 

 

 

 

Here is a screen shot:

 

/___sbsstatic___/migration-images/176/17612518-1.png

 

Here is a screen Shot of FIrefox on the same Page:

 

/___sbsstatic___/migration-images/176/17612518-2.png

Mac OS X (10.6.3)
  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Feb 16, 2012 3:36 PM (in response to macjsus)

    Hnmm, not sure at this point. I guess you could start by checking for Software Updates, and empty the Safari cache.

  • Carolyn Samit Level 10 Level 10 (84,445 points)
    Currently Being Moderated
    Feb 16, 2012 3:41 PM (in response to macjsus)

    Since it effects both browsers and most YouTube content requires the Flash plugin, try uninstalling your current copy of Flash, then reinstall new  >  Troubleshoot Flash Player | Mac OS

     

    For Safari ...   Make sure and quit Safari before reinstalling the plugin. Once it's reinstalled, launch Safari.

     

    From the Safari menu bar click Safari > Empty Cache

     

    Then try a video.

  • Carolyn Samit Level 10 Level 10 (84,445 points)
    Currently Being Moderated
    Feb 16, 2012 4:33 PM (in response to macjsus)

    Worth giving it a try 

  • NastyNickPee Calculating status...
    Currently Being Moderated
    Feb 21, 2012 6:53 PM (in response to macjsus)

    Same problem here, for at least the last month or two. Tried clearing cache, updating flash, trashing Safari preferences. No dice. Seems like it started around the time that YouTube changed its layout design. Can only see top half of video descriptions. Links appear if I wave cursor around, still no normal text shows. I produce video content that I post on YouTube & it scares me that Safari users will never see my notes & descriptions. Gonna' have to try to convice everyone to use Firefox, I guess.

  • jimthing Level 1 Level 1 (50 points)
    Currently Being Moderated
    Apr 29, 2012 11:07 PM (in response to macjsus)

    This is still happening.

     

    I've had this Youtube bug in Safari since Jan 2012, and here about to enter May with it still happening!

    I've reported bug several times to YT and Apple, yet nothing has been done in nearly FOUR MONTHS.

     

    So annoying having to continualy use cmd+A or rolling over the text with mouse pointer, in order to see decription details each time.

     

    Really unimpressed with YT & Apple's response here (I suggest it's YT more than Apple, but who really knows?!).

  • 2point5 Level 3 Level 3 (955 points)
    Currently Being Moderated
    Apr 29, 2012 11:39 PM (in response to macjsus)

    For what it is worth I have been having the same issues with Safari not playing the game with YouTube videos whereas Firefox works perfectly.  Very frustratiing.  I'm running Lion - 10.7.3

     

    The solution I have found, just a short while ago, was to remove the Flash Plugin altogether.  Now YouTube videos play perfectly in Safari (Ie, no black screen) despite the fact that YouTube advises that I should install the Flash Player plugin when I go to the home screen.

     

    The other benefit (real or perceived) is that my MacBook is now running a little better too.  Make of that what you will.

     

    Chrispy

  • jimthing Level 1 Level 1 (50 points)
    Currently Being Moderated
    Apr 29, 2012 11:53 PM (in response to 2point5)

    Sorry but that's not the issue we're all talking about in this thread.

     

    It's the *description text* underneath the videos that's not displaying properly (see the first post pictures).

     

    The videos all play fine whether using Flash or HTML 5 versions.

    (although there is yet another occasional bug, where the preview you get when mousing over the timeline fails to hide when removing your mouse pointer from it — but that's a whole other story!)

  • 2point5 Level 3 Level 3 (955 points)
    Currently Being Moderated
    Apr 29, 2012 11:55 PM (in response to macjsus)

    OK my apologies.

    I should add that I have the Perian 1.2.3 plugin which supports Flash and I'll be sticking with that for the time being.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.