Skip navigation

Mac OS 9.1 - forgot password - reset

2467 Views 4 Replies Latest reply: Apr 30, 2012 2:00 PM by alkla RSS
alkla Calculating status...
Currently Being Moderated
Apr 30, 2012 12:21 AM

I would like to know how to access my OS 9.1 so that I can reset my forgotten admin password.

 

I do not have the startup disk but I can follow directions to reset the computer manually if someone can provide semi-detailed directions for me.

 

I read somewhere that the first step is to restart my computer while holding down the command key and the 's'. I tried this but I am getting a message that says 'there is not enough virtual memory to load with extentions enabled', or something like that, and it continues to another window where I have to either enter the owner's password (the one I don't remember) or shut down.

 

Alternatively, if a manual restart is not possible, I can download the startup disk if there is a working link someone can provide? That would be great too.

 

Thanks, alkla

PowerBook, Mac OS 9.1.x
  • Don Archibald Level 10 Level 10 (101,125 points)
    Currently Being Moderated
    Apr 30, 2012 1:37 AM (in response to alkla)

    Does the password request appear before the OS has started to load, i.e. before the "Welcome" screen appears?

  • Don Archibald Level 10 Level 10 (101,125 points)
    Currently Being Moderated
    Apr 30, 2012 5:46 AM (in response to alkla)

    Okay.

     

    The first one is probably a firmware password, and is more difficult to remove since it is hardware-based.

     

    The second one, after the OS gas started to load, is probably a Multiple Users password. It's fairly easy to fix since it is software based.

     

    You will need a bootable CD, one appropriate for that machine model. It need not be an OS install CD, thuogh that is best; it can be a utility CD, such as one for DiskWarrior or TechTool. If you happen to have a bootable external hard drive, that will work also.

     

    Boot to the CD. Do not run any installer or other program on the CD - you just need to boot to it. The purpose is to get the machine booted to a volume other than the volume with the OS that needs fixing.

     

    Once the machine is booted to the CD, open the System Folder on the internal drive. In that, open the Preferences folder. In that, look for a file named Multi-User Prefs. Drag it to the Trash. Empty the Trash.

     

    Then do a normal restart. All Multiple User passowrds and requests for same should now be gone.

     

    *****

     

    Not sure what the command you mention, Control-S or Command-S, is supposed to do. I'm not familiar with that for OS 9, and I know just about all OS 9 commands.

     

    *****

     

    Your comment about getting a message stating

     

      ...there is not enough virtual memory to load with extentions enabled...

     

    is a bit curious. A message such as that usually indicates that the hard drive is too full, and/or Virtual Memory has been set too high.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.