Skip navigation

Magic trackpad hangs on user switching

5136 Views 34 Replies Latest reply: Oct 4, 2012 6:18 AM by r.gaufman RSS
  • benderj Calculating status...
    Currently Being Moderated
    Apr 11, 2012 12:08 PM (in response to Ralph Davies)

    I also experience this problem. For now, I am trying the workaround supplied by bripab007. Will report later on.

  • benderj Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 17, 2012 12:50 PM (in response to benderj)

    Nope, doesn't fix it for me.

     

    On a side note, I do notice the same message in the system.log every time this happens:

     

    hidd[41]: setting surface orientation to 0 returned 0xE00002C2

     

    Anyone recognize this?

  • benderj Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 17, 2012 1:05 PM (in response to benderj)

    Additional information:

     

    I'm experiencing this problem not exactly during user switching as I have only one user: me.

    I experience this problem when I return to the login window and then try to log back in. Usually it hangs after i've let it sit in the login window for a while e.g. overnight.

     

    This is really frustrating.

  • Brian.Black Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 19, 2012 10:02 AM (in response to benderj)

    Interesting error code you found. I'll have to look and see if my logs report that one as well.

     

    And I, too, can confirm that even with only using a single user account, eventually the problem crops up at the login screen.'

     

    One thing I seem to notice is that the problem is greatly exacerbated by 3rd-party Mac App Store apps. I would be greatly curious if you would try installing a Mac App Store app, like, say Twitter or something, leave it running and see if the problem rears its head even faster/more frequently. If I leave Twitterrific or Sparrow mail app up and running and switch to my wife's account, I can reproduce the problem after just one or two account switches.

  • TWH3 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Apr 29, 2012 1:03 PM (in response to Brian.Black)

    Yep this thread describe the exact issue that I have recently started to experience.

     

    it ony started happening the other day. I'm the admin account and my wife has another account. We switch accounts frequently.

     

    'Tis really getting on my wick.

     

    Interesting few comments made about 3rd Party MAS apps - The Twitter app has recently been doing funny things with scrolling ie not scrolling with my Trackpad. I'll try uninstalling that and see how I get on.

  • Brian.Black Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 29, 2012 1:36 PM (in response to TWH3)

    Yeah, that's exactly the behavior I've noticed in conjunction with the TrackPad problem. I've seen it with Twitter, Twitteriffic and Sparrow. Probably plenty of others, too, if I tried.

     

    This behavior (scrolling/not scrolling or not refreshing/repainting the screen until you minimize/maximize the app) occasionally shows up in iPhoto, too. This often signals an impending OS-wide TrackPad issue requiring a reboot.

  • TWH3 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Apr 30, 2012 12:42 AM (in response to Brian.Black)

    But odd that it's only started happening relatively recently. I don't think the Twitter app has had a recent update.

     

    Hmm...

  • TWH3 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Apr 30, 2012 10:56 AM (in response to TWH3)

    I've not yet launched Twitter since my latest reboot, but I think I have found a possible culprit. If the app is running when I switch users the trackpad stops working.

     

    And the app in question...

     

    ...the new Skydrive app from those that are no strangers to system freezes and driver issues, why it's Microsoft.

     

    Godda love em.

  • Brian.Black Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 30, 2012 11:03 AM (in response to TWH3)

    Yeah, it's not just the Microsoft app; I've been able to replicate it with at least three or four other apps.

  • TWH3 Level 2 Level 2 (470 points)
    Currently Being Moderated
    Apr 30, 2012 11:28 AM (in response to Brian.Black)

    I know, the MSFT dig was just too easy ;)

  • Varkias42 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 14, 2012 6:24 AM (in response to TWH3)

    I'm having the same issue.

     

    It's clearly to do with login/logout and user switching. It doesn't seem affected by other running apps, I use twitter but my wife doesn't and if she turns on the computer in the morning, then I login to my account the issue still happens.

     

    Also, everything was fine on my system before the 10.7.4 update. Started instantly after software update finished, and now won't go away. Happens every time I login/out or switch users. Most of the time the trackpad will recover after a minute or two, but sometimes it locks up and requires a reboot.

     

    Anyhelp would be great! Super PIA.

  • jpr76 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 17, 2012 8:27 AM (in response to Varkias42)

    I think I have the same issue and I too think it is related to the latest software update.  Anyone found a fix?

  • Varkias42 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 27, 2012 5:30 PM (in response to jpr76)

    Kind of. I just restarted my computer a number of times, and for some crazy reason the problem went away. I wish I had a better answer then that, but I've been unable to recreate the issue since about 48 hours after my above post.

  • eeancr Calculating status...
    Currently Being Moderated
    Jun 8, 2012 11:13 AM (in response to Ralph Davies)

    Also having this exact same problem. After switching between user accounts, the Magic Trackpad will not move the cursor, but it will click. Running Lion 10.7.4. Tried de-selecting "allow bluetooth devices to wake this computer" in the second user account, while keeping it in the admin account, but that didn't solve the problem. Powering the trackpad off and back on makes it work again. It's not a battery issue.

  • bripab007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 15, 2012 1:43 PM (in response to eeancr)

    You need to de-select that "allow devices to wake computer" option in Bluetooth settings in both accounts you're switching between.

     

    It won't completely eliminate the problem, but it will make it happen far less often.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.