Skip navigation

Aperture is not displaying some images quoting 'unsupported file format'.

388 Views 7 Replies Latest reply: Apr 30, 2012 11:42 AM by léonie RSS
Matt Evs Calculating status...
Currently Being Moderated
Apr 29, 2012 1:00 PM

I have tried to update, reboot, restart aperture, reprocess, move files and viewed the file in finder which is still not responsive. They are from a Nikon D3100 which has been working fine, even images from the same imort have worked correctly but the majority of them have not.I have successfully imported other files since without a problem, I see there have been some issues with people and tried some of the methods mentioned, anyone with some help there?

Aperture 3, iOS 5.1
  • léonie Level 8 Level 8 (46,760 points)

    Matt,

    we need some more information, please. Otherwise we only can speculate.

    • What is the image format? Raw, jpeg?
    • The version of Aperture? Your MacOS version? What kind of Mac?
    • Is your Aperture Library referenced or managed? Is the Library on the system volume or on an external drive?

     

    and viewed the file in finder which is still not responsive.

    This I do not understand: Could you open the images in the Finder or in Preview or not? What do you mean by "still not responsive"? Did you crash the Finder by trying to open the images?

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,760 points)

    No apologies necessary, Matt.

    Do the Raw files in the Master Folder have an adequate file size or are they too small? Have you compared the other file infos? Permissions, kinds, if they are plausible? If the files do look o.k., I'd try the Aperture Library First Aid: Repair Permissions and Repair Database.

    See this Support Article:

    Aperture 3: Troubleshooting Basics: http://support.apple.com/kb/HT3805

     

    Post back, if the repair does not help.

     

    Regards

    Léonie

  • Ronda Wilson Level 8 Level 8 (40,570 points)

    Please pardon the intrusion…

    Hi,  Léonie!

    Congratulations on advancing to Level 6!

    At the Water Cooler in the Level 6+ Lounge, we are throwing virtual confetti in celebration of your attainment of Level 6-dom. Would you care to join us at the Water Cooler?

    Towards the bottom of the index on the Apple Support Communities Home Page you soon will find the Lounge link available to you. It should work for you within the next 24 hours if all goes as it should.

    Hope to see you there soon!

  • léonie Level 8 Level 8 (46,760 points)

    Thank you so much Ronda, for the congrats and the kind invitation!

     

    I am looking forward to meeting you all there soon, and I certainly will join you there once I can get away from work. Is there anything I need to be aware of when attending the lounge? Netiquette rules, dress code - is it a virtual black-tie affair, or do I have to bring a virtual pot luck ?

     

     

    Cheers

    Léonie

  • léonie Level 8 Level 8 (46,760 points)

    You could try to copy the image files out of the Aperture library package to a folder outside Aperture and then try again to open them? If they will open there, I'd delete them from the library, then rebuild the library again, and then reimport the images.

     

    If you cannot open them ooutside Aperture, look if you have a backup and try to restore them from your backup your master image files.

     

     

    Sorry for coming back to you so late, but today has been a very busy day!

     

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.