7 Replies Latest reply: May 6, 2012 11:31 AM by Ralph Johns (UK)
R Knight Level 1 Level 1 (5 points)

Let me start with that I totally understand Messages is in beta but I'm hoping someone will have a suggestion.

 

In our office we use Bonjour chat extensively for inner-office chat and file sharing. Most of our workstations are still on Snow Leopard few on Leopard and one is on Lion running iChat 6 and 2 MacBooks Pros have the Messages Beta on Lion. The ones with Messages are having sporadic issues with receiving new chat messages. When it does not work, the sender gets the error "The instant messaging connection failed. The other person's computer may be unreachable."  This is from iChat to Messages, or Messages to Messages. (Please note, things like iMessage and Google Talk are working fine for these Lion/Messages Beta systems, the issue is isolated to Bonjour chat.)

 

Now if the person with Messages starts the Bonjour chat to person with iChat it will work fine and then a back and forth chat session will work fine. Message to Message is pretty much broke.

 

Occasionally I get a firewall access dialogue for "imagent" wanting Firewall access and I always click Allow, but seems to do little help. If I disable the OSX Firewall completely (through the GUI) on any system with Messages and the problem will resolve itself.

 

As another troubleshoot I tried leaving the Firewall on, Messages on but logged off of Bonjour and have Adium on and logged in into Bonjour and everything works great.

 

So I can narrow down the issue to Messages, with Bonjour chat and the Firewall. It seems to me Message isn't telling Bonjour to open the right ports.

 

Any suggestions anyone can give will be greatly appreciated. Thanks so much!

  • 1. Re: Messages Beta and problems with Bonjour Chat
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    This may seem strange but add  Public DNS server  to the System Preferences > Network > Advanced Button > DNS tab.

     

    In fact if this shows the greyed out DNS server info from the router then add these manually as well (it may list the router's IP which is not required)

     

     


    10:04 PM      Tuesday; May 1, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 2. Re: Messages Beta and problems with Bonjour Chat
    R Knight Level 1 Level 1 (5 points)

    Ralph, thank you for your quick response.

     

    Okay hopefully I understood you correctly that you wanted me to manually enter the public DNS server we are using (which is provided by our ISP). Originally there was the greyed-out router's IP which you mentioned and I know is normal. Unfortunately that did not work. I tried a few combinations of manually putting in the public DNS with manually putting in the router IP as well, or just the public DNS by themselves and even tried Open DNS just for kicks. And for good measure I flushed the DNS cache, disconnected from WiFi and closed and reopened Messages every time I made a change. And to no avail none of it work.

     

    Maybe I did something wrong, I'm sure! If you or anyone else has any more suggestions - I'm all ears (so to speak). Thanks again Ralph!

  • 3. Re: Messages Beta and problems with Bonjour Chat
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    HI,

     

    Your ISPs DNS servers may or may not be Pubilc DNS servers.

     

    Google run some Public DNS servers (I normally port 8.8.8.8 and 8.8.4.4)

     

    There is a collection  listed here

     

    It does seem that in some cases ISPs DNS servers are limited to what and where they can resolve names.

     

    However OpenDNS would be another option which you seem to have undertaken.

     

    At this point I would try deleting the com.apple.ichat.Subnet.plist

    And restarting Messages or iChat.

     

    In Lion you will have to use the Finder > Go Menu > hold ALT key and Select the Library when it appears > then go to Preferences

    ON other OS version it is in ~/Library/Preferences

    Just drag the file to the Trash.
    Restart iChat/Messages as stated.

     

    Messages still uses the iChat.plists  (it really is iChat version 6.1 in effect).

     

     


    8:00 PM      Wednesday; May 2, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 4. Re: Messages Beta and problems with Bonjour Chat
    R Knight Level 1 Level 1 (5 points)

    Thanks again Ralph.

     

    As per your suggestion I did delete just the subnet plist file and still nothing. I then tried to blow out all the plist files and still nothing. I even created a brand-new user name and still nothing.

     

    I have to admit I think I found a bug here, 3 different systems have this problem of not being able to receive a new message invite when the firewall is active. For the sake of troubleshooting I took one of the 3 systems (my MacBook Pro) and tried a few things, your DNS and subnet plist. suggestions included, at my house (a totally separate network from my offices at work) and still having the same issue.

     

    To add another troubleshooting thing to the list, on my personal system I uninstalled the Messages Beta, effectively putting it back to good ole' iChat 6 and the problem resolved itself immediately. I then reinstalled the Messages Beta again, and bam! back to the same problem.

     

    There's got to be something with Messages and Bonjour with the firewall thats creating this problem because on every system that has this issue I see in the Console's Firewall log this message over and over again once a new message is sent to the system:

     

    Firewall: Deny imagent connecting from 172.16.1.110:49396 to port 49169 proto=6

     

    And for one last troubleshoot I tried and brand new install of Lion (fully updated), installed the Messages Beta in that system and for a little all seemed to work fine, then out of no where (say 10 or so IM invites and few hours later) the problem shows up on that system with the same exact Console error.

     

    I don't know if you've got any more suggestions for this thing, but I'm at a loss. I wish there was a way to pass this along to Apple. I can't see this being all that isolated to me with 3 different systems, 2 networks and an additional new Lion install.

     

    Anyway thanks again for your suggestions. Hopefully this will get fixed! ;-)

  • 5. Re: Messages Beta and problems with Bonjour Chat
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    HI,

     

    Can you double the chances of the engineers seeing this by also reporting your findings here

    http://www.apple.com/feedback/ichat.html

     

    Messages is in fact iChat+ and Messages is identified as version 6.1

     

    The drop downs for iChat version and OS version have been out of step most of the time since iChat 4 was the main version.  Just type the info on Versions in the free text area.

     

    The fact that this Bonjour file Sharing seems to not be on an expected port is a bit concerning.

     

    The original set of Ports are listed here or rather the set for iChat 3 and upwards

    At note 2 at the bottom it lists the "Local" ports

    Port 5353 is the everyday Bonjour port used by the Finder to find other Bonjour computers or devices.

    This leaves port 5197 and 5298 for Texting and File transfers

    If it follows the AIM model, the UDP 5298  would seem to be the most likely port File transfers are supposed to be on.

    (It is known that A/V chats use the same port whichever Buddy List starts them - 5678 for invites then 16402 for everything else in iChat 4 and above)

     

    Is IMAgent listed in the  Firewall ?

    System Preferences

     

     

    (Messages should also be allowed.)

     

    The other thing about the error message is that the port also seems to want to change as part of the process.

     

     


    9:30 PM      Saturday; May 5, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 6. Re: Messages Beta and problems with Bonjour Chat
    R Knight Level 1 Level 1 (5 points)

    Ralph,

     

    Thanks again for responding. I did as you said and posted my issue in the iChat feedback section clearly pointing out it was in reference to the Messages Beta. Hopefully this will get some eyeballs on it, if this is a real bug I hope its resolved before Message goes primetime with Mountain Lion.

     

    imagent and Messages have been allowed in the Firewall from day one, I guess I should have mentioned that before. ;-)

     

    I too found it odd how the port numbers change, it seems its a different set being used on every (failed) attempt. One last thing you may find of interest. Below is the error the "sending" computer gets when it cannot send the IM invite to the system with Messages (10.6.8, iChat 6):

     

    - iChatAgent[194] [Warning] XMLStream: error Error Domain=NSPOSIXErrorDomain Code=60 "The operation couldn’t be completed. Operation timed out" occurred on input

     

    - iChatAgent[194] [Warning] JConnection: Error: Error Domain=NSPOSIXErrorDomain Code=60 "The operation couldn’t be completed. Operation timed out"

     

    Anyway, thanks again for your help. I'll keep a look-out for anything else.

  • 7. Re: Messages Beta and problems with Bonjour Chat
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    I had an System Preferences pane add-on that always wanted me to allow it in the Mac Firewall.

    This even crossed over to my iMac in Lion when I migrated the apps from a Leopard computer.

     

    The "Fix" was to remove it from the allowed List and then re-add it again.

     

    IMAgent is found in your Hard Drive(Name)/System/Library/PrivateFrameworks/IMCore.framework

     

    You could try "resetting" the firewall on the receiving computers.

     

     


    7:32 PM      Sunday; May 6, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously