Skip navigation

Timeline Disappeared

17969 Views 57 Replies Latest reply: Jan 12, 2014 5:03 PM by FabioPOBrazil RSS
1 2 3 4 Previous Next
YahYah24 Level 1 Level 1 (10 points)
Currently Being Moderated
Apr 17, 2012 2:46 PM

Well.  I'm not sure what I did but my timeline has simply disappeared from my project.  And now I have discovered I cannot see the timeline for any of my other projects on this disk, either.  And some of these other projects have been finalized, made into movies, and have been aired... so they were stable and fully functional.

 

What I was doing when this disaster happened:

 

1.  I was working with keywords in the event browser.

2. I closed out keywords because I was done

3.  There was a project open the whole time I was keywording.  It had a 1 minute spacer/gap at the very start of it, and then a purple title tile right after. 

4.  The spacer/gap was far too long so I grabbed it from the right side, pulled it to the left and got back to, maybe, 40 seconds, then the whole timeline area went gray.  Completely gray.  The whole thing is a light shade of gray.  There is nothing in it.  It is just one single gray area now.   My mouse was moving right along and then suddenly everything on that timeline disappeared and now it's just one big gray empty space.

 

I can't find any help on this on the internet, anywhere, so I'm hoping it's because it's a very simple fix - or - I'm not looking up the problem with the correct words.

 

 

Help?

 

 

I have rebooted the app 3 times.   I have shut it down, ejected the disks, plugged them back in and turned FCPX back on, but nothing has helped so far.

 

Thanks so much

 

Kat

MacBook Pro, Mac OS X (10.6.8), 8gig memory
  • Tom Wolsky Level 10 Level 10 (104,615 points)
    Currently Being Moderated
    Apr 17, 2012 3:05 PM (in response to YahYah24)

    Can you post some screen shots of your timeline?

  • fox_m Level 4 Level 4 (3,335 points)
    Currently Being Moderated
    Apr 17, 2012 3:16 PM (in response to YahYah24)

    did you try to Window > Revert to Original Layout ?

  • Tom Wolsky Level 10 Level 10 (104,615 points)
    Currently Being Moderated
    Apr 17, 2012 4:31 PM (in response to YahYah24)

    Did you trash your prefs?

  • terrapin86 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 23, 2012 10:02 AM (in response to YahYah24)

    I have had (EXACTLY) the same problem for about a week now. My timline in one project turned completely grey and I have not been able to open it since. I can open the timeline for other projects if I do not open the damaged project first, but if I go into the damaged project then try to open a different one afterwards, then none of the timelines for any of my projects work. I can play the damaged project by selecting it in the projects window and hitting the space bar, but it plays with no sound (the sound still works on my other projects, just not the damaged one).

    I have trashed my preferences, I have relinked files, I have restarted the program and my computer several times, all with no result.

    I am curious, what happened when you deleated the project and started over? I am hesitant to do this just because I don't want to spend another 3 months on a project only to have it disapear. If anyone knows what is happening and how to fix it, any help would be appreciated.

  • Norman Jayo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2012 8:15 PM (in response to YahYah24)

    I have had the same problem for the last four days. My timeline and timeline index vanished when I simply tried to alter the time of an audio clip. Once I got into the problem, I realized that the timeline data was there, even after the timeline and it's index had vanished. I was able to use the right arrow (player controls) to move along to each element in the invisible timeline and see the related data in the info window.  I could even select all clips and see that the info window was now showing multiple values: meaning the data was there, but something was hanging the timeline up.

     

    I also saw that if I opened another project after after being in the one with the corrupted timeline that newly opened project had a vanished timeline as well. The Timeline Index was, however, still visible in the newly opened project. If I quit and re-started FCPX those newly open projects moved back to normal mode with timeline and index operating normally.

     

    Next Step: I created a new project. I went back to the corrupted project, right arrowed from element to element selecting one at a time. Then I touch the “transforming/resizing” tool to ensure the clip was active. I copied the clip, closed the corrupted project, opened the new holding project and pasted that clip in.

     

    I could not see the timeline, but I expected that. I could, however, see the timeline index. The clip was there. I knew that if I closed and restarted the app without going into the corrupted timeline project the chances were good for the timeline, index and clip would be visible. It was.

     

    It was clear that the corruption was a bug somewhere the the project file. I had a choice to call for support or do the work around and rebuild the timeline one-clip-at-a-time. With over 130 elements (audio, video, text, and hold (freeze frames, butting up the the key video clips) I saw that the the amount of time was going to be a long long time. I tried to select all the clips in the corrupted project. That was successful, but when trying to paste them into the new project the App would crash. Too much for our spinning ball editor.

     

    IMPORTANT SIDEBAR

     

    I dreaded having to call the Pro Apps people, usually in Austin, because I had been getting this corporate (Adobe/Microsoft/WallStreet) kind of response:

     

    “We see your 90 day phone support has run out. We can send you an emil about what to do or you can pay $99 to talk with us on the phone or pay $700+ for a years of phone support.

     

    I would tell them that when I crossed over from FCP 7 Legacy and we (people who edit and make video/films for a living) were all worried about this app because we couldn’t import any of the old work, etc.. We all know the fear and contradictions over FCPX. I explained that when I talked to an Apple Pro App person, when I was deciding to invest in the new version, I asked him, “Was Apple going to stand by us if we crossed over from legacy, since there were bound to be bugs — we all knew that when we first started with Final Cut Pro version 1. This advisor said yes. He never said, We will help you for 90 days after that you have to pay or you are on your own — even if it is our inevitable bug. The Pro App Advisor I talked to in Austin said “Who told you that Apple would support you? I want to read what he said in your records. Give me the case number!”

     

    I said “You won’t find that in my records. This was a good faith recommendation by an Apple Rep who understood there were going to be bugs. The Pro App guy cut me off and said we have already spent too much time talking. Do you want me to sign you up for $99 or do you want the annual support...?”

     

    I said, “This is very unfair. This is a bug in the software. You should be supporting professional users trying to help you debug the software. After it gets back to the solid stability of Legacy, charging money after 90 days is fair, but this software is is not working right.

     

    He said, “There is nothing wrong with FCPX. I use it all the time and have never had a problem. I am thinking — this guy is making home movies. I said, “Do you read anything on the internet from professional users having problems. Again, he said “There is nothing wrong with FCPX. I’ve been a filmmaker for 17 years. All problems are 3rd Party related. 

     

    There wasn’t much left to say. We you know this type of discussion.

     

    I contacted people in Customer relations  determined to ensure this issue finds it’s way to policy people at Apple HQ in Cupertino on the loop. These community relations people got it. They know that as Apple grows there are signs of people who are more predatory in nature, seeking money over the equity of the principle that users should not pay to debug a product, especially one we make our living’s on. Especially, since we were taking a step to support Apple FCPX and not heading straight to Premiere or Avid.

     

    After establishing a honest point with the Community Relations people I contacted a Pro App person who had a realistic perspectives of the first generation flaws of FCPX and together we found a work around that demonstrated that it was in fact a bug.

     

    All of this has been documented (pro app advisors names and comments, etc..) because this policy issues has to be dealt with — connecting good people in Apple with users who care about the future of Apple.

     

    END SIDEBAR

     

    Here is the work around.

     

    1. Close the project that is corrupted and make sure it is highlighted in the Project Library.
    2. Go to File/Export XML and save that file.
    3. Re-import that file, generating a new project.
    4. Close and Restart the FCPX App.
    5. STAY AWAY FROM THE PROJECT FILE WITH THE CORRUPTED TIMELINE.
    6. Open the newly project created via the XML import.
    7. Everything should be there and working fine.

     

    The application code has to be debugged. I have sent the corrupted project file to be added with the Advisor’s note to be sent to the proper people in Apple.

     

    To revoke any argument from the Pro App people in Austin — that this problem was being cause by some 3rd Party App, or something wrong with my drives or computer, I built a new drive (in my Mac Pro Bay 1) with Lion 10.7.3. I did not install or use any other potential influencing elements of hardware of software  —testing the bug hypothesis on the start up drive alone.

     

    The hypothesis that the app is buggy related to the timeline (not to mention the dozens of other issues we have all faced) is correct. I also went back and repeated the work-around process on external drives connected via Firewire 400/800 and eSata. The same work-around was successful.

     

    Finally, if you attempt this work-around and it resolves the problem, in the short term, please note for other users your opinion with regard to the attitude that FCPX is already working fine and that we should be paying $99 per issue or $700+ to get support for problems that are based in this new and unstable version of Final Cut Pro X.

     

     

    Rio

  • fronzey Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 1, 2012 11:31 AM (in response to Norman Jayo)

    Norman Jayo (or is it Rio?),

     

    Thanks for posting the work around! I encountered this problem today for the first time and was very happy to find this thread. Here are a couple things to note, however:

     

    1. COLOR BALANCE AND SHAPE MASK LOSS -- If you use the above work around, and you have any shape masks with color corrections on them (or any color corrections, it seems) you will probably have to redo them.
    2. NO AUDIO ON FINAL EXPORT -- I'm not 100% sure it's related, but I just tried exporting my movie to Quicktime (Share > Export Media...) and when the final output movie is generated, the sound is missing. Given that this only happens when I export this project (and not other, never-corrupted-before projects), I'm pretty sure this has something to do with the above workaround. And yes, I did choose "Video and Audio" from the export menu (not "Video Only"). Yes, my speakers are on, etc. etc. I also tried exporting JUST the audio and got a silent audio file.

     

    Has anyone else experienced the audio problem in their export, and have you figured out what to do?

  • Norman Jayo Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 1, 2012 12:14 PM (in response to fronzey)

    Fronzy,

     

    I can see the loss of the color balance and shape mask. That loss is part of the bug. Still, that allows for a level of project recovery that is a lot easier than loosing everything. 

     

    I have had the audio problem you speak of, but not in the context of a vanishing timeline and recovering most of the project elelments via XML export and re-import.

     

    Try this: Create a new project (this will be pristine and nbot carrying the bug that crept into the original project). Now got back to the original project where you lost your audio — I am assuming audio playback within this project timeline still works and that it is only on export that the audio is lost. Copy the audio and paste it into the new project, go to share and export.

     

    Rio

  • fronzey Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 1, 2012 12:54 PM (in response to Norman Jayo)

    Thanks Rio, I will try that when I get the chance. You are correct that audio within the project timeline still works, but not on export. When you say to "copy the audio and paste it into the new project" I am guessing I will need to separate out the audio from all video/audio clips so that the audio appears as separate green waveforms? Also, I think you meant to imply that the new project should contain the rendered video I just exported? If so, is that going to double-encode it as H.264? I do not have Compressor right now so I would prefer to do this all in Final Cut without lossy double-encoding.

  • Norman Jayo Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 1, 2012 3:55 PM (in response to fronzey)

    I was saying highligh all and copy everything - rendering is your choice. You can always re-render if the specs are there. I am not sure what is triggering the bug. I was just trying to save the core elements thast were lost in the vanisged timeline.

     

    I am not using audio from any of the cameras. I have synced to external recordings viaa clap-board. I am going to take a quick look right now and see if the camera's audio is still there after I copied everything to the new project....

     

    Yes, the audio is still attached — though down at -96db —  and still plays back, so the work around should get you back to a timeline. 

     

    I am using 442 (HQ) on the export, as I am justing taking the clips over to Motion to add some stuff.

     

    Good Luck Fronzy

  • fronzey Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 3, 2012 10:16 AM (in response to Norman Jayo)

    Thanks so much Rio, your suggestion worked like a charm. Audio is being exported properly now.

  • tomatms Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 7, 2012 2:52 PM (in response to YahYah24)

    This has happened to me about four times and three of those times I was able to get it back through a trashing of preferences and then a re-start, but this time it took Norman's solution. One thing that seems to be common for me in having this happen is I am trying to add a gap at the end of the timeline in an effort to seperate two quotes or another section of the video. The screen blips and I am sent to gray timelineland.

     

    A fix is necessary.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.