Skip navigation

Home Sharing Stops Working After a Few Minutes

35164 Views 85 Replies Latest reply: Oct 18, 2013 11:56 PM by JohnStewart RSS
  • chiploi Calculating status...
    Currently Being Moderated
    Apr 18, 2012 3:12 AM (in response to 4CSmith)

    I have an appletv version 2 upgraded to 5.0 and a appletv version 3 with 5.1 using Windows7

    I find I am having problems with Homeshare and having to come out of, and go back into Homeshare within Itunes to be able to Homeshare for sometimes 5 minutes and sometimes 45 minutes.

    I have a friend who has appletv version 2 using 4.4.4 and he can Homeshare on this with no problem.

    We have different internet providers and we wondered whether this was the problem, but after setting up around his house I had the same problem and he had none.

    So it appears that the problem is with appletv with versions higher than 4.4.4.

    Could people having this problem please state what there appletv is running on?

    I feel that when Apple upgraded to 5 and above we started having trouble sharing.  This could also be working in conjuction with the latest upgrade of Itunes

  • stevenfromjohannesburg Calculating status...
    Currently Being Moderated
    Apr 23, 2012 1:17 PM (in response to 4CSmith)

    Same problem. :( really ***.

    Can stream from my iPad to my tv, from my iPhone to my tv, but not from iTunes.

    Wish I could downgrade.

    It worked fine before 10.6.7

  • wrager Calculating status...
    Currently Being Moderated
    Apr 25, 2012 8:36 AM (in response to 4CSmith)

    I too, am having this problem along with the many others.  I have tried multiple things - but no avail....  :-/

  • manpowre Calculating status...
    Currently Being Moderated
    Apr 26, 2012 1:51 AM (in response to wrager)

    We know for a fact that it is the multicast stream to ATV3 that gets interrupted somehow.

     

    Question, do you have iphone connected on the wifi too, or iPad ? just wondering if you can test turning off the wifi on these devices, as something is interrupting the multicast stream. do your friend have iphone/ipad, and are they connected to wifi too?

     

    hope to get some more answers about my hunch and after readin hundreds of posts, I do see some signals towards some turning off wifi on the devices in the house makes things better. iphone, ipad, slingbox etc..

  • Napajoe Calculating status...
    Currently Being Moderated
    Apr 27, 2012 4:25 PM (in response to 4CSmith)

    Amen brother,

    It's killing me

  • txkcpetty Calculating status...
    Currently Being Moderated
    Apr 27, 2012 8:50 PM (in response to Napajoe)

    My ATV2 finally got back on after reinstalling my itunes on computer (don't think this was it) AND rebooting back to factory my ATV- When I rebooted it had me reinstall the 10.6.7 I think the new install on the ATV did it-- I don't think the computer had anything to do with it-- All other network was working-- Oh and I also upgraded my laptop finally to Lion- desktop won't go-- My laptop never showed up on computers list till now-- don't know if this relates or not-- I have been up and running now for a week!!!!   I have 2 iphones, an ipad a intel core desk, and a core 2 duo lap and the ATV2 all networking and everyone seems happy now.

  • cidrock Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 28, 2012 8:29 AM (in response to 4CSmith)

    I wouldn't dare to say that I found a solution but so far it's been three days without dropping out. My wifi network comes from an Airport extreme and it's extended by another AE. Everything was updated to its last version. After many tests changing the configuration of my net, trying to find a solution to the problem with HOME SHARING, I eventually gave up and restored my AE,s. I started the set up from scratch. But, surprisingly, the process was smoother than I recalled, using the new version of Airport utility. Specially, when setting up the secondary AE. Airport utility did everything automatically. And now it seems to work just fine. Best way to find is stop searching...

  • TheeDJ Calculating status...
    Currently Being Moderated
    Apr 28, 2012 12:36 PM (in response to 4CSmith)

    I have 2 Apple TV's (1080p) on one network with 2 computers running shared librarys ( 1Mac & 1PC).

     

    On another network in a different building 4 (2 are 720p, 2 are 1080p) Apple TVs feeding from a library on a PC.

     

    All units unfortunately have the new update.

    Both networks are completly Apple Extreme with Airport Express.

    iTunes has been reinstalled in both locatons, making no difference.

    Ethernet and WiFi makes no difference.

     

    One network is on Verizon the other is TimeWarner, and I have NO problem streaming Netfilx.

     

    ALL UNITS HAVE THE SAME PROBLEM DROPPING THE HOME SHARING!!!

    This just started a few weeks ago after the update.

     

    The only relief I have is now knowing I am not alone. I spent may hours and weekends trying to resolve this internally.

     

    APPLE get it together!! Steve is not here to hold your hand anymore.

  • BentoVox Calculating status...
    Currently Being Moderated
    Apr 28, 2012 5:10 PM (in response to 4CSmith)

    My case:

     

    PC Win 7 64 bits

    iTunes 10.6.1.7

    Apple TV HD

    Teldat iRouter (wifi off)

    Timeport 2 TB (wifi on)

     

    PC wired via Ethernet to the Teldat router and connected to the wifi network (implemented on timeport).

    IPv6 disabled on both ethernet and wifi interfaces of the PC.

    No DHCP, every interface has its own static IPv4 address.

     

    With the above configuration, Homesharing stops working every 5 minutes... until today. Now it seems to be working fine.

     

    The only thing I've done is activating AirPrint, whith a program I found on the Internet. I wasn't looking for solving my home sharing problem, but to print from my iPad... but now my HomeSharing is not stopping at all.

     

    If anybody with the homesharing problem could try activating AirPrint, it could help identifying the problem and a possible workaround.

  • btwfuufs Calculating status...
    Currently Being Moderated
    Apr 29, 2012 4:35 PM (in response to 4CSmith)

    Mine is working solid now. A clue?

     

    Before configuration - Home Sharing stops working after a few minutes

    ===============

    Desktop PC Win XP SP3

    wired via Ethernet to D-Link DIR-825 Wireless Router - out of box settings

    running iTunes 10.6.1.7

     

    After configuration - Home Sharing working solid

    ==============

    Desktop PC Win XP SP3

    wireless connection via Linksys WUSB600N Wireless-N USB Adapter with Dual-Band ver. 2

         to D-Link DIR-825 Wireless Router - out of box settings

    running iTunes 10.6.1.7

     

    So my question is, does Home Sharing on iTunes 10.6.1.7 not like being wired via Ethernet?

  • Naturallybrewed Calculating status...
    Currently Being Moderated
    Apr 30, 2012 9:29 PM (in response to 4CSmith)

    Just got a New ATV 3 wish i had found out about this before, Plays moives or content for 2-3 mins then drops and tells me to turn on home sharing.

     

    Ive got a Imac running the most up to date Lion and it cant even work with the ATV thats pluged straigh into the router. So now ive got a little black paper weigh. beond annoying.

  • MateriaHunter Calculating status...
    Currently Being Moderated
    May 1, 2012 8:56 AM (in response to 4CSmith)

    Mine doesn't even get that far, I get the "Loading ______'s Library" screen, then timeout.

  • YerKillingMeSmallz Calculating status...
    Currently Being Moderated
    May 2, 2012 9:30 AM (in response to btwfuufs)

    I am also having HomeSharing issues.  It worked the first time I tried and then 10 minutes later, nothing!  I tried again yesterday with the same results.  My desktop system is also wired to the router that is part of the home network.  I guess some Apple products are not created equal....

  • Paul Mottram Level 1 Level 1 (15 points)
    Currently Being Moderated
    May 8, 2012 2:33 PM (in response to 4CSmith)

    Hi

     

    I have been experiencing the same problems, but with Lion and atv 2, Home sharing is on for 5 to 15 minutes streaming movies (including apple purchased content) and then it turns off. A wifi refresh restores the link for a few minutes and then it goes off again.

    However, I don't think this is an exclusive itunes issue. I have servetome/streamtome which is a fantastic app for streaming movies and songs from a hard drive on a Mac to other computers and IOS devices both on a home network and a remote network. This is now having the same problems on the home network with streaming dropouts. As itunes does not need to be on for this to work, I am thinking that this may be OS related from the master computer or new IOS software  related from the receiving devices (ipad/iphone/ATV).

    In any event it is absolutely disgraceful that Apple have done nothing about this. Home sharing is the point of Apple TV not just buying overpriced content.

1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.