Skip navigation

Installing Snow Leopard (and Rosetta) in Parallels 7 in Lion - PART ONE

20865 Views 39 Replies Latest reply: Mar 14, 2013 9:51 AM by MlchaelLAX RSS
  • Mutassi Calculating status...

    maybe i explained myself wrong, i have a computer that CAN'T be fully downgraded to snow leopard (or at least, that's what i read in forums), so that's why I'm wondering if making a downgraded partition would work properly, to answer your questions:

     

    1. My computers is an imac lion 10.7.2 (I purchased it a week ago)

    2. as far as I know Logic 8 is a Powerpc application (that's what my computer says when I try to install it), i don't know if it needs rosetta but what i know is that it works perfectly in a snow leopard system. (By the way, Logic 8 is a music software -like Cubase or Protools-)

    3. no

    4. no (i don't even know the use of this lol)

  • Mutassi Level 1 Level 1 (0 points)

    Yes, there is a newer version of Logic that actually works in Lion, but due to some other matters I am not interested in purchasing it. To me, the best solution would be to have a partition with the snow leopard system but I am not that sure if it will work, so that's why I'm asking if you are somehow sure that your proposal may work in a computer that came with lion from factory (i wouldn't have a problem paying for that snow leopard system if i'm sure it would work).

     

    I can't seem to find a trial version for Logic 8 but well, I'm totally sure that it would work in a snow leopard system 'cause I've tried it.

  • Mutassi Level 1 Level 1 (0 points)

    aw i see, i never made a "virtualization" so I thought it was the same thing as a partition. Yes, logic works with external audio devices such as keyboards, etc.  and no, i don't need to print out anything.

     

    No, i am not really nearby (i'm in Barcelona, Spain lol). I will ask for more details of the logic software in other sites, thank you anyways, now at least I know there's a possible and sure way of running snow leopard in a lion system.

  • asmystiq Calculating status...

    Sorry for the incomplete post (if you saw it just now) -- hit the wrong button. I don't know how to delete a post.

  • asmystiq Level 1 Level 1 (0 points)

    Thank you for the links, Michael!

     

    And for moving the guide where it can be updated - I ran into the same editing, or rather lack of ability to continuously edit, issue earlier.

     

    Anyway, here are the issues I am currently experiencing while running Snow Leopard in the (currently) latest version of Parallels Desktop, Build 7.0.15094 (Revision 749908; April 5, 2012):

     

     

    1) Sound does not work

     

    I tried all different settings in Parallels, the status is "Connected", but in Snow Leopard the Sound system preference pane shows no input/output devices.

     

     

     

     

    2) Unable to share my Mac (Lion) drives with Parallels

     

    "Sharing" under "Options" in Parallels is set to share all disks, "SmartMount" is checked, and I even added my drives (2 partitions on one drive, one is my Lion boot partition, the other is just a data partition) as custom folders. Still, no drives or folders show up in VM.

     

     

     

     

    3) Issues with "Boot order"

     

    In Parallels, I created a second, backup, hard drive to use for booting for restoring the “ServerVersion.plist” file onto my main drive, after removing it to use the Software Update (and the Sharing preferences if that gets resolved). I have not yet imlemented the script you mentioned. When I do, perhaps this will be a moot point, but until then... I used SuperDuper! to clone my main drive to the backup drive.

     

    I have the following order in the "Boot order":

     

    Floppy Drive

    CD/DVD

    Hard Disk 2 (backup)

    Hard Disk 1 (main)

     

    "Floppy Drive" is mapped to the virtual drive provided by Parallels, while "CD/DVD" is mapped to my Mac's optical drive, which has nothing in it.

     

    If the "Floppy Drive" and "CD/DVD" are checked in "Boot order" and "Connected", (sure, I'll never need the "Floppy Disk" and will uncheck and disconnect it for normal use, but... for the sake of troubleshooting), the VM boots from the main drive, even though backup is listed first.

     

    If the "CD/DVD" is unchecked and if the "Floppy Drive" is disconnected, whether checked or not, VM boots from the backup drive no problem. With the "Floppy Drive" unchecked or disconnected, the VM boots from the backup drive only if the "CD/DVD" is unchecked -- disconnecting it does not solve the problem, as it does with the "Floppy Drive".

     

    Using "Select boot device on startup" didn't work at first either -- the VM always booted from my main drive, even after manual selection of the backup drive, but after I deleted the main drive, created another, cloned the former backup to the new backup, renamed the former backup to be the main drive, I can boot from the new backup drive. Perhaps a glitch fixed by repeating the process?! So, currently, "Select boot device on startup" works, while the "Boot order" configuration (without "Select boot device on startup") does not. However, I did notice that on the boot selection screen, the main drive is listed before the backup drive (makes sense, it was created first, if that's how it works) and if I don't choose the backup drive (even though it's listed as first in the "Boot order"), the VM boots from the main drive. This seems like a Parallels issue, but I can't verify it without someone else replicating these steps on their system.

     

     

    I was having additional issues -- crashing System Preferences after deleting the "ServerVersion.plist" file, being unable to boot from the backup drive after deleting the same file on the main drive, but it seems these issues went away after I deleted the offending main system/drive, created a new drive, and cloned the backup to create a new backup. I don't know why this worked (the backup was after all identical to the main), but it did. However, the above-mentioned issues remain.

  • asmystiq Level 1 Level 1 (0 points)

    Ah, the first two issues were solved once I installed Parallels Tools; thank you for that tip in your guide.

     

    Although "Boot order" issues persist, as long as "Select boot device on startup" works, and it does, all's well! There is light at the end of the tunnel! Finally!

     

    Again, thank you!

  • asmystiq Level 1 Level 1 (0 points)

    Good idea, Michael. Thank you.

  • FangSuede Level 4 Level 4 (2,195 points)

    As you are not able to post on MacRumors at the moment I wanted to ask what happened when you updated to the latest April 5, 2012 version of P7?

    When followed, the MR instruction set only gets a P7 comment to use SL Server.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.