Skip navigation

iMessage

549 Views 13 Replies Latest reply: Jul 12, 2012 8:18 AM by randers4 RSS
DonnaMatheson Calculating status...
Currently Being Moderated
May 2, 2012 6:42 PM

I set my iMessaging as my email but I want it to be my phone number how do I change it

iPhone 3GS, iOS 5.1
  • randers4 Level 9 Level 9 (53,585 points)
    Currently Being Moderated
    May 2, 2012 6:43 PM (in response to DonnaMatheson)

    Go to Settings>Messages>Receive At>Caller ID, tap your phone number.

  • stevejobsfan0123 Level 7 Level 7 (30,505 points)
    Currently Being Moderated
    May 2, 2012 6:43 PM (in response to DonnaMatheson)

    Settings > Messages > Receive At... > Caller ID.

  • randers4 Level 9 Level 9 (53,585 points)
    Currently Being Moderated
    May 2, 2012 6:52 PM (in response to DonnaMatheson)

    The only way to remove the email is to tap your Apple ID for iMessage and sign out.  If it doesn't show your number in Settings>Messages>Receive At you may notice that it says "waiting for activation" under iMessage.  If so, iMessage hasn't yet activated your number with the server so it isn't available for Receive At or Caller ID.

  • randers4 Level 9 Level 9 (53,585 points)
    Currently Being Moderated
    May 2, 2012 6:53 PM (in response to DonnaMatheson)

    When you say that your number is grey, are you looking inside the Caller ID setting?  (The Receive At number is always greyed out.)

  • randers4 Level 9 Level 9 (53,585 points)
    Currently Being Moderated
    May 2, 2012 6:59 PM (in response to DonnaMatheson)

    Be sure it says "waiting for activation" under iMessage first.  If it does, sometimes just turning iMessage off, wait a few minutes, then turn it back on will work.  Other times users have struggled with this.  Some suggestions are to go to Settings>General>Date & Time, make sure Set Automatically is set to On.  Also be sure you are able to send and receive messages.  If you continue to have problems, some users have reported success by replacing the DNS servers on their wireless router with  8.8.8.8 and 8.8.4.4 (these are Google's Public DNS servers, see https://developers.google.com/speed/public-dns/docs/using).  If you make either or both of these changes, turn iMessage off, wait a minute or two, then turn back on to reinitiate the activation request process.  You may also need to turn wi-fi off, then back on on your phone to reconnect to your wi-fi if you change the DNS settings.

  • randers4 Level 9 Level 9 (53,585 points)
    Currently Being Moderated
    May 2, 2012 7:11 PM (in response to DonnaMatheson)

    You're welcome.  Good luck.

  • yiotaax Calculating status...
    Currently Being Moderated
    Jul 12, 2012 6:51 AM (in response to randers4)

    i have the same problem and it doesnt have as opportunite the" CALLER ID" WHAT I SHALL DO?

  • yiotaax Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2012 6:56 AM (in response to randers4)

    WHEN I TRY TO TURN ON MY iMESSAGE IT SAYS YOUR CARRIER MAY CHARGE FOR SMS MESSAGES USED TO ACTIVE iMESSAGE! AND THEN IT HAS CANCEL OR OKAY, WHAT THAT MEANS AND WHAT I HAVE TO DO?;S also when i press okay it has only my Apple Id to receive my imessages and it doesnt let me to choose my number it says verifying : my number and its gray! please help me, i tried it all! if you have an idea please tell it to me as soon as you can ! thankyou

  • randers4 Level 9 Level 9 (53,585 points)
    Currently Being Moderated
    Jul 12, 2012 8:18 AM (in response to yiotaax)

    When you activate iMessage a sms message is sent to the iMessage activation server.  You won't see the message being sent so it's warning you that it will be and that, depending on you plan with your carrier, you may be charged for this message.  Also, it is normal for your number to be grey in Settings>Messages>Receive At.  If you have problems getting it to activate, search the forums for "iMessage waiting for activation" and you'll get a number of posts with different solutions (there isn't just one that works for everyone).  Some solutions include:

     

    1. Turn iMessage off, wait a few minutes, then turn it back on.
    2. Go to Settings>General>Date & Time, make sure Set Automatically is set to On.
    3. Be sure you are able to send and receive messages.
    4. Also make sure in Settings>General>Date & Time that Set Automatically is turned to ON.
    5. Change the DNS servers on your phone and/or wireless router to 8.8.8.8 and 8.8.4.4 (these are Google's Public DNS servers)
    6. Call your carrier to make sure they aren't blocking premium texts or third party texts

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.