Skip navigation

Another . . Aperture won't delete plugins question.

1011 Views 7 Replies Latest reply: May 3, 2012 1:50 PM by léonie RSS
Buford Pusser Level 1 Level 1 (0 points)
Currently Being Moderated
May 3, 2012 11:57 AM

My Aperture 3 is not letting me delete plugins. I know this does not seem to be a new issue on this forum, but for me it is because I have tried (to the best of my knowledge) to delete these plugins according to several methods listed in the community here. I have gone to library/application support, I have opened the Aperture Package to view plugins . . . that are not even there! I have also used the uninstall that came with the original plugins install. The uninstall goes through the steps and indicates it has removed all files and deleted the plugin. Yet, when I have reopened aperture and even re-booted the program. I can right click on a photo and select "edit with" and the recently deleted plugin will still be avail AND still function.

 

I am really stumped. Unless I am missing something through your posts about mac terminology going through "finder", "library" and "go" that I am still getting acquainted with I cannot figure out what else to do.

 

I know I can reinstall Aperture or time machine "back". At this point I think I am more frustrated at not being able to solve htis issue than I am about the plugin problem.

 

I am fairly new to mac's infrastructure and I would like to learn how to fix this.

 

Any help is appreciated.

 

 

Forgive me if you have to type in "baby-steps"

 

"Dear Newbie: Click the Apple on your desktop . . ."

 

DJ

 


 

 

OS 10.7.3 & Aperture 3

Macbook Pro intel duo core

Mac book Pro, Mac OS X (10.0.x)
  • léonie Level 8 Level 8 (46,475 points)

    Dear Newbie,

    it would help to know which plug-ins you want to uninstall. Then it would be easier to advise you how to search for them.

     

    Cheers

    Léonie

  • léonie Level 8 Level 8 (46,475 points)

    I don't use any of those plug-ins - sorry.

     

    But the plug-ins usually should be installed in one of the two libraries used for installation, and from your previous post I gather you already looked in both places:

     

    • your user library -> Application Support -> Aperture -> Plug-ins
    • your system volume -> Library -> Application Support -> Aperture -> Plug-ins

     

    To uninstall:

    • Quit Aperture if it is running.
    • Open the libraries in the Finder: (I think you already found those)
      • The system library: click on your system drive icon on your desktop; navigate to the Library folder.
      • Your User Library: Finder -> Go -> Hold down the options key -> click the Library
    • Remove the plug-ins from the Application support -> Plug-ins folder.

     

    It is weird that your plug-ins still should be working after removing them from the Library. Did you empty the Trash after uninstalling?

    To make Aperture forget the plug-ins, empty the trash and then restart the system to empty all caches.

     

    Then try again.

    If the plug-ins still appear in the menus, remove the Aperture preferences file from the Preferences folder in the user library, as described here:

    Aperture 3: Troubleshooting Basics: http://support.apple.com/kb/HT3805

     

    Post back, if you need more advice.

     

    And I hope a Nik-plug-in user will join us here

     

    Cheers

    Léonie

  • léonie Level 8 Level 8 (46,475 points)

    You need to search these folders inside your Libraries and dive down thru the hierarchie of folders:

    To find "Application Support" in your System Library

    • double click the icon of your hard drive to open a Finder window.
    • In the Finder window double click the Library icon
    • You should see a folder named "Application Support" inside the Library.
    • Double click and in the Finder window that opens navigate to "Aperture"
    • Search the Plug-ins folder.

     

    Do the same for the User Library.

     

    Regards

     

    P.S. I am trying to send a screenshot, but having network trouble ...librarySearch.png

  • léonie Level 8 Level 8 (46,475 points)

    You are welcome. My pleasure.

     

    Regards

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.