2 Replies Latest reply: May 4, 2012 5:02 AM by gandalf
gandalf Level 3 Level 3 (930 points)

I just bought a Mac Mini that came with Lion installed. I couldn't transfer my files over from my old G4 because the video card died in that Mac, so I put the hard drive into an external USB case and did the transfer of my old settings that way using Migration Assistant. All my settings seems to have moved fine and I manually moved my web files to Library/WebServer/ Documents folder, but when I turn on Web Sharing none of my files show up on the server although they are all in the Library/WebServer/ Documents folder and Web Sharing is turned on Sharing Preferences. All I get when I access the IP is "It Works". Am I missing something here?

  • 1. Re: How to get files to show up in Library/WebServer?Documents folder?
    gracoat Level 3 Level 3 (660 points)

    Are you running Lion Server, or Just lion client?

    If it's lion client, then the documents that you copied need to go in the ~/Sites folder.

    This being the case, the address to reach your web server would be server.example.com/~username (username is the name of the user folder where you dropped the website documents)

     

    If it's lion server, then you need to create the website in the server.app ...  ....app before you copy your data.  Just in case Lion rewrites any of the data that's in the /Library/Webserver/Documents folder.  If you've already put the files in there, just move them all to a handy spot on your desktop.

    Create the site, copy the data and BAM!

     

    Then your website address will simply be server.example.com/

     

    HTH

    -Graham

  • 2. Re: How to get files to show up in Library/WebServer?Documents folder?
    gandalf Level 3 Level 3 (930 points)

    Thanks gracoat but I've always used the main library/web server/ documents folder since Panther never the user sites folder. When I tried to do as you sugested I get a permission error that I don't have permission to use the server. BTW it's not Lion server I'm running the client version. Funny thing is when I try to access my files I get the "It Works" page. So ther server is running it just doesn't see the files for some reason.