Skip navigation

Windows 7 cannot access Lion SMB share, no login prompt

8937 Views 29 Replies Latest reply: Jul 23, 2013 8:21 AM by jlgtx RSS
1 2 Previous Next
docmars Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 15, 2012 2:08 PM

Hey everyone,

 

I am able to access my Windows 7 machine's shares on my Mac (Lion 10.7.3) through SMB with no problems at all. However, I am unable to access my Mac's shares on my Windows machine.

 

I have been fighting with this issue for hours and haven't found a solution yet. I've done a bunch of Googling and have found plenty of posts related to my issue, but no solutions. Everyone seems to be at least receiving a login prompt when they try to connect to a Mac OS X Lion Samba share from a Windows 7 machine, but I am not. All I get is "Windows cannot connect to \\MAC" after ~15-20 seconds of waiting.

 

Here's what I've tried:

  • Reconfigured all of my settings on both the Windows and Mac systems, then restarted.

 

  • Windows: set to 40- and 56-bit encryption for File Sharing, instead of 128-bit.
  • Windows: network discovery and file sharing enabled.
  • Windows: Network Security: LAN Manager Authentication Level to Send NTMLv2 response only” to “Send LM & NTLM – use NTLMv2 session if negotiated as suggested in another post.
  • Windows: verified workgroup as WORKGROUP.
  • Windows: verified Windows Firewall options for File Sharing.
  • Windows: cleared credentials for my Mac's share in the Credential Manager, still no login prompt.
  • Windows: reinserted my Mac's credentials in Credential Manager for the share, same issue.

 

  • Mac: Enabled File Sharing, enabled SMB, enabled my Mac's account.
  • Mac: verified Firewall settings for File Sharing.
  • Mac: verified workgroup as WORKGROUP in WINS/NETBIOS configuration.

 

  • For both systems: verified IP configuration as DHCP under the same gateway and subnet mask--they're clearly under the same network.

 

Could it be a hosts file issue of any sort?

 

All help is appreciated, thank you!

MacBook Pro, Mac OS X (10.7), 15-inch 2011
  • richardhowell Level 1 Level 1 (0 points)

    Hi docmars, strange you've had no reply!

    I'm sorry I'm not able to help you, though, as I'm having the same problem.But can we just share some information here please? On your PC when you click on Network in explorer, can you see an entry for your mac. It sounds from the above as though you can, since you enabled file sharing on your mac account. However, on my PC I can see no entry for my macbook at all.

    But like you, I have perfect communication in the mac >> pc direction.

    There must be someone out there to shed light on this!

  • Shootist007 Level 6 Level 6 (16,640 points)

    Try turning off the Mac firewall. If you are behind a router you don't need it enabled.

     

    In the options section of Sharing make sure your username is listed and checked and that you have input the correct password.

  • ben43 Level 1 Level 1 (0 points)

    I had this problem too. Interestingly, one Lion machine which I had worked perfectly, i.e. Windows 7 could connect fine; this machine had been upgraded through many OS X versions over the years. A new Mac with a clean Lion install exhibited the problem you describe.

     

     

    I compared the two smb config files and there was a difference. Take a look at your

      /Library/Preferences/SystemConfiguration/com.apple.smb.server.plist

    My working Mac had one extra entry in its plist:

     

     

              <key>AllowGuestAccess</key>

              <true/>

     

     

    So I edited the plist (you'll need to use sudo to do this) and added this key, then turned File Sharing off and on again -- or reboot if you're superstitious -- and it began to work for me.

  • CGraffix Level 1 Level 1 (0 points)

    On the Lion side try turning off SMB shares then back on again.  Then try to map your network drive or browse the networks from the windows side.   I must toggle SMB shares every time I reboot the Lion "server".

  • ben43 Level 1 Level 1 (0 points)

    To be honest, my AllowGuestAccess tweak was most likely a red herring. Even after that change, I had a recurrence of the problem later on (after machine restart), The next time I just turned sharing off and on again and it fixed the problem for me, so that was probably what had fixed it before too.

     

    Another factor is that when my Windows machines can't connect, other Macs can connect using an smb:// URL. The Windows machines are all joined to an Active Directory domain and would be automatically attempting a connection with (Kerberos?) domain credentials first, which would fail. I wonder if a non-domain Windows machine would work? I'll test that next time it bites me,

  • ben43 Level 1 Level 1 (0 points)

    One more comment, of a diagnostic nature: rather than using the Windows GUI to connect, try connecting from the CMD prompt. It will probably still fail, but you may get a better or at least different error message back that gives you a clue. If you've got a server called MAC with an smb share SHARE you would map this to your X drive as follows:

     

    net use x: \\MAC\SHARE password /user:username

     

    Oh, and you don't say so specifically, but I presume you have verified that your Mac machine name is resolvable by Windows, i.e. "ping MAC" works? You could also try using the Mac's raw IP address in place of MAC in the connection command, to eliminate DNS issues.

  • ben43 Level 1 Level 1 (0 points)

    If you can't ping the machine by name then this sounds like a different problem and it's not to do with Lion's SMB configuration, but is a DNS issue. It sounds like you think your Mac is machine name "MAC" but your router does not agree. In System Preferences / Sharing, under "File Sharing: On" what does it list as the machine name? You may need to do something to make your Mac and the DNS agree what the name is.

     

    Alternatively, since the IP address works, add a hosts file entry to the Windows machine to manually name that IP address.

     

    And if you try to connect to the share by IP address on Windows, e.g. \\10.1.x.y\SHARENAME, does that work?

  • markopolo73 Level 1 Level 1 (0 points)

    Try checking your Advanced TCP/IP Settings under Windows 7. Mine was somehow set to append a custom DNS suffix (in this case my remote workplace domain) -- I believe my VPN client software might have been the culprit. Once I changed it to 'Append primary and connection specific DNS suffixes' (the generic option for name resolution), I had no problem connecting by hostname to my Lion-based Mac.

  • abwc Level 1 Level 1 (0 points)

    I, too, have spent hours today troubleshooting this.

     

    At this point, it is working, but I don't yet know if the 'temporary nature' of this 'working' condition, as described by others, has yet to expire.

     

    Between now and when it may stop working, here is what I have found to be relevant in solving the problem for:

    • a straighfroward sharing setup between Windows 7 and a Mac OS X Lion ( 10.7.4 ) workstation
    • where Lion is hosting a share with SMB sharing enabled
    • where Lion was installed fresh, without carrying over any history from previous versions of the OS
    • where Lion can connect to Windows 7 shares with ease
    • where the same Mac machine was performing SMB sharing flawlessly while running Snow Leopard, but everything stopped working once I installed Lion

     

    1. Windows: LAN Manager authentication in Local Security Policy on the Windows machine does NOT appear to be relevant ( this was required back in the Leopard days, but was not required by Snow Leopard, and does not appear to be required by Lion ); I have two Windows 7 clients working, and one of them has the value 'NT & NTLM + NTLMv2 if negotiated', while the other has 'Not Defined' as the value; both of these configurations are currently working.
    2. Windows: IPv6 settings don't need to be altered from the defaults
    3. Lion: The WORKGROUP setting in Network Preferences/Advanced/WINS must match the name of the workgroup to which the Windows machine belongs. The workgroup name does NOT have to be "WORKGROUP", but it does need to match the Window's machine's workgroup name. NOTE: it is easy to omit the "Apply" step when making this change, but unless you hit "Apply" you will find that your changes do not stick.
    4. Lion: The WINS server IP address value is blank
    5. Lion: The configuration changes prescribed here MAY be CRITICAL, but I am unsure. In my working configuration, this prescribed configuration is in effect. ( if you are curious about the 'com.apple.smb.server.plist.lockfilefile' living alongside 'com.apple.smb.server.plist', read this.
    6. Windows: to Map the Network Drive in Windows to the Lion SMB share, using Windows Explorer is the quickest, most straighforward method: enter \\LIONNETBIOSNAME in the address bar, and expect to be prompted to enter your Lion user account credentials
    7. Windows: choose "use a different account"
    8. Windows: the username must be fully-qualified, as in LIONNETBIOSNAME\shortusername. ( The advice given in Lion's Sharing Preferences pane to use IPADDRESS\username is unnecessary )
    9. Lion: in my case, despite having gotten all of the above in place, I was still unable to connect. The final piece of the puzzle appears to have been, in Sharing/FileSharing/Options:
      • uncheck the box next to your user account
      • authenticate the change
      • click DONE
      • Again in Options, uncheck SMB sharing
      • click DONE
      • Again in options, enable SMB sharing
      • Check the box next to your name
      • authenticate
      • click DONE
      • Repeat steps 6, 7, and 8

     

    My guess is that step 5 is critical, but it may be rendered useless by having completed step 9 first, such as during previous attempts to get SMB sharing working without ( knowledge of ) it.

     

    In all of the Googling I've done today, every single one of these pieces of information was available, but none of them was synthesized into anything useful as a stand-alone solution. My hope is that the next person to stumble across my recipe finds that it also works for them; better still if they can further refine it to eliminate the uncertainty that remains in my account...

  • vanclute Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 17, 2012 6:53 PM (in response to abwc)

    HOLY CRAP!!!  I've been plagued with this bizarre problem for months, with absolutely no concrete idea as to why.  On a lark, I decided to just try your final steps... nothing else... AND IT WORKED!!!  All I did was:

     

    in Sharing/FileSharing/Options:

     

        uncheck the box next to your user account

        authenticate the change

        click DONE

        Again in Options, uncheck SMB sharing

        click DONE

        Again in options, enable SMB sharing

        Check the box next to your name

        authenticate

        click DONE

    And instantly my Windows machine can login to the Lion shares with nothing more than entering the Lion machine username & password into the Windows 7 prompt. 

     

    Thank you so much for posting this.  Obviously some setting internal to OSX was just "stuck" and systematically unchecking & rechecking everything in just this way, fixed it.  I had previously checked & unchecked just about everything, but not in this specific, methodical way.  THANKS AGAIN!!!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.