8 Replies Latest reply: May 4, 2012 1:39 PM by hawkins1621
newtomac2008 Level 1 Level 1 (0 points)

When I first start up iMovie 11 it seems to load up fine with all my projects and photos listed. But as soon as I choose any of my projects to start working on I get the 'spinning beach ball' that spins forever. I have recently updated to Lion and when I updated to iMovie 11 and didn't have any issues like this before. Now suddenly the process is not responding in the Activity Monitor (see snapshot below). Do I need to uninstall iMovie, if so how and how do I make sure I backup the right files? Any help someone out there can provide would be much appreicated:

 

 

 


iMovie '11, Mac OS X (10.7), iMovie not loading under Lion
  • 1. Re: iMovie Not Responding in Lion
    wible4 Level 1 Level 1 (0 points)

    I have the same problem with OS X 10.6.8. I cannot even get to the help file to try anything there.

    I hope someone has a procedure to do a rebuild without losing all my videos!

  • 2. Re: iMovie Not Responding in Lion
    calbe Level 1 Level 1 (110 points)

    It sounds as if perhaps one of the projects may be "corrupted."

    Try moving the contents of ~/movies/imovie projects/ to a temporary folder to see if you can get iMovie stable. Then systematically move them back.

     

    It could also possibly be the ~/movies/imovie events/ as well.

     

    From my experience, I have encountered more causes from the project library than the event library.

  • 3. Re: iMovie Not Responding in Lion
    wible4 Level 1 Level 1 (0 points)

    Thank you calbe. It was as you suggested. It was difficult to rid the file as the loading phase wanted to keep running.

     

    wible

  • 4. Re: iMovie Not Responding in Lion
    calbe Level 1 Level 1 (110 points)

    wible4 wrote:

     

    Thank you calbe. It was as you suggested. It was difficult to rid the file as the loading phase wanted to keep running.

     

    wible

     

    My pleasure! Glad it worked!

  • 5. Re: iMovie Not Responding in Lion
    SanXa85 Level 1 Level 1 (0 points)

    I had the same problem and your suggestion helped me to fix it. Thanks a million!

  • 6. Re: iMovie Not Responding in Lion
    Paul Nord Level 1 Level 1 (15 points)

    Didn't help me.  I had to go into my ~/Library directory and trash some iMovie preferences.  I removed a folder at the Library level.  Also some com.apple.imovie* files from Preferences.  And the iMovie folder from Application Support.

     

    Hope that helps someone.

  • 7. Re: iMovie Not Responding in Lion
    smithfromboston Level 1 Level 1 (0 points)

    calbe wrote:

     

    wible4 wrote:

     

    Thank you calbe. It was as you suggested. It was difficult to rid the file as the loading phase wanted to keep running.

     

    wible

     

    My pleasure! Glad it worked!

    I had the same problem and now resolved, thank you

  • 8. Re: iMovie Not Responding in Lion
    hawkins1621 Level 1 Level 1 (0 points)

    My imovie has been playing up all day, have been having to force close it. My Uni deadline is on tuesday and I am so close to finishing so its very frustrating. One of my projects seems to be ok so what you said about the corrupt file could be right. I have removed it from imovie projects and imovies now seems to be ok, however I need to work on this project, is there anyway to uncorrupt it?! Thanks.