Skip navigation

System Preferences Appear Corrupted

475 Views 9 Replies Latest reply: May 5, 2012 12:21 AM by Possumboy RSS
Possumboy Calculating status...
Currently Being Moderated
May 4, 2012 7:37 PM

System Preferences appear corrupted within 10.6.8 - mouse will not activate any commands within any preference and will not close Finder windows (or initiate apps with a double click as it used to).  Have tried rebooting and resetting PRAM and NVRAM.

 

Another user account on the same machine appears to working without issue.

 

Think my young son may have dabbled with system preferences after he downloaded Minecraft last night.

 

Any help welcome.

iMac, Mac OS X (10.6.8)
  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 4, 2012 8:06 PM (in response to Possumboy)

    Try deleting com.apple.systempreferences.plist in your Preferences.

     

    Possibly also com.apple.finder.plist.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 4, 2012 8:52 PM (in response to Possumboy)

    Try booting in safe mode and see what happens.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 4, 2012 9:07 PM (in response to Possumboy)

    Not sure what to suggest.  It is obviously localized to your own account so there's something that needs to be removed.  The only possible other plists that might be involved with opening System Preferences are the ones in ByHost within your Preferences folder.  But wiping all those all out is a bit radical.

     

    I suppose you could experiment by temporarily renaming ByHost, say as ByHostX, and then see if your system preferences successfully open.  If that worked at least you would have localized to something in the By Host folder.

     

    Even more radial would be to temporarily rename the entire Preferences folder.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 4, 2012 9:17 PM (in response to Possumboy)

    If the other existing user account is working OK, the new one should as well.

     

    Unless you import into the new account whataver is screwing up the current account.

     

    Moving stuff can be a bit of a hastle if you don't know everything to move.  You can move apps but if you don't move the preferences and anything else associated with those apps at a minimum you would have to redefine their preferences but you could also miss other stuff those apps may have installed in /Application Support and other places.  Itunes lib can be copied but you then have to tell itunes where it is.  Photos I don't know how you do that.

     

    I never had to recreate nor move an account so I am no expert at it.  And when I set up a new machine I know everything involved with each thing I move so I have no problems moving those either.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.