Skip navigation

Error when installing Lion on empy HD: "Couldn't find app store version, falling back to hardcoded"

1242 Views 1 Reply Latest reply: May 5, 2012 7:00 AM by rkaufmann87 RSS
Ikabodo Calculating status...
Currently Being Moderated
May 5, 2012 5:55 AM

I've run in to a problem that is making me tear the hair from my head. I'm hoping for your help!

 

Short story:

I'm trying to install OS X Lion on my 27" iMac.

I've erased the HD using Disc Tool in recovery.

HD shows no errors.

I've tried Internet Recovery (it loads up, but wont start the installation)

I've tried creating a recovery usb on another similar iMac, and use it on this. Same error, only differance is it keeps "loading" when installing, but nothing happens. Same error in log.

 

When I try to start the Reinstall I get an error in the installation log that goes something like this:

 

Install Mac OS X Lion[354:9c03] Couldn't find app store version, falling back to hardcoded

Can not connect to /var/run/systemkeychaincheck.socket: No such file or directory

 

Apple Care suggested:

Trying another network (doesn't work).

Install with the original Snow Leopard DVD first, then upgrade (can't do that, the DVD is lost and a DVD from another friend is not working)

 

 

What can I do to get around this error?

Someone suggested buying a usb with Snow Leopard from the apple store. Do I really have to buy a NEW operating system because the recovery doesn't work? Would I have to pay to upgrade to Lion again?

iMac (27-inch Mid 2010), Mac OS X (10.7.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.