1 2 Previous Next 21 Replies Latest reply: Dec 2, 2013 3:21 PM by jenandjase
TheDudeAbides76 Level 1 Level 1 (0 points)

I rented a movie on my ATV3 and when the "ready to play" pop-up came up, I pressed "menu" so that I could watch it later. When I went back to the main menu, the movie appeared along the top row under "rented" for about three seconds and then it disappeared. I tried the "check for rentals" option and nothing happened. I tried resetting my ATV and nothing. I tried a factory restore, still nothing. I tinkered with my wireless router to see if any settings had changed, but it was still functioning exactly the way it always has and prior to this, I have never had difficulty with renting. I reset my modem and wireless router (as well as the range extender i use, which was also verified to be in working order) and yet the issue persists.

 

I contacted Apple support and they gave me a refund and told me to rent movies on my PC and then play them through there, but my homesharing does not seem to work either. I checked the IP addresses of all the hardware involved and they are all on the same network. I can still play the movies I purchased from the cloud, but I am not about to purchase movies that I am only willing to pay $4 for because I wont be watching them all the time. I am at a loss here. I have searched these forums like crazy and I have seen many people with simmilar problems, but none of these discussions have resolutions.


Apple TV, ATV software 5.0 (4099)
1 2 Previous Next