Skip navigation

Cannot change preferences

1079 Views 15 Replies Latest reply: Feb 20, 2013 3:56 PM by psuarmy RSS
1 2 Previous Next
psuarmy Calculating status...
Currently Being Moderated
Apr 24, 2012 6:27 PM

I recently created two users on my MBP.  One for me and one for my wife.  Since doing so neither account can change preferences.  Website login and passwords will not save.  I save the password, but it asks me again every time.  I also cannot delete keychains.  If I do delete keychains they reappear as soon as keychain access is restarted.  I cannot change permissions on file access as well.  Everytime iPhoto is opened on my wife's login it states there are inconsistancies found in the library.  I figure there is a currrupt file somewhere, but I don't know where to look.  It seems that the computer settings and preferences are frozen in whatever state the computer was in when the second login was created. Any help would be appreciated.

MacBook Pro, Mac OS X (10.7.3)
  • Linc Davis Level 10 Level 10 (108,120 points)
    Currently Being Moderated
    Apr 24, 2012 6:33 PM (in response to psuarmy)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.


    Launch the Terminal application in any of the following ways:


    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    Open LaunchPad. Click Utilities, then Terminal in the page that opens.


    Drag or copy — do not type — the following line into the Terminal window, then press return:


    chmod -R -N ~


    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:


    sudo !!


    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.


    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.


    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens. You’re not going to reset the password.


    Select your boot volume if not already selected.


    Select your username from the menu labeled Select the user account if not already selected.


    Under Reset Home Directory Permissions and ACLs, click the Reset button.


    Select ▹ Restart from the menu bar.

  • Linc Davis Level 10 Level 10 (108,120 points)
    Currently Being Moderated
    May 5, 2012 5:43 AM (in response to psuarmy)

    From the Finder menu bar, select Go ▹ Go to Folder... and copy the following line into the text box that opens:




    A Finder window will open with an item selected. Press the key combination command-I to open the Info window. In the Sharing & Permissions section of that window, do you have read & write access? Is the item locked? What is its modification date?

  • Linc Davis Level 10 Level 10 (108,120 points)
    Currently Being Moderated
    May 6, 2012 7:19 AM (in response to psuarmy)

    Those are not the default permissions. Did you change them after resetting permissions as above?

  • Linc Davis Level 10 Level 10 (108,120 points)
    Currently Being Moderated
    May 6, 2012 2:04 PM (in response to psuarmy)

    I'm not sure I understand your response, but if resetting permissions fixes your computer, and changing them breaks it, then I suggest you stop changing them.

  • Linc Davis Level 10 Level 10 (108,120 points)
    Currently Being Moderated
    May 6, 2012 4:47 PM (in response to psuarmy)

    I am still having trouble understanding your responses. You wrote earlier that everything worked after you reset the home folder permissions; now you seem to be saying something different. Since it's not clear to me what the issue is, I don't think I can be of any further help. I'm not sure you fully understand how permissions are supposed to work. It's normal that you can't access files in another user's home folder. If you're trying to share files between two different users, you're going to have problems. It's also normal that you can't make changes to most files outside your home folder without authenticating as an administrator.


    I suggest you repair the permissions of system files in Disk Utility, if you've changed them, and also reset your home folder permissions again, if you've changed those. If those steps don't resolve your problems, start a new thread with a less confusing title to address them.

  • Linc Davis Level 10 Level 10 (108,120 points)
    Currently Being Moderated
    May 6, 2012 5:31 PM (in response to psuarmy)

    If you and your wife want to share the same files, you should share the same account. There's no other practical solution. You have been wrecking the permissions of every file on the system. If you do things like that, your computer won't work.

  • Linc Davis Level 10 Level 10 (108,120 points)
    Currently Being Moderated
    May 6, 2012 5:54 PM (in response to psuarmy)

    Some of what you want could be achieved by using iCloud and sharing the same ID with separate local accounts. You might want to post a question in the iCloud discussion area.

  • TheCraw Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 20, 2013 8:45 AM (in response to psuarmy)

    I happened to be looking at this, I assume you have already solved this but one simple way to share the files is to set up dropbox on both your accounts. Any files you normally share will go up and down each time you log into your account. Or if it is a desktop just keep files on an attached drive. No issues with permissions on those files.


    Hope you found a good solution.



1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.