Skip navigation

10.6.8 Snow Leopard- can't use iCloud (on iPhone 4s) -no OS X Lion. Update/Upgrade help?

1541 Views 1 Reply Latest reply: May 6, 2012 8:17 AM by Roger Wilmut1 RSS
KaitlinSC Calculating status...
Currently Being Moderated
May 6, 2012 7:56 AM

I have 10.6.8 Snow Leopard and can't use iCloud (which is installed on my iPhone 4S) because I don't have OS X Lion. Is there a way to upgrade to Lion and use iCloud without having to pay for the upgrade? Is there a stand-alone upgrade? I was under the impression the transition to iCloud would be easy.

 

I have a MacBook Pro with 10.6.8 Snow Leopard, and an iPhone 4S with iCloud, and want to use iCloud to connect my MBP and iPhone (the way iCloud is supposed to...) but checking around for 10.7.1, I found out that I am supposed to pay 49.99 for OS X Lion. Is there any way to get this upgrade for free, since I already have an iCloud account, an iPhone, and Snow Leopard? Or am I forced to once again pay $$$ for apple products?

Thanks.

iPhone 4S, Mac OS X (10.6.8), iCloud issue

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.