1 2 3 Previous Next 30 Replies Latest reply: Jan 13, 2014 10:59 PM by hossam.alosh Go to original post
  • 15. Re: How can I change the language setting on my Mac?
    Kurt Lang Level 7 Level 7 (31,995 points)

    Oh, DUH!!! I read it as he was trying to set Italian as the default.

  • 16. Re: How can I change the language setting on my Mac?
    Linc Davis Level 10 Level 10 (117,995 points)

    I don't use X-Plane, but unless there's something very strange about it, you don't install it per user; you install it system-wide, and all users have access to it. If that's not the way you installed it, please do so now. Reinstalling it after that isn't going to make any difference. The problem is something in your user account, not in the application.

     

    Please go back into the Terminal application and run the command below, in the same was as before -- no typing:

       

    defaults read -g AppleLanguages

      

    Post the output.

  • 17. Re: How can I change the language setting on my Mac?
    columbus new boy Level 1 Level 1 (0 points)

    This is what came back:

     

    (

        "en-GB",

        ga,

        "en-US",

        it,

        fr

    )

     

    I only used XPlane because the CD was close to hand. This may have something to do with it:

    For my main account, I actually had the software installed on an external drive (with all my iTunes music). When I installed it on the Guest account, I installed it locally.

     

    I appreciate your help and reiterate that the only thing that is different with XPlane (as installed) is that everything in XPlane is in Italian: normally there are Italian dialogue boxes as I install new software, but once the software is installed, I can proceed in English.

  • 18. Re: How can I change the language setting on my Mac?
    Linc Davis Level 10 Level 10 (117,995 points)

    I'm still not sure I know what you're doing. Where is X-Plane installed? It should be in the Applications folder at the top level of your startup volume -- not on an external drive, and not in the home folder of any user. Once it's installed there, you should be able to run it from any user account without having to install it again.

     

    The documentation I saw says that X-Plane, unlike most Mac applications, has its own internal language setting. If that's accurate, then you may be running afoul of that setting. Either change it from within the application, or move all the settings files out of the way and see whether there's a difference.

  • 19. Re: How can I change the language setting on my Mac?
    columbus new boy Level 1 Level 1 (0 points)

    XPlane was installed originally on an external harddrive and ran fine from there. I've deleted it while I tried what you suggested and haven't yet re-installed it.

     

    XPlane isn't the real problem though - the issue is that somehow Italian is fixed as a language in the computer when I install software - the XPlane was just an extreme example.

  • 20. Re: How can I change the language setting on my Mac?
    Linc Davis Level 10 Level 10 (117,995 points)

    This thread has been going on a long time and I'm close to giving up on it. I still don't know whether you have this problem with all applications that are installed system-wide, not just X-Plane, and whether you have it in the guest account as well. If I can't get that information, I certainly can't help you. Even if I can get it, I may not be able to help, because I've never of heard of this before.

  • 21. Re: How can I change the language setting on my Mac?
    columbus new boy Level 1 Level 1 (0 points)

    The problem is a general one - EVERY time I install software, the dialogue boxes regarding agreements, locations to install etc. present in Italian.

     

    I used XPlane because the DVD was right there. That was the only one I tried in the Guest account and, as I said, it presented in English so my assumption is that the problem is just with my account.

  • 22. Re: How can I change the language setting on my Mac?
    Linc Davis Level 10 Level 10 (117,995 points)

    And still I don't know whether it's the same in the guest account. Here's my last word in the subject, based on the assumption that problem is limited to your account.

     

    First, back up all data if you haven't already done so. No matter what happens, you should be able to restore your system to the state it was in at the time of that backup.

     

    Open the Library folder in your home folder as follows:

     

    If running Mac OS X 10.7 or later, hold down the option key and select Go ▹ Library from the Finder menu bar.

     

    If running an older version of Mac OS X, select Go ▹ Go to Folder… from the Finder menu bar and enter “~/Library” (without the quotes) in the text box that opens.

     

    From the Library folder, move the entire contents of the subfolder Caches (not the folder itself) to the Trash, then log out and log back in. Empty the Trash. Test.

     

    If the problem is not solved, open the Library folder again in the same way and move the entire contents of the subfolder Preferences (not the folder itself) to a new folder on the Desktop (not to the Trash.) Log out and log back in. The account will then be pretty much in a clean state. Test. If you can still reproduce the problem, then put the Preferences folder contents back, replacing any that were created in their place, log out, and log in again.

     

    If you can't reproduce the problem in the clean state, then start putting things back in the Preferences folder piecemeal, starting with items that seem unrelated to the issue. I can’t be more specific. After each group of items, repeat the log out/log in cycle and test. At some point, the problem may reappear, in which case you know that something in the last batch of files you restored is at fault. If it never reappears, the problem is solved.

     

    This may be a very time-consuming process, but it’s the best I can suggest in the circumstances.

  • 23. Re: How can I change the language setting on my Mac?
    Alberto Ravasio Level 4 Level 4 (3,175 points)

    I'll also try to replace the user .GlobalPreferences.plist with the pristine .GlobalPreferences.plist located in

     

    /System/Library/User\ Template/English.lproj/Library/Preferences/.GlobalPreferences.plist

     

    If you have another admin user log in with that user, open Terminal, issue

     

    sudo cp /System/Library/User\ Template/English.lproj/Library/Preferences/.GlobalPreferences.plist /Users/your_username/Library/Preferences/.GlobalPreferences.plist

     

    sudo chown your_username:staff /Users/your_username/Library/Preferences/.GlobalPreferences.plist

     

    Logout and login as your usual user.

  • 24. Re: How can I change the language setting on my Mac?
    columbus new boy Level 1 Level 1 (0 points)

    Thanks guys, I'll try both over the next couple of days and get back to you.

  • 25. Re: How can I change the language setting on my Mac?
    Tom Gewecke Level 9 Level 9 (71,730 points)

    columbus new boy wrote:

     

    In language there are several languages listed..

     

    Is Italian listed?  If so, try using the Edit button to uncheck its box and then restart.  Doing this should not affect you ability to "use" Italian if you need to.

  • 26. Re: How can I change the language setting on my Mac?
    NG13ali Level 1 Level 1 (0 points)

    Hi Guys,

     

    I have same problem like you, language in every software is changed into my country language..

    I have done some test and it work, maybe it helps you to find out the solution..

     

    First i open System Preference>Keyboard> then you will see Show Keyboard & Character Viewers in ... you click Input Sources Then you click "Region" based on United States (Computer) Then click "Language" dont forget to thick out Italian language on your list.. then restart your computer tadaa..

     

    after the macbook turns on you may try open application and the language set into English.. 

     

    hope this help

     

    RD16GR512

  • 27. Re: How can I change the language setting on my Mac?
    Tom Gewecke Level 9 Level 9 (71,730 points)

    NG13ali wrote:

     

    you click Input Sources Then you click "Region"

     

    Before you can do the "Region" you need to click on "Formats".

  • 28. Re: How can I change the language setting on my Mac?
    hossam.alosh Level 1 Level 1 (0 points)

    i have similar issue. i bought a German keyboard Macbook 10.1. i shiftted the launguge to English completly but when i log out from any availbe user (2 users in my case) the German languge is still there in the longin Window. the three icons located in the middle bottoms (i belive they are tunr off, restar, ..) are read in German languge only. furthermore in the upper right conrer the key board icon always shows the Deutshc language although i have added Englishc and English-pc.

    i hope you can find more idea now to solve this issue.

  • 29. Re: How can I change the language setting on my Mac?
    Alberto Ravasio Level 4 Level 4 (3,175 points)

    I think the only option left for you, is going through the initial setup again.

    That does not mean you have to reformat your hard drive.

    There is a file (placeholder), /var/db/.AppleSetupDone that tells OS X that you already went through the very first phase when you unpacked the Mac and switched it on the first time.

    If you remove that file

     

    sudo rm /var/db/.AppleSetupDone

     

    and restart your Mac, you will be able to go back to that very moment and create a new Admin user. Please note that all of your actual data and user accounts will be preserved. After that you can get rid of the new admin user if you don't plan to use it in the future.

     

    The above command must be performed inside a Terminal window, using your admin user.

    Open Terminal application, issue the command, type your admin password when requested and confirm. Please note that the password won't be echoed on the screen, that is normal.

     

    Ça va sans dire, that does not prevent you to make a good backup before getting into those steps