10 Replies Latest reply: Mar 13, 2014 7:09 PM by MsquaredJa
phase52010 Level 1 Level 1 (10 points)

"Software Update can't connect to the Update Server" - so I can't even check to see if updates are available.

This has been going on for sometime.


For a while if I created a new admin account and used that it would work, but not today.

Tried creating a new admin account but to no avail.


So what happen's is this: I clcik on the Apple Icon, (top left hand side of screen), click on SOFTWARE UPDATE, it runs for a split second, then:




after which I check my internet connect to see that it's fine. (And I attempt to run SU with nothing else using the internet).




I've checked the forum and found a few people with the same problem.


I've tried deleting PLISTs and using DNS address, (https://discussions.apple.com/message/17852918#17852918), but still cannot get it to work.


Anyone have any suggestions?


And BTW: I still have my old G4 Power running OS 10.5.8 connected to the same modem (Netcomm NB6PLus4w Modem which has 4 ports) as my Mac Mini, and it runs Software Update without any issues. So it's not my internet connection and it's not the Apple server, so it's something about the Mac Mini that's not right. But what?


Thanks all.



Mac-Mini 2.4 GHz Intel Core 2 Duo - OS 10.7.2 - 8GB 1067MHz DDR3 Memory.

Mac mini, Mac OS X (10.7), Netcomm NB6PLus4w Modem
  • 1. Re: Software Update can't connect to the Update Server
    MadisonP Level 5 Level 5 (4,485 points)

    Greetings Robert,


    Sounds like a Network preferences issue on your computer.


    I would try:

    1. If you are running any anti-virus or firewall software, try turning it off.
    2. Boot to recovery and use Disk Utility to Repair Disk and then Repair Disk Permissions -- Test software updates again
    3. Clear your disk cache by resetting the PRAM -- Test software updates again
    4. Remove Macintosh HD > Library > Preferences > System Configuration > NetworkInterfaces.plist to the trash and restart your computer. 
      1. Once the computer is back up and running go to Apple > System Preferences > Network > Location > Edit Location > "+" to add a location and call it something logical like "Home".  Close Network Preferences and apply changes.  -- Test software updates again
    5. Download the Combo update on your other system and then bring it over to this computer and install it which may resolve this issue going forward: http://support.apple.com/kb/DL1484


    Hope that helps.

  • 2. Re: Software Update can't connect to the Update Server
    phase52010 Level 1 Level 1 (10 points)

    Sorry for the delay in replying. We moved house quiet unexpectedly, and it;s taken this long to get back online.

  • 3. Re: Software Update can't connect to the Update Server
    phase52010 Level 1 Level 1 (10 points)

    Hello Madison P;


    firstly, thanks for the detailed response.

    unfortunately, after doing as you suggested I've had no success.

    i still get the same message.


    it's very frustrating.


  • 4. Re: Software Update can't connect to the Update Server
    phase52010 Level 1 Level 1 (10 points)

    I'm still looking for an answer.


    I've reinstalled LION from the original disc. (Backed up after download).

    Didn't work.

    Upgraded to 10.7.3 with no change, still didn't work.


    Tried setting up a different ADMIN which used to work, but no longer does.


    I can download directly from the download page: http://support.apple.com/downloads/

    But SOFTWARE UPDATE still does not work.


    Does anyone have any idea why this has happened?

    Does anyone have any other suggestions to FIX IT.


    Thanks all.


  • 5. Re: Software Update can't connect to the Update Server
    MadisonP Level 5 Level 5 (4,485 points)

    Greetings Robert,


    As reinstalling the OS did not resolve the issue, that leaves 2 possibilities that I can think of:


    1. Your router is specifically filtering connections from the Software Update server to this particular computer.
      • To test this theory you would take your mac to a different network entirely (work, school, apple retail store, etc) or plug your mac directly in your modem, bypassing the router all together and then testing software update.
    2. There is something broken deeper in the OS than can be resolved just by reinstalling, which means an erase and install is required.



    Just in the unlikely event that this is in fact an issue with your router, try hard wiring your Mac directly to the modem (you may need to turn the modem's power off for a good solid 5 minutes for it to deliver Internet service to the Mac).


    If that does not resolve the issue then a complete erase of the Mac would be my next step.


    Before erasing be sure you have all your data backed up: http://support.apple.com/kb/HT1427

    Also make sure you have any important software that isn't available via download on disks so you can reinstall when your are done.


    To Erase:

    1. Startup to Lion Recovery
    2. Open Disk Utility
    3. Click on the drive you use to startup with on the left hand side (usually called Macintosh HD unless you have renamed it)
    4. Click "Erase" in the top middle
    5. Fill in a name (Suggested "Macintosh HD") and make sure the format is Mac OS Extended Journaled.
    6. Click "Erase" at the bottom right.
    7. Quit Disk Utility and proceed with reinstalling Lion.


    Once the reinstall is complete you will have a completely clean copy of Lion on your system.

    DO NOT restore your computer from your backup yet as you want to test to make sure the issue is resolved before you contaminate the system with potentially compromised data.


    The computer will ask you to create a new user account once the reinstall is complete.  Use a generic name like "test" for the account so you can get in and run software update to make sure it is working.


    Assuming software update is working at this point you can restore your data from your Time Machine backup using the Migration Assistant which is found in Macintosh HD > Applications > Utilities.


    This is important:  Do not restore your entire computer from the backup as this could bring the issue back.  Instead restore only your Users from the Time Machine backup which is one of the choices offered in the Migration Assistant.


    Once you've restored your users you can go to Apple > Logout to get out of the temporary "test" account and login as your normal user which will likely have your name on it.  You can then go to Apple > System Preferences > Users & Groups and remove the "test" account.


    You can then reinstall any applications as required from disks / downloads etc.



  • 6. Re: Software Update can't connect to the Update Server
    phase52010 Level 1 Level 1 (10 points)

    Hi MadisonP;


    once again thank you for such a detailed response.


    the new residence is still in a bit of a mess, and the computer setup is temporary, so i really don't want to get into any extensive backup and restorations just yet.



    i'll get back to you with results asap.



  • 7. Re: Software Update can't connect to the Update Server
    phase52010 Level 1 Level 1 (10 points)

    Still working on this issue.

    Still digging around. I'd really like to know what it is, because it seems a lot of people have experienced it, but no-one has posted a solution.


    Looking at the install.log:


    Jun  5 10:19:00 192-168-1-2 Software Update[632]: SoftwareUpdate Scan: Error Domain=NSURLErrorDomain Code=-1004 "Could not connect to the server." UserInfo=0x7ffecad45bb0 {NSUnderlyingError=0x7ffecad45040 "Could not connect to the server.", NSErrorFailingURLStringKey=http://swscan.apple.com/content/catalogs/others/index-lion-snowleopard-leopard.m erged-1.sucatalog, NSErrorFailingURLKey=http://swscan.apple.com/content/catalogs/others/index-lion-snowleopard-leopard.m erged-1.sucatalog, NSLocalizedDescription=Could not connect to the server.}


    Anyone know what that means? (I'll keep looking and post back if I find an answer).

  • 8. Re: Software Update can't connect to the Update Server
    andrewbevitt Level 1 Level 1 (0 points)

    I've been having the exact same problem on my home based network... plus I could not access AppStore or iTunes store. I have several devices  on the same network:


    One Snow Leopard install working properly for all services.

    One Lion install does not work - no updates, no iTunes store, and no AppStore.

    iOS devices work normally.


    I found that the problem was caused by having a .local domain for the network. This conflicts with the Automatic Proxy Discovery which uses multicast dns to do a link-local lookup for the WPAD server to fetch the proxy config file from.


    A few years back the Snow Leopard machine was joined to an AD domain that used a .local domain and I did this http://www.multicastdns.org/DLLC/ to get it to work (I'd forgotten about it until I went searching tonight for a fix); and iOS manually have the proxy servers turned off in settings so they couldn't care less what the domain was/is.


    I have literally just changed the network domain to .internal and everything works perfectly. If you can't change the domain then try the tool from the multicastdns.org link above (working on my Snow Leopard install).


    As for your 10.5.8 G5 - As I understand it 10.5 doesn't support auto proxy discovery so it won't care what the network domain is either. It appears support for auto proxy discovery was added in 10.6.


    AB: Edit to remove spelling typo

  • 9. Re: Software Update can't connect to the Update Server
    Alan Stone Level 1 Level 1 (5 points)

    Still using OS 10.9.0 and had the same problem. I turned off Little Snitch temporarily. Problem solved! Hopefully this is a clue that will help others.

  • 10. Re: Software Update can't connect to the Update Server
    MsquaredJa Level 1 Level 1 (0 points)

    Thanks for this. problem has been driving me nuts for months. Read this posts and checked little snitch rules and sure enout there was one blocking software update. Changed that and wallah, problem solved.


    Thanks a million