Skip navigation

iphoto imports upright photos as black

52219 Views 107 Replies Latest reply: Oct 16, 2013 9:38 AM by Old Toad RSS
  • Sebastian Gebhard Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 2, 2012 12:21 AM (in response to david_mbp)

    I have also noticed this behavious. I import my pictures from SD card an take them with an Canon EOS 550D. Portrait photos are black, but they show up, as soon as I go to edit.

     

    Hint: If you just change one of the settings (like lighting or exposure), or even if you do the auto-improve, the pictures show up correctly again!

     

    @tommyc19

    I do wonder, why Apple Care said, that they don't know about the issue. I reported that bug 2 weeks ago.

    Keep on bugging them! I just did a photoshooting with 500 pics and one third of them are black *grrr*

  • tommyc19 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 2, 2012 5:33 PM (in response to Sebastian Gebhard)

    @Sebastian Gebhard.... I have tried the suggestions of changing the photo's in the editing section of iPhoto and it works for some of the them but NOT on all of the photo's, .... This is a nightmare Grrrrrrrrrrrrrrr!

     

    Also, when I import the portrait photo's into Facebook (after changing them in edit mode, so they become visable as a thumbnail Grrrrrrrrr!) some of them are Black again... Grrrrrrrrrrrrrrrr!

     

    THIS IS A JOKE!!!!!

     

    I am not supprised at all the AppleCare told me that they have not heard of this problem.... They won't acknowledge this until they Tech guys can start working on a solution.....

  • hyl046 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 3, 2012 6:35 PM (in response to david_mbp)

    i have the same problem too when I import photos from my iphone...i don't think it's only photos that are edited since some of my photos taken straight from iphone camera wont show as well. I can only see black images in the display of iphoto but if i choose edit then i can see my photos. My solution right now is just to edit every photo (i always choose "enhance") and that works; images will show in the display. I really want to figure out a real solution to this though!!!!

  • kingturtle Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2012 5:03 PM (in response to david_mbp)

    I also have this problem... and now that I learned that I can edit, my work-around is to rotate the photos 4 times (to get back to the original orientation), and they seem to appear ok from that point on (even after quitting and restarting iPhoto).  annoying... but seems to work for me.

  • Buadhai Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2012 5:10 PM (in response to kingturtle)

    As I said earlier, all of this indicates that the problem is with the EXIF data, where orientation information (portrait or landscape) is stored. By rotating or otherwise editing the photo you are rewriting the EXIF data making the image compatible with iPhoto.

     

    Has anyone tried simply deleting the EXIF data before opening the image in iPhoto?

  • Justin Bur Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 6, 2012 6:34 PM (in response to david_mbp)

    This problem is, indeed, amazingly irritating. As it makes iPhoto look very bad for a lot of users, I would have hoped that fixing it would be a higher priority. However, it doesn't affect iPhone pictures, only the 3:2 aspect ratio pictures from my Nikon DSLR...

     

    There is a quick and easy non-destructive workaround (must be applied to all freshly imported portrait-orientation pictures).

     

    1. Select all the black portrait-orientation photos.

    2. Photos menu > Rotate (command-R).

    3. Photos menu > Revert to original – and confirm in the alert dialog that pops up.

     

    That should tide us by until the fix eventually shows up.

  • Buadhai Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2012 7:03 PM (in response to Justin Bur)

    Which further demonstrates that the problem lies with the way the EXIF data is stored. Rotating the image in iPhoto causes iPhoto to rewrite the EXIF data.

  • Justin Bur Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 7, 2012 5:10 AM (in response to Buadhai)

    Maybe that's true, but there's certainly no demonstration of it.

     

    Photo files are written by cameras always in the same (landscape) orientation. Portrait photos are tagged to indicate they should be rotated. Viewing software like Preview or the Finder takes notice of the tag and adjusts the orientation on the fly. iPhoto, on the other hand, chooses to rewrite the photo with the rows and columns flipped, at the time of import. Something is going wrong at this stage: the rewritten, reoriented photo is black.

     

    When iPhoto does this rewriting, the new version is saved as if it were a manual edit (under the File menu, Reveal in Finder, you will see both Modified File and Original File for all portrait-orientation photos). But this new version is not marked as changed, so the Photos > Revert to Original menu item is greyed out. By performing a rotation (my step 2), we're just doing something, anything to get the files marked as changed. Then (my step 3) we do a revert. This throws away both our rotation, and the original rotation performed at import time. It causes iPhoto to go back to the original landscape-orientation file from the camera and redo the rotation. And it gets it right this time, problem solved.

     

    So we're not really rotating the image in iPhoto; we're provoking an undo, which forces iPhoto to automatically redo a rotation which is not just a metadata tag but an actual decoding, rearrangement, reencoding of the image data.

    Buadhai wrote:

     

    Which further demonstrates that the problem lies with the way the EXIF data is stored. Rotating the image in iPhoto causes iPhoto to rewrite the EXIF data.

  • Buadhai Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 7, 2012 6:26 AM (in response to Justin Bur)

    What you call "tagging" is the orientation tag in an EXIF file. For example, in a portrait image file my Canon camera produces an EXIF orientation tag as follows:

     

    Orientation: Rotate 90 CW

     

    My guess is that the Orientation Tag produced by some cameras for portrait oriented images causes iPhoto to fail to render the image. The steps you go through causes the entire EXIF data to be rewritten by iPhoto, correcting the incompatible EXIF file produced by the camera.

     

    So, you're right, you're not rotating the image, you're just forcing iPhoto to write compatible data to the EXIF file.

  • ul7x Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 10, 2012 11:00 PM (in response to Buadhai)

    This same problem happens to me with Pictures taken using the iPhone 4S camera in Portrait mode. One would think that the tags produced by Apple's own camera would be compatible with iPhoto, no? This is a serious bug with no solution as far as I can see. I've tried all of the suggestions posted here to no avail.

     

    "My guess is that the Orientation Tag produced by some cameras for portrait oriented images causes iPhoto to fail to render the image. The steps you go through causes the entire EXIF data to be rewritten by iPhoto, correcting the incompatible EXIF file produced by the camera."

  • Spencer Wood Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 13, 2012 7:35 AM (in response to Buadhai)

    I agree with Buadhi, it appears to be a problem with the EXIF data tags...I just opened up an offending picture in Preview, and saved a version, and it worked....I'm guessing it could be a problem with the camera software on the Canon as well...

     

    It does suck, but it is fixable..

  • bthomas310 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 14, 2012 8:11 AM (in response to tommyc19)

    Hi Tommyc19, I have an almost identical configuration and issue as you. I found a fix (see below) but its still a PAIN and annoyance to do this for every photo.

     

    I wanted to see if there was a better way you/anyone else found to address on or before the import?

     

    My Setup:

    1) MacBook Air OSX 10.7.3

    2) Canon 60D - settings on Large size (3456 x 5184), High Quality JPG ( 8->10 MB)

    3) iPhoto 9.2.3 (626)

    4) All Vertical/Portrait Photo Previews are BLACK

     

    My Solution:

    For each Picture, Go into Edit Mode and then make a change (Rotate, Enhance), save this version (just go back to thumbnail library.

    ** I also tried highlighting several pictures and doing group editing but iPhoto crashes when saving.

     

    Any update on what Apple Support/Care told you?

     

    I don't think they care or know the best fix but this is a real issue that need's attention Apple!

  • LarryHN Level 9 Level 9 (54,900 points)
    Currently Being Moderated
    May 14, 2012 8:13 AM (in response to bthomas310)

    I don't think they care or know the best fix but this is a real issue that need's attention Apple!

    This is strictly a user to user forum - Apple does not monitor nor do they respond here - to tell Apple something - iPhoto menu ==> provide iPhoto feedback

     

    LN

  • luggate Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 21, 2012 5:42 PM (in response to LarryHN)

    I don't know if everyone has the same symptoms as me but I think my findings are telling.  If you actually open up the iPhoto Library folder, there are three folders, Master, Previews and Thumbnails.  For me, all the portrait photos in both the Previews and Thumbnails folders are black.  However, those same photos in the Masters folder appear correctly.

     

    For example, in Terminal.

    cd ~/Pictures/iPhoto Library

    open Masters/2012/04/19/20120419-221840/DSC_0329.jpg

    open Thumbnails/2012/04/19/20120419-221840/DSC_0329.jpg

    open Previews/2012/04/19/20120419-221840/DSC_0329.jpg

    These are the same image file DSC_0329.jpg, in the same directory structure but only the one in Masters is correct, the other two are black.  Obviously this is just an example and not everyone will have a photo at this path but I'm curious to see if others can find this same issue.

     

    FYI, I have a Nikon D3100, others have noted an issue with Canon cameras as well as the iPhone.  So how can this be blamed on the camera?

     

    I've sent my issue over to Apple, hopefully they release a fix.

  • dtklamf Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 22, 2012 11:57 PM (in response to david_mbp)

    yes that is my issue.

    masters folder - fine

    previews folder - black

    iphoto app - black

     

    if i delete & reimport those masters i get black previews again

1 2 3 4 5 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.