6 Replies Latest reply: May 7, 2012 8:55 AM by dalstott
JohnHardcastle Level 1 Level 1 (0 points)

I am a recent convert to the Mac. I have not found it an easy transition: not by any means. Absolutely love the iPhone and my iPad - but the MacBook Pro has been a huge disappointment. It is in serious danger of becoming nothing more than just a nice thing to look at. I am really struggling to get to grips with what are much more than just nuances over Windows.

 

My latest problem concerns .pdf's opened in Preview. I am sure that, initially, I had no problem with "saving a version" - now, all of a sudden it says that:

 

"... could not be saved. You don’t have permission."

 

It tells me to find the document in Finder, and then look in "get info" - I do that. I have Read and Write permissions. I have unlocked the document, I have given "others" read/write permissions - I have tried everything, but still no joy.

 

I am sure that this is just something obvious... please enlighten me!


MacBook Pro, Mac OS X (10.7.3)
  • 1. Re: Cannot save a .pdf opened in Preview
    Linc Davis Level 10 Level 10 (117,895 points)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.

     

    Back up all data now. Before proceeding, you must be sure you can restore your system to its present state

     

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    Open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy — do not type — the following line into the Terminal window, then press return:

     

    chmod -R -N ~

     

    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:

     

    sudo !!

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.

     

    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

     

    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

     

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens. You’re not going to reset the password.

     

    Select your boot volume if not already selected.

     

    Select your username from the menu labeled Select the user account if not already selected.

     

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

     

    Select ▹ Restart from the menu bar.

  • 2. Re: Cannot save a .pdf opened in Preview
    JohnHardcastle Level 1 Level 1 (0 points)

    Hi, I am very grateful for the rapid response to my question. What puzzles and disturbs me, however, is how and why this is required: I have not done anything other than surf the net, install Microsoft Office and create/open/edit a couple of Word documents and open a few .pdfs - how/why do I find myself in this position?

     

    This is really disturbing and I'm not convinced I like the idea of the steps that I have to take to resolve this. I have been an iPhone user for over 3 years and have found it inuitive and rock solid; very user friendly. Likewise with my iPad 2 that I have had for a litte under a year... but the MacBook - nothing seems easy or inuitive and I have absolutely no idea how or why I find myelf in a position where I am having to perform some sort of laborious factory reset. I just don't get.

     

    Disappointing and frustrating - but thank you for your help Linc Davis... I'm not sure I'm confident enough to try this though.

  • 3. Re: Cannot save a .pdf opened in Preview
    Linc Davis Level 10 Level 10 (117,895 points)

    Then you'll have to adapt to using a permanently crippled computer.

  • 4. Re: Cannot save a .pdf opened in Preview
    dalstott Level 4 Level 4 (2,530 points)

    You could try the print and save as pdf. Open the pdf in Previer and then select print from the file menu or press command-P keys. In the lower left corner is a pdf button which when pressed gives you the option to save as a .pdf document.

     

    Screen Shot 2012-05-06 at 10.45.35 AM.jpg

  • 5. Re: Cannot save a .pdf opened in Preview
    JohnHardcastle Level 1 Level 1 (0 points)

    This worked!

     

    What I find mystifying is the fact that I have now discovered that some .pdf's are still "savable" from preview by way of "save a version".

     

    Could it be thatthe .pdf's from this particular site have now been protected with some sort of copyright protection (even though I have a license to save documents from this particular site)?

  • 6. Re: Cannot save a .pdf opened in Preview
    dalstott Level 4 Level 4 (2,530 points)

    There must be some kind of protection code as I too have had the same issue. It sometimes will not allow the print window to show a preview of the page and will only print a blank page. I get around this by copying and pasting to something like Pages or I take a selection screen shot (shift-command-4) and save it as a pdf via print command.