Skip navigation

AirPrint working on one idevice but not others

847 Views 6 Replies Latest reply: May 11, 2012 8:11 AM by lbenoitg RSS
Shahcrew Calculating status...
Currently Being Moderated
May 7, 2012 9:20 AM

I have a 3GS iPhone that allows me to use AirPrint without any trouble ( I haven't updated the software on it), but none of the other devices, iPhone 4, iPod 3, new iPad, allow me to use AirPrint, error No AirPrint printers found.

 

It's a foregone conclusion that the printer is AirPrint compatible, it works on the one device without issue.

 

I've tried resetting the printer, setting it up wirelessly, installing third party AirPrint software on the pc. I've checked to see if it can be found on the network using epsons printer finder app, everything is as expected. I've also updated iTunes on the pc, so it's the latest revision, and synced the pad with it ( I thought there may be an authorisation issue)

 

Nothing that I've tried has worked, the old iPhone still prints to the printer but no other devices will.. I am tearing what little remains of my hair out trying to resolve this :(

iPad Wi-Fi + 4G, iOS 5.1
  • pjl123 Level 5 Level 5 (5,450 points)
    Currently Being Moderated
    May 7, 2012 9:35 AM (in response to Shahcrew)

    It may be as simple as rebooting the router, and letting it find your devices again.  Try that.

  • pjl123 Level 5 Level 5 (5,450 points)
    Currently Being Moderated
    May 7, 2012 1:58 PM (in response to Shahcrew)

    I have really never heard of a model that was AirPrint not working with ios5.1. Really strange, as that will mess up a lot of folks.

     

    What make and model printer are you talking about?  I would like to poke around a little.

  • jalf007 Calculating status...
    Currently Being Moderated
    May 8, 2012 8:55 PM (in response to Shahcrew)

    I'm having the same issue, it is very frustrating!!! I'm using the iPhone 4s and the iPad 2 and none of my devices are detecting my printer, good thing a read this because I was about to call HP and... Well let's just say that I didn't plan on having a friendly conversation with them!!

  • lbenoitg Calculating status...
    Currently Being Moderated
    May 11, 2012 8:11 AM (in response to Shahcrew)

    Same issue here my iPhone 4S (OS 5.1.1) finds the airplay printer HP LaserJet CP1025nw but my New iPad (OS 5.1.1) don't, I've rebooted the router but still the problem remains any ideas?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.