Skip navigation

TextEdit quarantines files

1925 Views 5 Replies Latest reply: May 22, 2012 6:49 AM by Bradley Ross RSS
hurbas Calculating status...
Currently Being Moderated
Feb 2, 2012 10:55 PM

After an OS X Lion update which happened this afternoon, TextEdit is suddenly behaving in a strange way.

When I open a bash script with TextEdit and leave the script unchanged, the script still runs normally.

But as soon as I hit any key on the keyboard (even without saving the file), the script cannot be run any

more and, assuming the script's name is kaps, I get this message:

 

-bash: ./kaps: Operation not permitted

 

If I issue the command xattr kaps, I get this:

 

com.apple.TextEncoding

com.apple.quarantine

 

If I reset the xattr, the file will run again, but as soon as I modify the script with TextEdit, the above

happens again. And this occurs with any script (old or new).

 

Strangely enough, this seems to affect only files run with the  x attribute (chmod +x), because, even

if they are now quarantined, the scripts can be run if sourced (ex:   . kaps  o r   bash ./kaps).

 

Any idea how to prevent TextEdit from arbitrarily quarantining the files it edits?

iMac (21.5-inch Late 2009), Mac OS X (10.7.2)
  • Thomas Halenbeck Calculating status...
    Currently Being Moderated
    Feb 9, 2012 9:39 AM (in response to hurbas)

    Same here. After updateing to 10.7.3 all my Shellscripts do not run anymore.

     

        -bash: ./my_shellscript.sh: Operation not permitted

     

    I have no idea. All permission are still as correct as they used to be prior 10.7.3. To say it harmless: Lion is not the best Apple ever made. I do not like it to much

  • Thomas Halenbeck Level 2 Level 2 (395 points)
    Currently Being Moderated
    Feb 9, 2012 11:38 PM (in response to hurbas)

    Yep, same here as well. I had this symptom as well. Not with all files but with some.

    No idea what happened, since it is not reproducable. Just the same as with my "Operation not permitted" problem. I found out that this is not reproducable as well!  It happened that I just needed to open the ShellScript  with TextEdit. Just to open it was sufficient No changes, nothing! If I now started the script on the command line it worked as expected !!!???   Lion is

  • tombaeyens Calculating status...
    Currently Being Moderated
    May 8, 2012 2:04 AM (in response to hurbas)

    Same problem here.  It seems silly that you're not allowed to execute a shell script that you just edited in TextEdit.

  • Bradley Ross Calculating status...
    Currently Being Moderated
    May 22, 2012 6:49 AM (in response to hurbas)

    It looks like using XCode to edit script files does not set the flags.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.