Skip navigation

OSX Lion + 2011 iMac 27'' + Video = Freeze

350977 Views 1,999 Replies Latest reply: Apr 15, 2014 3:02 PM by cimbalino RSS Branched to a new discussion.
  • crapplestout Calculating status...
    Currently Being Moderated
    May 4, 2012 7:24 AM (in response to Gigabitten)

    I just did my research before posting this, so please let me know what article you've read that tells you otherwise, but CTRL+SHIFT+EJECT is for immediately turning off your display, not switching graphics cards. This has been a keyboard shortcut for a few versions of OS X now and I have found nothing that states that this shortcut has been modified to switch graphics cards. It simply turns your LCD off, which may be just the kick it needs to unfreeze the login screen and other lock-ups. I'm looking forward to trying. Thank you for posting that.

  • Gigabitten Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 4, 2012 8:05 AM (in response to crapplestout)

    I was referring to the article link I posted that that author states it forces the system to use the intagrated graphics, not sure what it does exactly-- but it works. I'm just letting everyone know what works for us when the screen goes black. We don't have the lockup/kernel issues (yet). Apple has been on this for weeks with us with no answer except to take them both to the apple store, which will render my art dept without machines to work on. This quick fix has saved us in the meantime so we can work out the repair details. We need to get temp machines in house, transfer all apps/settings so we can work daily while they (hopefully) find an answer to the blackouts.

  • thibaultfromversailles Calculating status...
    Currently Being Moderated
    May 7, 2012 8:34 AM (in response to rubenlx)

    Same here. Since yesterday my 27 iMac crashes randomly. I thought it was the GC, then the heat, tried to monitor it with ultrafan, but to no avail.

     

    Why on earth did I upgrade from SL????

     

    Anyway, I'll try the  + Shift + Eject combination.

     

    If anyone has good news, keep us posted...

     

    Thanks a lot for the tip

  • Gigabitten Level 1 Level 1 (0 points)

    Control + Shift + eject, not command. This only works for getting the black monitor to come back if the machine is still running.

  • Andrew Humphreys Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 7, 2012 5:17 PM (in response to jjjjjjb)

    jjjjjjb,

    I get the exact same corruption on my Mid-2010 27" iMac (with an ATI 5750) along with horrible corruption using Quicklook and the Finder but I'm running 10.7.3. I'd assumed this was Lion-specific but if you're seeing it in Snow Leopard it might be a hardware issue, Which version of 10.6 are you running? Maybe later versions (after 10.6.4) introduced newer graphics drivers which are causing the problem.

    You should also take a look at this thread:

    https://discussions.apple.com/thread/3199218

  • thibaultfromversailles Level 1 Level 1 (0 points)

    @ Gigabitten: I tried crtl+shift+eject, it didn't work, although the machine was running, I could even hear the sounds of the game I was playing...

     

    @ Andrew Humphreys: I am running Lion 10.7.3. I just regret I didn't keep SL, because I had no bug at that time.

     

    My GC is a  ATI 4850.

     

    I did further testing, with the help of ultrafan to decide at what t° the fans should kick-in at full speed, and I noticed that the t° had nothing to do with the crash, but more the starting of the fans.

    Each time the fans start, be it at 45, 50 or 55°C, it comes along with a full black screen, even if the computer is still working. HDD is running, and I can even hear the characters speak in the computer game I use to have the computer heat up quickly.

     

    I don't get it: is it a power supply thing? i.e. when the fans starts to run there is a default and screen has to stop?

     

    I really don't know....

  • Gigabitten Level 1 Level 1 (0 points)

    @thibaultfromversailles  After you use the key combo, wait a moment then hit any key, like the spacebar. The screen should come back.

     

    hope this helps

  • luibargi Calculating status...
    Currently Being Moderated
    May 8, 2012 12:55 PM (in response to rubenlx)

    Let me join the list..

    iMac 27" December 2010 - RAM 8 GB 1333 MHz DDR3 - ATI Radeon HD 5750 1024 MB - Mac OS X Lion 10.7.3 (11D50b) - HD 1TB

    Upgraded to Lion soon after its release, my Mac worked lovely without the slightest problem for 16 months.

    About one week ago started having this problem, the screen goes blank but the machine keeps working (I can hear the HD scratching noise and scanner running if I was using it).

    Differently from other users I am never working on videos or graphic SW, just browsing (Firefox and Safari) or doing some Office document.

    Also crtl + shift + eject does not sort any effect, nor hitting any key; I have to push power button three or four times then the machine comes back to life. At that moment is like reverting from sleep, I hear the flatbed scanner and the external HD coming to life too.

    Working on the Preferences > Energy saving and setting to minimum time for Computer and monitor sleep (say 5 to 10 minutes) the black screen comes every 10 to 15 minutes while setting to higher values (say 2.5 and 3 hours) it happens 3 or 4 times a day only (I use the Mac for 7-8 hours/day).

    I have no memory of when was the last system update but it was not long ago, so I tend to believe that the problem is in the last update.

    I hope this helps Apple people to find a solution.

    Btw I don't have a temperature or fan controller but by the touch I can tell the Mac is not overheating

  • JachyRawr Calculating status...
    Currently Being Moderated
    May 9, 2012 11:56 AM (in response to rubenlx)

    Let's see... I have my iMac from mid 2011 with 27" and OSX Lion...

    I brought it back from the Apple store for the third time

    In the second time they changed the HD and it keep randomly freezing

    now they changed BOARD,LOGIC,2.7GHZ,QUAD-CORE I5   and CABLE,HDD DATA  

    And guess what?!... They freezing issue is still there...

    Here some videos:


    http://youtu.be/6gZuSiyl1OA

    http://youtu.be/14bRk0EZ8Oc

    http://youtu.be/Pb6CNhr73E0

     

    Sorry my english is not my main languaje but anyways.


    Any how im gonna be on the phone with an Apple representative... and let's see what will happen from now.


     


     

    Message was edited by: Host

  • Gandalf The Grey Level 2 Level 2 (275 points)
    Currently Being Moderated
    May 9, 2012 7:36 AM (in response to JachyRawr)

    I had the same thing happen to my June 2011, 3.4GHz i7 with 16gigs of memory iMac. After the 3rd time I asked for a in-store credit and they gave it to me. My only issue is I am using a Mac Mini with there Thunderbolt display and this thing is slow by comparisons.  When I had my iMac it was the fastest machine I have ever owned only to be put in downtown New York City during Rush hour when I put Lion on it. All I an say is CALS!!! Abbreviation for something that should be done!!

  • Rentu Calculating status...

    Sorry I haven't updated my status in a while. When I took the iMac (mid-2011, 27", 8GB, 10.7.2) back to Apple the 2nd time, I showed all the pics and vids I took with my iphone and told them it's got to be an issue with the gfx card. They replaced it in a week. It's been over 2 months going on three and I haven't seen the issue (black screen, gray screen, semi-freeze, or any artifacts) since.   I am shocked to see this thread still going.  I use my iMac for business and pleasure and have had zero issue since the video card replacement.

  • TimoAbram Calculating status...
    Currently Being Moderated
    May 9, 2012 9:48 AM (in response to Rentu)

    My problem was solved too, when the service guys replaced my Graphics card.

    After that, for more than a month, there has been zero issues.

    Working Like it should be.

  • Justanotherdriftwood Calculating status...
    Currently Being Moderated
    May 9, 2012 12:08 PM (in response to TimoAbram)

    My 27" iMac (2011) just started freezing for the first time 3 days ago.... before that I had no problems whatsoever.  The only thing I've installed lately is Google Drive.

  • Andrew Humphreys Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 9, 2012 1:31 PM (in response to JachyRawr)

    @JachyRawr: Hate to say it, but I think you'll have to take your iMac back to the Apple store again and get a replacement graphics card. Clearly that's where the problem lies.

    @ Renru and TimoAbram: Glad that replacing the graphics cards worked for you.

     

    Doing a little digging around, I've discovered that there have been plenty of problems with ATI Radeon HD graphics cards in Windows PCs as well - the very same cards that Apple has used in the majority of newer iMacs. Take a look at this discussion for example, which is eerily similar to the problems we've experienced in Lion:

     

    http://www.tomshardware.com/forum/276896-33-radeon-5750-display-driver-stopped-r esponding

     

    Apparently the power saving modes on the graphics cards use a very low core clock speed and memory clock speed, which leads to stability issues. On the PC side, the problems have largely been fixed by ATI driver updates and in some cases BIOS (firmware) updates. You can also use ATI's Catalyst Control Centre on a PC to tweak the card's core and memory clock speeds.

    I suspect the issue at least on some iMacs is the same. The hardware itself is generally NOT faulty but replacing the graphics card with a newer card with a newer BIOS will fix the problem. What's really needed is a firmware update for affected graphics cards and better ATI drivers.

    There have been no graphics firmware updates for mid-2010 iMacs but there are updates available for Late 2009 and 2011 (Mid and Late) iMacs. Links are available here: http://support.apple.com/kb/HT1599

    If they apply to your machine, they might help.

    Using Boot Camp and a variety of Windows tools I've extracted the BIOS from my iMac's graphics card (an ATI 5750, which is really a Radeon Mobility 5850), raised the lowest core and memory clock speed and re-flashed the card. So far everything has been working fine, but it's only been a day or so and it definitely needs more testing. Fingers crossed.

  • luibargi Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 10, 2012 2:53 PM (in response to rubenlx)

    So it looks like the GC has to be replaced, even though it sounds strange for having been good for 16 months.

    I bought my iMac  on early Jan 2011 so it must be a production of late 2010.

    Will "iMac Graphic FW update 2.0" for Middle 2011 work for my machine too?

    Thanks for any reply.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (99)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.