11 Replies Latest reply: May 8, 2012 5:42 PM by Matinicus Rock
Matinicus Rock Level 1 Level 1 (110 points)

Hello FCP Gurus,

 

So I just bought FCP-X, not thinking that it would effect my current beloved FCP7.  But low and behold, after installing, it reduced my FCP7 to FCP5!  And then when I downloaded the ProApps update 2010-02 to upgrade back to 10.7, it told me that my computer doesn't need the update!  So now I have all my FCP7 projects that can't be opened in FCP5 because they're "too new!"  Any suggestions???

 

Thanks!


Mac Pro, Mac OS X (10.7.3)