Skip navigation

Configurator - Apple ID Not Authorized

36687 Views 37 Replies Latest reply: Sep 12, 2013 7:49 AM by nsdjoey RSS
1 2 3 Previous Next
jewiebe Calculating status...
Currently Being Moderated
May 2, 2012 8:31 AM

I've been testing Apple Configurator in hopes that we can use it to pre-install our MDM application onto our iPads and iPhone before they are sent to the users.


However, when I try to prepare a blank iPad, configurator gives the error that the Apple ID is not authorized. I have signed in to configurator with an Apple ID that has downloaded the (free) app, and this iMac is authorized in iTunes (and currently signed in to the iTunes store).


Is there something that I'm missing?


Apple Configurator, Mac OS X (10.7.3)
  • gyrhead Level 3 Level 3 (785 points)
    Currently Being Moderated
    May 2, 2012 9:07 AM (in response to jewiebe)

    Make sure the computer running configurator is authorized for the itunes account you are using to log into configurator.

  • gyrhead Level 3 Level 3 (785 points)
    Currently Being Moderated
    May 2, 2012 9:22 AM (in response to jewiebe)

    You need to authorize the computer running configurator with a different apple id than the one that was used to obtain the app.

  • harryfromreston Calculating status...
    Currently Being Moderated
    May 3, 2012 7:52 AM (in response to jewiebe)

    Firstly, i have this problem too.  Secondly, gyrhead seems to have two contradictory suggestions, but perhaps I am missing a nuance.  Oh - now i see (after writing the rest of this message). The preference setting i found requires and Apple ID, and i think it must be a special VPP program apple ID? Didn't know what "log into configurator" -- but i think understanding those two messages is key. Will re-read the docs.




    I have logged into iTunes and alunched the configurator from one computer, downloaded a free app, then attempted to use configurator from THAT mac to intitialze a set of iPads in a Bretford tray.


    I think this means i must have authorized this computer for that apple ID. I even tried authorizing the ipads by connecting them to the store and downloading free apps, and set authorized them for the same app id.


    I see that configurator itself has preference seting for apple ID, and it says "The Appl eID used in the Itunes Store on this Mac to redemm VPP redemption codes and download apps. This is not the VPP PRogram Facilitator's Apple ID."   I know this is not a VPP Program Facilitator's Apple ID; i am not sure if this means i Should use the VPP Program Facilitorto's Apple ID or if this means that it SHOULD NOT be as it won't be used that way.


    In any event i just want to install and manage FREE apps, and don't have a VPP Program account.


    With one regular Apple ID intended for use with free apps, i can't make this work.

  • christopher274 Calculating status...
    Currently Being Moderated
    May 4, 2012 8:28 AM (in response to harryfromreston)

    If you are only deploying free apps, do not put an Apple ID in the Configurator preferences. Configurator will authorize the app on the devices by using the Apple ID that 'purchased' the free app. This Apple ID must be authorized in iTunes on the Mac that is running Configurator.

  • christopher274 Level 1 Level 1 (30 points)
    Currently Being Moderated
    May 7, 2012 9:26 AM (in response to jewiebe)

    When you add the app to Configurator, is the app listed as 'Free' or does it have or little warning indicator next to it?


    If it's marked as 'Free', try moving your Configurator preferences file out of the way.

  • christopher274 Level 1 Level 1 (30 points)
    Currently Being Moderated
    May 7, 2012 9:54 AM (in response to jewiebe)

    Shut down Configurator, got to ~/Library/Preferences, and rename or move This is your preferences for Configurator. It will be recreated when Configurator is started again.

  • christopher274 Level 1 Level 1 (30 points)
    Currently Being Moderated
    May 7, 2012 10:17 AM (in response to jewiebe)

    Are you looking in /Library/Preferences /Users/<yourusername>/Library/Preferences? ~/Library = /Users/<yourusername>/

  • harryfromreston Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 8, 2012 12:55 PM (in response to jewiebe)

    "If you are only deploying free apps...".  How is this relevant? If you are getting apps from the app store, they are digitally signed, free or no.  Does your purchase / download get you a version signed with the app ID you are buying with? I thought that was true.  If so, you'd have to have that signer's certificate on every machine you want to run the app on.  Or are free apps different? or only signed by apple and the developer, so signatures are irrelevant to this challenge of using configurator to push apps out to multiple devices?

  • Sinjef Calculating status...
    Currently Being Moderated
    May 8, 2012 4:25 PM (in response to jewiebe)

    I had this same issue. My resolution is below.


    1. Apple Configurator - Preferences - General - Apple ID - Set this to the iTunes account you used to download the application (doesnt matter if it was a new download or you are redownloading it from the cloud.)


    2. Make sure your computer is authorized inside of Itunes. ( ITunes - Store - Authorize this computer).


    3. Delete out the apps from Apple Configurator - Click Apply - If you are using a profile then refresh it - Import the apps again - Click apply. (Probably just need to delete out the apps and then import them again, but these are the steps I took.)


    Should work this time



1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.