Skip navigation

Deploying Profiles in Unsupervised Mode with Configurator 1.0.1

12287 Views 24 Replies Latest reply: Jul 20, 2012 3:31 PM by scsdlink RSS
1 2 Previous Next
alexanderstein Level 1 Level 1 (0 points)
Currently Being Moderated
May 9, 2012 3:55 AM

When I attempt to use Apple Configurator with 30 iPad2's with a MacBook Pro (Lion 10.7.3), Apple Configurator 1.0.1, and Bretford cart in Unsupervised Mode.  With two profiles assigned in the prepare stage (enforcing a passcode requirement and adding web clips; not that complex at this testing stage), it never completes.  The status of all devices after completion:

 

Tap device to install profile.

 

Naturally, I could not do that with 30 of these devices at once, so after only a minute or so of this it will error out sequentially saying:

 

Can't install profiles.

 

I still can run through the setup assistant and everything else on individual iPad's, but it will definitely mess up any attempt at seriously prepping these things for deployment in advance.  Is this seriously by design?  We are piloting these devices at the instution, and Apple's promise of the Layered Ownership Model is still Institutionally Burdensome (excuse the pun).

iPad 2, iOS 5.0.1, Lion 10.7.3 & Configurator 1.0.1
  • gyrhead Level 3 Level 3 (785 points)

    It has been my experience that once you take the devices out of the cart you will be able to tap and install the profile and everything will be set up the way you wanted it to be.  It is still a pain to have to do this for each device.  Apple's ingrained philosophy is oriented around individual ownership and these types of hassles are the result.

  • gyrhead Level 3 Level 3 (785 points)

    "tap" to install profile.  I have to go through the steps too.  I keep the devices connected but have never tried doing it unconnected.  Just noticed that IOS 5.1.1 is out...........

  • christopher274 Level 1 Level 1 (30 points)

    Why did you choose not to supervise these devices? This seems like the classic use case for supervising.

  • Stephanie Griffin Calculating status...

    I have a similar problem- can't install the profiles error if I wait too long to tap the devices.  In fact I have two profiles to install, and it seems like if I don't immediately respond to the "tap to install profile" prompt, then the second profile doesn't even try to install.  Apple configurator throws the error.

     

    I'm doing these unsupervised, with two profiles (wireless and calendar).  The wireless profile install comes up on the five devices I'm testing right now.  I tap to install while still plugged in.  Wireless profile installs.  But tapping twice on five machines takes a minute or so, and by the time I'm done I've got the error message saying the profiles can't install, and the second profile (and renaming process) doesn't load up to install.

     

    Any ideas?  Help?  I started with a third profile too for a  passcode, but took it out of the mix to keep it simpler.

  • gyrhead Level 3 Level 3 (785 points)

    You can set up a single profile that includes passcode, wireless settings, calendar, etc.. I don't understand why you would want to separate these out..........I have set up email, calendar, wireless, passcode, etc. in a single profile with no issues installing.  If you have devices that require different settings just set up a different specific profile for those.

  • Rwickberg Calculating status...

    I have the same setup as the OP, but I connected one ipad to the mac with the configurator so I COULD tap once, to see what it would do next.  When I did, nothing happened.  I also tried to step through the setup screens, but can't complete that before the configurator times out. 

     

    In answer to potential questions, I set them up as unsupervised because they're going to teachers.  I just want to update iOS, set up the wireless, add a web clip that points to our student information system, and preload a couple of apps I think everyone should have.  I don't want the teachers to not be able to sync to iTunes.

     

    So what gives?  I tells me to tap, but doing so does no good.

     

    All the profile does is set up the wireless and load the web clip.  The configurator will do the rest without loading a profile.  Is loading a profile simply incompatible with not supervising the iPad?

  • SEG-IT Level 1 Level 1 (0 points)

    Setup one iPad with the profiles you want. Backup that iPad (Menu -> Devices -> Backup) and then Restore with that backup (Erase before installing is optional).

     

    If you add a profile requiring a passcode, when the new user logs in, they haveup to 60 minutes to create the passcode ... nice.

     

    I think layering the profiles is a good idea. For example, if you need to change a wireless password, you can just email that to your users and they can remove the old one and install the new one.

     

    Message was edited by: SEG-IT

  • Rwickberg Level 1 Level 1 (0 points)

    This doesn't address the issue that I can't seem to put a profile on an unsupervised machine at all, even one of them. 

  • christopher274 Level 1 Level 1 (30 points)

    Can you put a profile on an unsupervised device after the 'Setup Assistant' on the device has been completed?

  • Rwickberg Level 1 Level 1 (0 points)

    How?  You can load profiles in the configurator under prepare, which is what doesn't work, and then under supervise, but only if the machines are supervised.

  • christopher274 Level 1 Level 1 (30 points)

    1. Create (or import) a profile in prepare mode.

    2. Check the profile to install it

    3. Set the iOS popup to 'No Change'

    4. Connect a device that has completed the setup assistant

    5. Press the 'Prepare' button.

     

    Results:

     

    A UI will be displayed on the device to confirm the profile installation.

  • SEG-IT Level 1 Level 1 (0 points)

    What I have done with Configurator:

    1. Setup one iPad.

    2. Gone through the setup assistant.

    3. Then installed profiles for wireless, passcode and webclips with Configurator.

    4. Then backed up that iPad with Configurator.

    5. Then used Configurator to deploy that image onto an iPad as unsupervised.

     

    The setup asisstant runs and the wifi worked, the passcode was requested and the webclips were on the desktop.

     

    Works for me ...

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.