Skip navigation

New Apple TV loses connection to iTunes 10.0.1

115036 Views 187 Replies Latest reply: Jun 7, 2013 6:42 PM by Rathbone Hall RSS
  • Troels Kolding Level 1 Level 1 (30 points)
    Currently Being Moderated
    May 9, 2012 3:23 AM (in response to olannes)

    Just another confirmation that in my case I don't believe it is down to ports.

     

    Simply restarting iTunes application on my iMac helps everytime and my ATV3 will then reconnect. I have to do it several times a week and it is really annoying.

     

    So I suspect either a software/firmware issue on the ATV3 client side or an iTunes application issue.

  • deodoro-filho Level 1 Level 1 (0 points)

    That's probably what bugs me the mosts:

     

    I don't know if that's the case for everybody, but for some of us the problem is clearly caused by the combination of iTunes and an extender. No extender, iTunes works fine, and when it crashes, a simple program restart makes things work again.

     

    My best hypothesis is that the traffic shape between iTunes and ATV makes the Airport Express behave badly momentarily and generate a few packets that crashes iTunes. Air Video does not interface with iTunes, that'd explain why it streams AirPlay correctly to the ATV in the same setup.

     

    Thus, IMHO, it's a problem in iTunes, probably because it's not ignoring some specific kind of error from the network. And these bad packets happen more often when you're using the extender.

  • arkoenne Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 12, 2012 9:37 AM (in response to deodoro-filho)

    Maybe the Apple TV firmeware update released just yesterday fixes the problem, see

     

    http://www.appletvhacks.net/tag/apple-tv-5-0-1/

  • Jerome Colas Level 2 Level 2 (215 points)
    Currently Being Moderated
    May 12, 2012 9:56 AM (in response to arkoenne)

    Sadly, I've been experiencing this since I replaced my ATV2 by an ATV3.

    After a few hours (basically each time I want to use my Apple TV!), I have to restart iTunes on my always-on Mac mini in order for it to work.

    Interestingly, not only the Apple TV has trouble connecting, but also iTunes from my MBP, which keeps displaying "looking for new purchases on Mac mini".

     

    Neither Mac OS X 10.7.4, nor the 5.0.1 update of the Apple TV software helped :-(

  • Mike5906 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 12, 2012 11:17 AM (in response to Toasty!)

    Just to confirm.  I too have this issue.

     

    I have four Apple TVs.  2 ATV2 and 2 ATV3.  They all lose connections to iTunes at the same time.  As does streaming to iPod, iPad and iPhone.

     

    Restarting iTunes seems to fix the issue.  I've had to get in a habbit of restarting iTunes before using my devices.  This has been going on since Wifi sync was added to iTunes and has continued in the last several versions.

  • Jerome Colas Level 2 Level 2 (215 points)
    Currently Being Moderated
    May 13, 2012 1:00 AM (in response to Mike5906)

    Trying to find what could be the culprit:

     

    - I have many mDNSResponder error messages in Console (mDNSResponder is the Bonjour process, used among other things for iTunes discovery) like

    13/05/12 09:50:43,261 mDNSResponder: Mac-Mini-de-Jerome-Colas.jcolas.members.mac.com.: bad signature

    13/05/12 09:50:43,261 mDNSResponder: hndlRecordUpdateReply: Registration of record Mac-Mini-de-Jerome-Colas.jcolas.members.mac.com. type 28 failed with error -65560

    - I was an iTools member migrated to dotmac, MobileMe and now iCloud. So I have a @mac.com address which now also works as @me.com. The @mac.com address is the one I use for iTunes home sharing. There were issues for mail migration from MobileMe to iCloud and I had to use the @me.com address instead of the @mac.com address in order fot Mail to work correctly. I am wondering f something similar is happening here.

     

    So, could anyone with AppleTV/iTunes connections problems please confirm whether :

    - they also have mDNSResponder error messages in Console

    - they use an old @mac.com address for home sharing

     

    Thanks in advace,

    Jerome.

  • patscanlan Calculating status...
    Currently Being Moderated
    May 14, 2012 11:41 AM (in response to Jerome Colas)

    I have been experiencing this issue for a while and I also have an @mac.com address from my previous MobileMe account which is now an iCloud account that I use for Home Sharing  I will have to check my console logs when I get home for any mDNSResponder errors, I will update later if I do.  Also just want to say that this has been an issue for me for some time, unfortunately I cannot remember which version of iTunes or the AppleTV software it started with.  Once I quit and reopen iTunes, Home Sharing works great, no drops or connection issues.  If I turn off my AppleTV though and go to watch it the next day, it will not reconnect to my iTunes library, I have to run upstairs and restart iTunes again.  Very annoying.  Hoping for a software fix soon.

     

    Pat

  • Jeff4Jeff Calculating status...
    Currently Being Moderated
    May 14, 2012 2:21 PM (in response to Toasty!)

    I wanted to use one to stream slides for an information board.  It would run for random amounts of time then stop.  I switched from wireless to a direct ethernet connection and it has been fine ever since.  A friend is experiencing the exact same behavior with his new one.  He has four older models that work fine wireless but the new one stops.  I randomly lost my connection to the homeshare computers as well when using wireless.

  • Mike5906 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 14, 2012 2:40 PM (in response to Jerome Colas)

    I am not using a .mac account.  I use my appleid which is my own email at my own domain.  I do not have dnsresponder errors in my logs.

  • Mike5906 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 14, 2012 2:41 PM (in response to Jeff4Jeff)

    All of my AppleTV's are hardwired ethernet to a Gigabit switch in the structured cabling room.  The Mac Pro running iTunes (and Lion) is plugged into the same switch on the same ASIC.

  • ZoobeeQ Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 16, 2012 1:42 PM (in response to Mike5906)

    For my set up (2 x Apple TV 3rd Gen - all wired -  4 x Airport Express - 3 wired and 1 wifi + Airport Extreme 5th Gen), even after the latest update to Apple TV firmware - my problem of iTunes hanging remains.

  • weewood Calculating status...
    Currently Being Moderated
    Jun 18, 2012 3:09 PM (in response to Toasty!)

    I'm having the same problem as you guys! I've read a lot of posts, and even though I'm new to Apple TV, I learned a bunch here. Everything worked just fine when the photos and music was on my desktop (windows PC, sorry), but after moving the data to my server, and using a notebook PC is when the problem started. It has run as long as 8+ hours without a hitch, but most of the time it fails about every 1/2 hour! Sure wish Apple would fix this.....

  • olannes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 21, 2012 2:19 PM (in response to weewood)

    I changed from dhcp to fix IP on all wifi devices : AirPort express, time machine, Apple Tv.

    I dont experience this problem of lost connection to iTunes anymore.

    I hope this may help you, the problem came from my internet DHCP routeur giving not always the same adress

  • patscanlan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 21, 2012 4:38 PM (in response to olannes)

    @ olannes

     

    I will try assigning a fixed IP to my Apple TV.  DHCP is being handled by my Time Capsule right now and both my iMac and Apple TV are connecting using ethernet.  My iMac already has a fixed IP assigned using a DHCP IP reservation based on MAC address through the Time Capsule settings.  I will assign one to the AppleTV as well and see if it changes the behavior.  Thanks for the suggestion.

     

    Pat

  • ZoobeeQ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 21, 2012 4:48 PM (in response to olannes)

    @ olannes

     

    All my devices (2 x AppleTV3, and 4 x Airport Express) have static IPs...  I still have to do either one of the two things:

     

    1) Restart iTunes

    2) Restart AppleTV3

1 ... 7 8 9 10 11 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.