Skip navigation

iPhone uses wrong exchange account for outbound email

11807 Views 25 Replies Latest reply: Jun 12, 2013 11:52 AM by Arderr RSS
1 2 Previous Next
brent654 Calculating status...
Currently Being Moderated
Feb 1, 2012 9:24 AM

I have two Exchange accounts that I need to keep separate. I cannot figure out how to get iOS to not send ALL outbound emails through one of the accounts. If I'm in Exchange account "A", I want outbound emails to go out through A... if in B, then B. This use to work fine but now all outbound email goes through account A.

 

In the email, I can set the account, but regardless of the account I choose, it always goes out from account "A".

 

Any thoughts on how to solve?

iPhone 4S, iOS 5.0.1
  • MessagingTech Level 1 Level 1 (40 points)

    Under Settings>Mail,Contacts,Calendar change the default account to the one you want to always send email form.  You can change it on an individual basis to send emails from the other account if you need/want to

  • MessagingTech Level 1 Level 1 (40 points)

    So when you go into the Sent Mail for the sent from account (assuming the wrong account) that email is in there? 

  • MessagingTech Level 1 Level 1 (40 points)

    Are you using the combined inbox view or are you going into Inbox A, composing the messaging and it still goes into the sent folder of mailbox B?  Have you also checked the sent folder in exchange and is the message still in the wrong sent box?

  • sebas71 Calculating status...

    I had the same issue just now.. Couldn't figure out what went wrong.

     

    I have two accounts, one of them being gmail. All my outbound mail was being sent from that account even though all my settings were correct. I even switched off all alternative smtp servers (for each account) to be sure.

     

    Then I remembered I recently changed my other account's mailbox password. When checking I discovered I only adjusted the pop3 password accordingly (since it's more visible when you dive into your mailbox settings on iPhone). I never thought of checking the smtp settings. That did it for me..

     

    Hope this helps..

     

    iPhone 3GS iOS5

  • Jason_Ward Calculating status...
    Currently Being Moderated
    Mar 21, 2012 10:06 AM (in response to sebas71)

    When typing an email (replying or whatever) you will see the "Cc/Bcc, From" field at the top of the message.  If you tap on that field it will expand letting you see each of those individual areas.  The "From" portion will be automatically popluated with the default account.  If you tap on it you will be provided with a list of all of the available accounts that the phone has configured.

     

    Choose the account you want the email to originate from and enjoy the rest of your day.

  • brunsona Calculating status...

    Same problem here, same situation - two accounts on one iPhone. No matter which acct used for sending all outbound emails had account "A" for address. I checked all the options in settings and in the email send for choosing the correct account but all email was delivered from "A" no matter what.

     

    I discovered that the default "A" account was setup for SMTP but the "B" account did not have SMTP validated. It showed a password but it also showed account "A" as a secondary SMTP server.

     

    I took account "A" off account "B" as a secondary SMTP server. The next email sent from "B" required a password. When I opened settings, completed the password for "B" and the SMTP server validated.

     

    Now email sent from "A" is delivered from "A", email from "B" is delivered from "B".

     

    Thanks for pointing me to the solution!

  • Lisa88c Calculating status...

    I am having the same issues also. When I send an email from my account A  (Exchange email account) a copy of the email is now being saved to the sent folder of my Hotmail Exchange sent folder and not to the account A folder.   The default account under settings is set to Account A. 

     

    The only way I can ensure that a copy of my email is saved to the correct account folder is to ensure to deactivate my hotmail account before sending an email from my Account A.

     

    Is there a way to fix this issue so that copies of sent emails are saved in the "sent folder" of the account they are sent from.

  • Becca D Calculating status...

    I am having the same issue. I called apple support and they seemed unaware of this problem. I have to disable a gmail account to send emails through my work email acocunt, otherwise the emails will be sent from my personal gmail acocunt. The problem is embarassing on a professional level. I have attempted to resolove the issue with the suggestions above but nothing is working. My phone is updated.

    One strange thing I noticed, despite making my work email the default address, the phone has determined that  my personal gmail account is the "home" email address- strange as the address is not associated with any contacts in my address book etc. Dont know why the phone would designate the acct as home.

    My phone is a 4S and brand new, I previously had a 4 and NEVER had any issues.

  • RaslDasl2 Calculating status...

    I'm having the same issue since I added an Outlook.com address. The problem may stem from the fact that my Microsoft ID is my gMail address. I think the phone is confused because the login ID for both gMail and Outlook.com is the same.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.