4 Replies Latest reply: May 10, 2012 2:14 PM by Inigodiaz
Inigodiaz Level 1 Level 1 (0 points)

Hi, i just got an iphone 4 handmedown from my brother. The iphone was restored to factory settings so it would be new for me. I set up my iphone and put sim in it. The diplay on the iphone says that there is no service. I have no idea how to fix this i have tried two different sims, toggling the airport button, restoring it, turning it on and off. i have no idea how to fix this. i have done nothing to the phone but turn it on, restore it and update it. I dont understand why it doesnt work considering it was working a week ago. I have updated the software to 5.1.1 and still nothing. I have no idea what to do considering i have tried everything and i really dont want to go all the way to the apple store which is really far way.


iPhone 4, iOS 5.1.1
  • 1. Re: No Service on iPhone 4
    randers4 Level 9 Level 9 (57,225 points)

    Do you have an iPhone plan with your carrier?  Most require data plans and offer service plans specific to iPhones, so not just any SIM will work (even if it's from the same carrier).  If you do, contact your carrier to see if your plan is provisioned correctly.  If it is, you may have a bad SIM.

  • 2. Re: No Service on iPhone 4
    Inigodiaz Level 1 Level 1 (0 points)

    yeah i have the iphone plan and i have contacted my carrier and they didn't say much. i have also tried the phone with a different sim so its not the sim. thanks for the reply though!

  • 3. Re: No Service on iPhone 4
    randers4 Level 9 Level 9 (57,225 points)

    Then you might have to restore it as new, which replaces the iOS with a fresh copy.  (Unless that's what you meant by "restored to factory settings".  Restoring is different from Erase All Content & Settings.)  If it still doesn't work after restoring as new, and your carrier has nothing to say on the subject, then you have no choice but to take it to the Apple store for evaluation.

  • 4. Re: No Service on iPhone 4
    Inigodiaz Level 1 Level 1 (0 points)

    yeah i've restored twice now, set it up a new phone and nothing. i guess i'll have to take it to the apple store. thanks for your help and anyways.