Skip navigation

iMessages saying sent from my Apple ID not Phone number...?

313 Views 2 Replies Latest reply: May 10, 2012 7:44 PM by 4noble1 RSS
LaineyNZ Calculating status...
Currently Being Moderated
May 10, 2012 7:34 PM

I'm successfully sending and receiving iMessages however recipients are saying that they are coming from my Apple ID rather then my phone number.  Is there are way to coprrect this?

iPhone 4S
  • randers4 Level 9 Level 9 (53,165 points)

    Go to Settings>Messages>Receive At.  If you phone number is listed there then go to Caller ID and select your phone number instead of your email address.  If your phone number isn't listed in Receive At then your number is not yet registered with the iMessage server and you will probably see "waiting for activation" listed under iMessage.  You may also not have the Caller ID setting until your number is registered.

  • 4noble1 Level 1 Level 1 (30 points)

    I wouldn't call this a problem, more of a choice. If you leave it alone as you can see that your messages are being sent and received using the phone. However, if you want to imessage an ipad then leaving the "receive at" set to your apple id email is I believe the only option. To my knowlege this is the reason for the options.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.