Skip navigation

Invalid Certificate on every secured website

186779 Views 125 Replies Latest reply: Apr 3, 2014 3:19 PM by Krag RSS
1 2 3 ... 9 Previous Next
sébastienfromquebec Level 1 Level 1 (0 points)
Currently Being Moderated
May 10, 2012 12:56 PM

Hi,

 

I've just updated to 10.7.4 with Safari 5.1.7 and after the update I'm always getting an Invalid Certificate for secured website.

 

www.paypal.com

every banking sites

etc

 

The content is not entirely loaded even if I click "continue".

 

I don't know if it related but I can't install any Extensions in Safari. I had ClickToFlash and 1Password and neither can be reinstalled after the update. I got a message telling me that the extension cannot be installed.

 

Thank you

MacBook Air, Mac OS X (10.7.4)
  • Linc Davis Level 10 Level 10 (107,540 points)

    Are the current date (including the year) and time shown on your system clock? If not, correct them and try again.

     

    Otherwise, launch the Activity Monitor application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Activity Monitor in the page that opens.

     

    Select All Processes from the menu in the toolbar, if not already selected. Enter "ocspd" (without the quotes) in the "Filter" text field. Is a process with that name listed?

     

    If not, select Go ▹ Go to Folder… from the Finder menu bar. In the text box that opens, enter

     

    /var/db/crls

     

    From the folder that opens, move these two files to the Trash:

     

    crlcache.db

    ocspcache.db

     

    You’ll be prompted for your administrator password when you do this. Then reboot, empty the Trash, and try again.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    [If this doesn’t work, it’s something like “LittleSnitch” or “Hands Off.” Test in safe mode.]

  • Linc Davis Level 10 Level 10 (107,540 points)

    Yes.

  • marc from white river junction Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 11, 2012 6:53 AM (in response to Linc Davis)

    Hi Linc,

     

    I'm experiencing the same issue, but I'm not behind any proxy.  The problem first occurred when I updated to OS X 10.7.4 and Safari 5.1.6 and the problem remains after upgrading to Safari 5.1.7.  I do not have Little Snitch or anything similar installed.  System date and time are correct, "ocspd" appears in Activity Monitor.  I have deleted the two .db files in /var/db/clrs as indicated with no effect.  Any ideas?

  • Linc Davis Level 10 Level 10 (107,540 points)

    It's working for me.

  • Linc Davis Level 10 Level 10 (107,540 points)

    No.

  • Mac Admin1 Level 1 Level 1 (0 points)

    I have(had) the same issue, Davis was right, ocspd was not running after update to 10.7.4.

    After performing the suggested steps the issue with Safari disappeared - almost... still, often I have to reload the https page because it would not finish loading by itself. But at least I'm not getting the certificate warning anymore.

     

    However, the certificate warning in Mail.app remains each time I launch it:

     

    Mail can't verify the identity of exampledomain.com

     

    I have the required certificates in my keychain and they are set to always trust.

    I have a couple of  email addresses hosted on different email servers. Mail.app does not complain on ones hosted by gmail for example,

    but it does on 2 other email addresses that are hosted by Communigate Pro email server.

     

    Let me note this is happening since updating to 10.7.4, never had this before on 10.7.1-2-3

  • Robke Level 1 Level 1 (0 points)

    I'm having the same issue. I reset my keychain, removed crlcache.db and ocspcache.db, and rebooted.

    I'm also behind a corporate proxy.

     

    When I go to mail.google.com I get the 'invalid certificate' sheet: the issuer certifcate 'Thawte SGC CA' is marked as valid, but for the certificate 'mail.google.com' it says: 'This certificate has an invalid issuer'.

     

    This is since the upgrade to 10.7.4, so I guess something broke in the handling of proxy certificates. This is not only happening in Safari, but in most applications which connect via HTTPS (Twitter, Reeder, Google Notifier, …).

     

    I've submitted this as Bug ID# 11444256.

    Schermafbeelding 2012-05-14 om 13.17.00.pngSchermafbeelding 2012-05-14 om 13.17.05.png

  • dbajohn Level 1 Level 1 (10 points)

    Same problem with slight twist.  The error message in the invalid certificate is "This certificate cannot be used (unsupported key length).  Very annoying as I'm at work and cannot access some critical sites using Chrome.  Some work in Safari.  I cannot figure out a pattern of why one site works and another does not.  This definitly is related to the os/x 10.7.4 upgrade as I was working on some of these sites before upgrading this morning. 

     

    Any help would be appreciated.

1 2 3 ... 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.