8 Replies Latest reply: Jan 21, 2013 5:18 PM by onecuwldood
chris.cam Level 1 Level 1 (0 points)

OK, enabling autologin may not be universally applauded, but the family like this feature.

 

We have three macbooks and I'm using the workgroup manager (yes I migrated everything from Snow Leopard).  In the workgroup preferences, the "Enable automatic login" option in the Login options is enabled.

 

However, only two of the three Macbook have Automatic Login enabled.  These also had Automatic Login enabled under Snow Leopard.

 

Does anyone know how to force the other Macbook to enable Automatic Login?  This Macbook didn't have Automatic Login enabled under Snow Leopard and has Lion Server installed as it was my trial run before upgrading our server.


Mac mini, Mac OS X (10.7.4), Mac mini server
  • 1. Re: Enabling Autologin
    gracoat Level 3 Level 3 (660 points)

    Try creating a new local user on that macbook.  Make sure it's an Administrator User. 

    Try setting auto log in for that new user.

    Log in as that user and see if you can change the auto login to the desired user.

    HTH

     

    -Graham

  • 2. Re: Enabling Autologin
    chris.cam Level 1 Level 1 (0 points)

    The whole auto login option is greyed out.  It isn't a matter of not being able to select the user, the whole option is greyed out.

     

    I discovered the iMac is in the same situation.  The workgroup manager profile shows that autologin is enabled.  I deleted the iMac from the workgroup manager, created a new profile manager profile, also allowing autologin.  I then subscribed the iMac to the profile (never used profile manager before).  In the control panel, it shows the profile has "Disable autologin" as False, but the autologin option is still greyed out!

  • 3. Re: Enabling Autologin
    Christy1685 Level 1 Level 1 (0 points)

    What you are going to have to do is log in as a root user, To do so follow the below link:

     

    http://support.apple.com/kb/HT1528

     

    Then when you are logged in as root go to the accounts and enable automatic login for the user account you use, it wont be greyed out when you are logged in as a root user.

     

    Once your done log back into your account and disable the root user account the same way you enabled it. The enable (where you selected before) will now show disable.

     

    Hope this helps

     

    NB. just in case: after you log out select OTHER and type root as username and whatever password is the default (or what you just choose if you enabled root for the first time).

  • 4. Re: Enabling Autologin
    chris.cam Level 1 Level 1 (0 points)

    Sorry, do not pass go, do not collect $200.  Using root doesn't allow autologin to be turned on!  Thanks for the suggestion.

     

    There must be something low level that Work Group Manager sets or resets that hasn't been reset correctly when the option has been enabled there!

     

    I'll keep digging.

  • 5. Re: Enabling Autologin
    chris.cam Level 1 Level 1 (0 points)

    Suddenly had a thought to look at one of the MacBooks where Auto Login worked!

     

    I looked at the com.apple.loginwindow defaults and found that they had autoLoginUser set.  I set that and rebooted.  No change, but now the AutoLogin option was active in the User and Groups preferences!

     

    Set the preference and all is good now!

     

    But it hasn't solved the problem on the iMac.  That one had the autoLoginUser set, but it still isn't working!!!!

  • 6. Re: Enabling Autologin
    tingo Level 1 Level 1 (0 points)

    Maybe a bit late but I had the same problem and I have just discovered that you need to disable Firevault in Security & Privacy preference.

     

    Peace and love

  • 7. Re: Enabling Autologin
    WarrenO Level 1 Level 1 (10 points)

    Perfect. Perfect, that was it! For me, anyway.

  • 8. Re: Enabling Autologin
    onecuwldood Level 1 Level 1 (0 points)

    My wife and I just got new MacBook Pros. Mine was logging in automatically, her's was not. I finally got her's to do it!

     

    I simply set hers to "not" login automatic and restarted. Then went back in and set it to auto again, restarted and BINGO! It works now.

     

    I hope yours is as easy...