Skip navigation

How do I tell Lion to disable the LCD screen even when the lid is open?

106606 Views 383 Replies Latest reply: Dec 20, 2013 6:34 PM by louisinhongkong RSS Branched to a new discussion.
  • BluegillOnTheFly Calculating status...

    Didn't work on my machine (MBP 5,3 Boot ROM MBP53.00AC.B03, 10.7.3). Still looking for a workaround better than that magnet trick (work computer, not home). This whole experience has frosted me so much that when I ordered a new computer for home use the other day, I went with a high-end HP rather than a Mac. I've got 3 MBPs and 2 iPhone 4s at home, and it's not 4 MBPs because of this Lion bug.

  • BluegillOnTheFly Level 1 Level 1 (0 points)

    Update: it worked sort of, but doesn't really get back the SL behavior.


    Under SL, the machine would wake up when I plugged in any USB device. Now, both USB headphones and a USB HDD failed to wake it up. I happened to have a USB keyboard around I plugged that in. Hitting a key on the keyboard woke up the machine and the internal display remained dark after I opened it.


    Better than nothing, but far short of what Apple should have done here. This bug - I can't imagine anyone could look at it with a straight face and call it a feature - has existed far too long without Apple releasing a fix. Especially since it would be so easy to fix, they should be ashamed.

  • robbmasters Calculating status...

    blizzfire wrote:




    the command: sudo nvram boot-args="iog=0x0"

    doesn't work on my MacBook Pro Early 2010 running the new OS X Lion version 10.7.3 (and yes, I restarted after entering the above command).


    Maybe it's because of the latest update to version 10.7.3? Does anybody know if it still works there?




    Finally got round to trying this fix on my late 2011 MBP, but it made no difference here either. I'm also on 10.7.3. So maybe Apple have broken the fix in the latest update...


    PS Thanks for the link, "peterd_". Have emailed them...

  • RobertCailliau Level 1 Level 1 (0 points)


    Do you know of a setting that will tell the external screen to go to sleep?

    The machine sleeps, lid closed, but the Cinema display's light is still on permanently.

    I.e. the screen light itself does not "breathe", so I have no indication about the sleep state, since my laptop is hidden behind the screen.

  • Godoy12 Calculating status...

    So, for Lion users, it's possible to just use the external display with the lid open:


    1. In Mission Control Preferences activate one Hot Corner to put the display to sleep.


    2. Connect the external monitor and plug in the power source to your computer.


    3. Move the mouse to the Hot Corner to put the display to sleep.


    4. Close the lid and wait a few seconds.


    5. Open the lid and voila!


    Take care!

  • r_marshall Level 1 Level 1 (0 points)

    Godoy12 -- it's brilliant!


    Why on earth does this work? I would have thought closing the lid would simply put the laptop to sleep, and then the subsequent wake would invoke both the internal and external displays to turn back on.


    Is this trick exploiting a "lag" between the internal display turning off and the machine going fully into sleep? (Have you tried it with different timings to see how the "wait a few seconds" affects the result?


    This solutions is weird, doesn't make logical sense, and my be a little hard to remember, but hey, it freaking works!


    Thank you for figuring this out and posting Godoy12!


    I will definitely be reposting elsewhere...

  • moptopcanada Calculating status...

    Is the magnet trick not much simpler?


    Open the laptop with both monitors on, find the display sleep magnet area on the laptop (mine is just in front of the Superdrive on the right hand side, place a fridge magnet over top of it, and the internal display sleeps while the external display remains on.


    This way you can switch back and forth as often as you like without unplugging anything.

  • stkmks Calculating status...

    I've been staring at this post for a long time, and finally tried the magnet trick today.. it works great, luckily with a fairly weak magnet from the fridge. Note on a 2009 17 inch mbp at least, the magnet area is just under the speaker on the -right- side.


    I really, sincerely hope this will be better done in mountain lion. Either the old behavior or a setting somewhere to customize it. Even in an air conditioned lab at apple, its absolutely nuts that they wouldn't have noticed any heat issues with the lid closed and any gpu intensive app running. That's just nuts. My first 15 inch macbook from 2006 developed blotches on the lcd from running games in closed mode..


    Anyways. My current laptop is an older 2009 17 inch mbp. I'm also running an external 30 inch monitor (at 2560x1600). The old 9600m just doesn't cut it for having both displays turned on and moden apps.. at least for me.


    Anyways, i really hope this is fixed.  Another one to its pure fiction that there are no heat issues when running load with the lid closed.

  • Globehun Calculating status...

    Perfect!!! Thx a lot!

  • marionlc Calculating status...

    I have the opposite problem!


    When I was on SnowLeopard, I was eager to use both my external monitor and my laptop's monitor - I need all the space to move different items around.  If I had occasion to close the "clamshell", to go do something else, I would shut the lid, and the laptop would go to sleep.  Then when I opened the lid again, I'd get both displays, the way I needed it.


    Now, on Lion, when I close the lid the darned external monitor stays on - and the display shifts so that only the external monitor is active - which is useless, since I can't access the keyboard with the lid down.


    And when I open the lid again, I ONLY have the external monitor - and I have to "detect displays" all over again to get back the laptop's monitor.  What a waste of time!  How can I achieve the "problem" you're complaining about?

  • marionlc Level 1 Level 1 (0 points)

    How can I reverse your "bug report"?  I WANT - I NEED - both monitors to stay open, but my laptop display shuts off if I close the lid, and it doesn't come back when I raise the lid.

  • Godoy12 Level 1 Level 1 (0 points)

    As far as I'm aware you have two options:

    Either you click on the Apple logo and select Sleep (or arrange the shortcut of your preference) and then close the lid if you want, or you disconect the power source when you leave and close the lid (the computer goes to sleep if the power is not connected).


    Hope it helps!

  • FORESTCY Calculating status...

    That's right. It's exactly what I want. This is my conclusion:

    1. If you want to use an external monitor and the MBP's keyboard, then follow Daromirr's method. Turn off Mirroring, Go to Systerm Preferences - Displays - Arrangement, and relocate the menu bar (the white band on top of the display) on the external monitor. The menu bar indicates that which display is the main one, where the Dock, desktop and all apps are shown, except System preferences. Then you can turn down the brightness of your internal monitor to be black.
    2. If you want to use an external monitor, keyboard and mouse, then just stay in Lion. Don't need to go back to pre-Lion. Under the Mirroring being off and the external monitor being plugged in, every time when you close the lid, the system will still be on, not sleep, and the external monitor will become the main display (the desktop including everyting on it and the Dock will move to it). Thus, you just use your keyboard and mouse and continue your work.


    Hope this can help you.

  • SciArtist Calculating status...

    Well, holy cow. I've been using a Mac for illustration over 7 years now, and never realized I could simply move the menu bar to my larger Cinema HD display. I've been looking through this thread, with the same problem as most everyone after having updated to Lion, not understanding why I can't just leave my laptop's screen black while using my larger display on illustration work. This won't let me darken the laptop screen, but at least I can dim it. Thank you, Forestcy!


    It's still ridiculous that Apple changed this mechanism at all, or that they pretend to not understand why it's useful. Get with the program, Apple. We all expect more of you.

  • Bill In CO Calculating status...

    Re: Godoy12's suggested solution using hotcorner to sleep display: This does not work on my 2011 air. When I reopen the lid, the screen "resets" and simply turns the internal display back on.


    Either more instruction is needed, or this doesn't work on the Air (or possibly doesn't work under Lion 10.7.4).

1 ... 15 16 17 18 19 ... 26 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (19)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.