Skip navigation

Lion:WiFi not autoconnecting after sleep mode

110197 Views 131 Replies Latest reply: Mar 15, 2014 7:50 AM by jason_81 RSS Branched to a new discussion.
  • Marcelo NS Level 1 Level 1 (40 points)
    Currently Being Moderated
    Apr 12, 2012 1:48 PM (in response to Aismaiil)

    Lucky you Aismaiil that you could solve the issue. The steps you described helped me only for some time. As soon I move with my Air to other location (for example to one of my client's office) the problem comes back. I like my MBA but this irritating issue, and specially the lack of Apple support in my country (The Netherlands) made me decide to switch back to PCs.  

  • Aismaiil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 12, 2012 1:55 PM (in response to Marcelo NS)

    Haha talk about lack of support, we don't even have apple stores in my country (Lebanon), let alone apple support. Anyway, I guess this problem is related to each internet connection individually, so since I reset everything and readded the connectiong I use such as the one at home and the one at my gf's house, I haven't had the problem here and there. Until I try it regularly somewhere else I won't notice if it worked completely, but i'll let u know!

  • dizm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 12, 2012 4:16 PM (in response to Aismaiil)

    Aismaiil: For me that solution only worked for a short time, after which the problem came back. This even on my iMac, which is always connected to the same wifi access point.

     

    One thing that has worked so far: disable "Allow Bluetooth devices to wake this computer" (System Preferences/Bluetooth/Advanced)

     

    If it's any consolation, here in New Zealand, we also have no Apple stores and no real support.

     

    I will say that none of this has ever tempted me to go back to that other brand.

  • garymansell Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 13, 2012 11:34 AM (in response to live4hills)

    I am not sure whether anyone else has noticed this but I have been suffering this problem for ages.

     

    Normally I just turn the wifi on and off a couple of times using the wifi icon on the menu bar until it reconnects again, but today I just shut the screen and opened it again and it re-connected immediately - much easier than having to try and reconnect using the icon...

  • Harpo Marx Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 13, 2012 2:21 PM (in response to garymansell)

    Follow these steps - it will fix the issue (After restarting or waking from sleep, my computer might not connect to the Internet) on the latest iMac with Lion 10.7.3:

     

    What we will do here is - first install the latest iMac Wi-Fi Update. Then remove our preferred network in network settings plus remove the stored network passwords from KeyChain Access Utility. Restart and rebuild our preferred network with password. Done. Please follow the instructions carefully.

     

     

    1) Download iMac Wi-Fi Update v1.0 here: Download

     

    This update resolves an issue that may cause an iMac to not automatically connect to a known Wi-Fi network after waking from sleep. February 24, 2012 - 25.81 MB

    http://support.apple.com/kb/DL1500

     

    2) (http://support.apple.com/kb/HT4628?viewlocale=en_US) - (slightly modified below)

     

    Symptom: After restarting or waking from sleep, my computer might not connect to the Internet

    • 1. Select the Wi-Fi tab and view your Preferred Networks list.
    1. Select each network and click the minus sign to remove those networks from your Preferred Networks list.


      => REMOVE ALL NETWORK - including your PREFERRED NETWORK (which is the very one you are having issues with)

    2. Click OK and close the Network preferences.

    2. Remove your stored network passwords using the Keychain Access Utility.

    1. Open Keychain Access from /Applications/Utilities. Your window will look like this:
    2. Remove your AirPort network passwords from the login keychain: Select the "login" keychain from the Keychain sidebar. Click the "Kind" column to order the list of keychain items by their type. Remove all entries of the kind: "AirPort network password".
    3. Remove your AirPort network passwords from the System keychain: Select the "System" keychain from the Keychain sidebar. Click the "Kind" column to order the list of keychain items by their type. Remove all entries of the kind: "AirPort network password".

      Note: The above steps will remove your Wi-Fi network passwords. If you do not know them, or if your network does not use passwords to restrict access, you should contact your network administrator.

    3. Restart your computer.

    4. Go to network settings / preferred networks and click the button to add your preferred network. Join your Wi-Fi network. You will need to enter your password for your network again if it requires one.

    Done.

    Click Sleep and wake it and it all will be fine!

  • OregonArtee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 13, 2012 5:02 PM (in response to Harpo Marx)

    Thank you for this thorough walk-through.  It seems to be working for me, for now.  It does take about 5 seconds after the screen wakes up for the computer wi fi antenna to find the base station signal, but once it does the connection is up and works normally.  2011 iMac running 10.7.3, with ActionTec PK 5000 base station

  • Harpo Marx Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 14, 2012 4:29 AM (in response to OregonArtee)

    OregonArtee,

     

    I'm glad it worked for you.

     

    About 5 seconds is normal behaviour.

  • OregonArtee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2012 1:15 PM (in response to Harpo Marx)

    Rats.  Spoke too soon.  Has worked fine for a day, but now the problem has reoccured, and was so jammed up it required a cold restart.  I'm back to closing mail and firefox before putting the computer to sleep, and waking it up by the power button.  that sequence seems to work the best.  My iMac is too far from the base station to hard wire, but I have an old usb mouse and keboard around someplace, so I'm going to hook them up and see if that helps (some folks have blamed the bluetooth).

  • Aismaiil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2012 1:40 PM (in response to Harpo Marx)

    I think Harpo Marx's tip combined with mine should do the trick, at least it makes sense! i haven't had a problem for months now, and I forgot to mention I also did Harpo Marx's steps such as deleting all the password from the keychain, so basically i literally returned everything to its factory settings as if the laptop was right out of the box and also reset my router so as to get a clear new signal on a new channel n have the laptop pick it up directly. Has anyone tried to do all of my steps combined with Harpo Marx's yet and had any luck??

  • joshuafromauburn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 16, 2012 6:34 PM (in response to live4hills)

    It may be a problem with the connection information stored in your network profile.

    1. Go to System Preferences > Network.
    2. Click the Wi-Fi connection.
    3. Click the Advanced... button on the bottom right.
    4. Click the Wi-Fi tab.
    5. Under Preferred Networks, select your wireless network.
    6. Click the - (delete) button.
    7. Turn off your Wi-Fi connection.
    8. Turn it back on.
    9. Select and login to your wireless network. This will re-save your connection under Preferred Networks.
    10. Close your laptop and reopen it to test whether it worked.
  • marc.45 Level 1 Level 1 (0 points)
  • Mastory Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2012 8:22 PM (in response to live4hills)

    I didnt get to go through all the threads to check if this solution was suggested, either way that is what i found out. I started having this problem after leaving the Bluetooth ON on my macbook pro (early 2011). Obviously, for iMac users, the bluetooth has to remain ON for the keyboard and mouse to function. I noticed that in the hierarchy of connection hardware, the Bluetooth comes before Ethernet and WiFi, so when the computer recovers from sleep mode it will check the Bluetooth hardware first for connection before WiFi and that would explain the delay in finding the Preferred Network.

    So all what I did is moving the WiFi up in the hierarchy all the way to first position, and that solved the problem for me.

    Here how you can do that:

    1. Open Network Preferences.

    2. Under the list of Connection Hardwares (Bluetooth, WiFi, Ehternet), click on the drop down Option Menu and select Set Service Order.

    3.Drag the WiFi all the way up or both Bluetooth all the way down.

    4. Ok and Apply.

    Done !!

     

    Regards,

  • Toadyandfatty Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 12, 2012 9:26 AM (in response to Mastory)

    This worked for me. Thanks!

  • jwmartin83 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 21, 2012 6:17 PM (in response to live4hills)

    Just wanted to chime in--my issue seems to be resolved after repairing disk permissions on the Macintosh HD.  I tried creating a new network location, making sure Bluetooth was turned off, setting network service order, and recreating preferred networks--nothing seemed to work except reparing the permissions.

  • jwmartin83 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 21, 2012 6:27 PM (in response to jwmartin83)

    Well that was short lived. Repairing permissions was only a temporary fix. Back to the drawing board...

1 ... 5 6 7 8 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.