12 Replies Latest reply: May 31, 2012 7:21 AM by jamurdie
HZMD Level 1 Level 1 (0 points)

I installed 10.7.4 on an iMac that was running an 10.7.3, and which was updated only last weekend. After 10.7.4, the computer indicated I had to reboot. after the reboot, I hear the chimes, then only a gray screen. Nothing else. Tried safe mode by holding down shift key after chimes, but problem persists. Any ideas?

  • 1. Re: 10.7.4 upgrade bug - failure on reboot
    ivan.whm Level 1 Level 1 (15 points)

    I have the same problem, but in MacBook White.

  • 2. Re: 10.7.4 upgrade bug - failure on reboot
    HZMD Level 1 Level 1 (0 points)

    I believe I fixed it.

     

    Disconnect all peripherals

     

    Shut down computer for 10-20 minutes

     

    Reboot in safe mode (shift key after chimes)

     

    Run Disk Utilities to repair permissions twice.

     

    Update software once or twice (new Safari, then new Flash)

     

    Reboot

  • 3. Re: 10.7.4 upgrade bug - failure on reboot
    roger205 Level 1 Level 1 (0 points)

    This update hosed two Macs at my house.  First, an iMac, then a Macbook Air.  Neither computer could boot into any user account after using software update to download and install 10.7.4.

    I got both units operating again by downloading and reinstalling Lion from the web after booting using the Command-R startup method.

    Anyway, not sure why I had to go through all that, I do have a bit of an unusual setup I guess.  I run with FileVault enabled, the FIPS-enabled encryption package installed, and ESET A-V.

    I believe one or a combination of these specialities led to my problems but I can't be sure.  Mostly, I suspect the FIPS crypto package since downloading and reinstalling Lion left me without the FIPS package until I reinstalled it after confirming all was well.

    I would be interested to know if any others had similar issues.

  • 4. Re: 10.7.4 upgrade bug - failure on reboot
    innov8ion Level 1 Level 1 (0 points)

    I installed this update and can't boot into OS X any more. I had FileVault installed too. Have I lost all my data not backed up?

     

    I don't have AppleCare but Apple should support this seeing as their update broke my system. :/

  • 5. Re: 10.7.4 upgrade bug - failure on reboot
    jamurdie Level 1 Level 1 (10 points)

    I guess I should record my (unhappy) experience with 10.7.4 also.  I updated my 2010 iMac with no problem, but the update apparently bricked my 2011 MacBook Pro (with power adaptor connected). It rebooted for the first time after the update, showing the firmware boot white screen but then only a black screen. I waited half-an-hour for any change, but nothing happened. None of Cmd-R, D (diagnostic boot), NVRAM reset (Command-Alt-P-R for two chimes) or select boot image (Option key) had any effect, though I waited ten minutes or so after each attempt just in case anything happened.  I tried these things repeatedly, and then made a 10.7.4 install boot disc on the iMac from App Store using Disk Utility and tried to boot the Pro with C held down - again, just a black screen, and I couldn't get the DVD out with either eject or holding down the trackpad button when I powered up the Pro. Having the power supply connected or not made no difference. I made a Genius Bar appointment and left the Pro overnight.

     

    The next morning - having not touched the Pro since the day before - it booted first time at the Genius Bar (and I was able to remove the disc)!  Hardware diagnostics and disc checks showed nothing wrong.  I brought the Pro home where it once again repeatedly failed as before. I left it overnight once more, and now it boots again!

     

    I'm starting to suspect that I have a coincidental display hardware intermittent connection and if so, nothing to do with the 10.7.4.  Either that, or 10.7.4 has done something really bad to the machine.  Fortunately, I have an up-to-date backup.

  • 6. Re: 10.7.4 upgrade bug - failure on reboot
    innov8ion Level 1 Level 1 (0 points)

    Took it to the Genius Bar. They were curious that the diagnostic boot wouldn't work. I did show them that Cmd-R got me to Recovery. They reinstalled the OS and I was able to log in. Downloaded and installed the combo update to 10.7.4 and all was good. Didn't lose any data. Phew...

     

    They recommended  not to upgrade using Software Update. Apparently, combo update is the way to go. Now I know...

     

    Good luck, everyone.

  • 7. Re: 10.7.4 upgrade bug - failure on reboot
    jamurdie Level 1 Level 1 (10 points)

    I should have said that SMC resets do nothing to fix the problem for me, either. (Attach power, press Shift-Control-Option-Power, release and reboot.) I tried that from the start.  I'd also noticed from the start that when the Pro boots into a black screen, the power light is sometimes indicating 'sleep mode'.  Just once (but perhaps also when I visited the Genius Bar?), I've got the Pro to give me the login screen instead of the black screen by closing and reopening the lid.  This has usually had no effect on my problem.  Rebooting from the problem state simply causes the problem all over again - sometimes with the black screen I get the startup chime and a steady power light, other times there is the black screen, no chime and the power light fades and brightens to indicate sleep mode.

     

    I shall visit the Genius Bar once more.

  • 8. Re: 10.7.4 upgrade bug - failure on reboot
    jamurdie Level 1 Level 1 (10 points)

    And now, on the next day, I can't make the boot failure happen at all, after ten successful boot attempts over half-an-hour or so.  I'd done several apparently ineffective SMC resets yesterday and then left the Pro overnight (with power cable disconnected).  As I am unable to demonstrate the problem, I've cancelled the second Genius Bar appointment.  I can't rule out the possibility that the problem will reoccur, and it is so frustrating having an unreliable laptop for whose problem I do not even have a immediately effective work-around when it does occur.

  • 9. Re: 10.7.4 upgrade bug - failure on reboot
    creativeunit Level 1 Level 1 (0 points)

    After much nashing of teeth and rending of garments (read wasting time chasing white rabbits on Google--a lot of time), the fix for me was to evoke Lion recovery mode (hold down cmd-r during startup). I then chose the option to reinstall a fresh copy of Lion. Took forever to download (used the time to clean my office -thanks Apple!) , but followed the prompts, verified my account and then Lion did its thing, automatically downloaded a fresh copy and did the reinstall for me. Everything fixed.

     

    So...

    1. Shut down machine

    2. Restart while holding down cmd and the r key

    3. Follow prompts select install fresh copy of Lion

    4. Find something to do while it does it's thing

    5. Restart when done

    6. Check for updates

    7. Post fix to maybe help others

     

    Hope this helps someone.

  • 10. Re: 10.7.4 upgrade bug - failure on reboot
    Bruce Tsiknas Level 1 Level 1 (5 points)

    I  discovered the same fix as creativeunit. This was on a MacBook Pro. After Recovery Mode and Lion re-install I  updated back to 10.7.3, then disabled Software Updates, which I do not like to do. I spoke with an Apple Tech who couldn't help but said he'd report it.

  • 11. Re: 10.7.4 upgrade bug - failure on reboot
    jamurdie Level 1 Level 1 (10 points)

    After the ten consecutive good restarts, I left the Pro for a couple of hours, and then had almost two days of consecutive boot failures - despite repeated SMC resets which made no difference. Then this morning, after having left the machine untouched overnight once more, I tried another SMC reset (With machine powered off, attach power, hold shift-control-option-power for a few seconds, then release them at the same time and turn the Pro on again) and a reboot with Cmd-R (recovery) and it worked!  I was able to try a Lion reinstall from Apple - expecting 10.7.4, but I got 10.7.3. I then used Software Update to get 10.7.4 successfully but noticed that Safari was still at 5.1.6. I then ran Software Update again expecting to be able to update Safari 5.1.6 to 5.1.7, but no update was provided, so I downloaded the manual update for Safari 5.1.7, whose install succeeded.

     

    If I write nothing more here, assume that it 'just works' for me from now on. The Pro was new in December, and hasn't been ill-treated in any way.

  • 12. Re: 10.7.4 upgrade bug - failure on reboot
    jamurdie Level 1 Level 1 (10 points)

    After a further two weeks of intermittent failures of the same kind - black screen on boot - I finally took the Pro to the nearest Apple Store Genius Bar. They commented that an 'archive reinstall' such as I had done wasn't always enough to fix this kind of problem, and did a full reinstall (of 10.7.3) for me. I brought the Pro home and have used Software Update to update to 10.7.4 once again. Fingers crossed!